summaryrefslogtreecommitdiff
path: root/packages/javasqlite/javasqlite-mkconst-native_20080130.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
commit12f8a39939c28003a39b84713d9a51305511650d (patch)
tree2235c3d2a30eac66c0319b7cff55928990c89bbd /packages/javasqlite/javasqlite-mkconst-native_20080130.bb
parent058132b8be45ac2041a574782b8800c1956e44d3 (diff)
parentfcbe107913b10643d1ba8ac137de273e12e8854a (diff)
merge of '470ca3fe64c9411d3a7d992db39d5efbed869839'
and '912f388483a3e1703ca89d7b2309723fd3407420'
Diffstat (limited to 'packages/javasqlite/javasqlite-mkconst-native_20080130.bb')
-rw-r--r--packages/javasqlite/javasqlite-mkconst-native_20080130.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/javasqlite/javasqlite-mkconst-native_20080130.bb b/packages/javasqlite/javasqlite-mkconst-native_20080130.bb
new file mode 100644
index 0000000000..e6f9a8e1ae
--- /dev/null
+++ b/packages/javasqlite/javasqlite-mkconst-native_20080130.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "mkcons program needed for javasqlite build"
+HOMEPAGE = "http://www.ch-werner.de/javasqlite"
+LICENSE = "BSD"
+
+DEPENDS = "sqlite-native sqlite3-native"
+
+SRC_URI = "\
+ http://www.ch-werner.de/javasqlite/javasqlite-${PV}.tar.gz \
+ file://build-fix.patch;patch=1"
+
+S = "${WORKDIR}/javasqlite-${PV}"
+
+inherit autotools native
+
+# Program names are there to fool configure checks
+# because we actually do not need these.
+EXTRA_OECONF = " \
+ --with-sqlite-incdir=${STAGING_INCDIR} \
+ --with-sqlite-libdir=${STAGING_LIBDIR} \
+ --with-sqlite3-incdir=${STAGING_INCDIR} \
+ --with-sqlite3-libdir=${STAGING_LIBDIR} \
+ --with-jardir=${datadir_java} \
+ --with-native-libdir=${libdir_jni} \
+ --with-java='echo version 1.5' \
+ --with-javac=true \
+ --with-jar=true \
+ --with-javah=true \
+ --with-javadoc=true \
+ "
+
+do_configurepre() {
+ sed -i -e "s|wrong-libtool|${BUILD_SYS}-libtool|" Makefile.in
+}
+
+addtask configurepre after do_patch before do_configure
+
+
+do_compile() {
+ oe_runmake native/mkconst
+}
+
+do_install() {
+ :
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 native/.libs/mkconst ${STAGING_BINDIR}/javasqlite-mkconst-${PV}
+}
+
+PACKAGES = ""
+