summaryrefslogtreecommitdiff
path: root/packages/ixp4xx/ixp4xx-npe_2.3.2.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-04-27 23:10:35 +0000
committerRod Whitby <rod@whitby.id.au>2007-04-27 23:10:35 +0000
commite4ef03e2e6dd41f5fb5aacfc2f0be46e41719e7f (patch)
treeb927d5918be6b1865025927be2a1dce29be3af44 /packages/ixp4xx/ixp4xx-npe_2.3.2.bb
parentbdec7852733fc02671fef077955822164ce2857f (diff)
ixp4xx-npe: Updated to microcode version 2.3.2
Diffstat (limited to 'packages/ixp4xx/ixp4xx-npe_2.3.2.bb')
-rw-r--r--packages/ixp4xx/ixp4xx-npe_2.3.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/ixp4xx/ixp4xx-npe_2.3.2.bb b/packages/ixp4xx/ixp4xx-npe_2.3.2.bb
new file mode 100644
index 0000000000..3a13074240
--- /dev/null
+++ b/packages/ixp4xx/ixp4xx-npe_2.3.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
+LICENSE = "Intel Public Licence"
+PR = "r0"
+DEPENDS = "ixp4xx-npe-native"
+
+# You need to download the IPL_ixp400NpeLibrary-2_3_2.zip file (without crypto) from:
+# http://www.intel.com/design/network/products/npfamily/ixp400_current.htm
+# and put it in your downloads directory so bitbake will find it.
+# Make sure you *read* and accept the license - it is not a standard one.
+
+SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
+S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
+
+COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
+
+FILES_${PN} = "${base_libdir}/firmware/NPE-B"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/IxNpeMicrocode-${PV} -be
+}
+
+do_install() {
+ install -d ${D}/${base_libdir}/firmware/
+ rm ${S}/NPE-B
+ mv ${S}/NPE-B.* ${S}/NPE-B
+ install ${S}/NPE-B ${D}/${base_libdir}/firmware/
+}
+
+do_populate_staging() {
+ install -d ${STAGING_FIRMWARE_DIR}
+ install ${S}/NPE-B ${STAGING_FIRMWARE_DIR}/
+}
+