summaryrefslogtreecommitdiff
path: root/packages/ixp4xx/ixp-osal-2.1.1
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/ixp4xx/ixp-osal-2.1.1
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/ixp4xx/ixp-osal-2.1.1')
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/2.6.patch143
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch30
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/assert.patch41
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/invalidate-cache.patch115
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/ixp4xx-header.patch115
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/le.patch72
6 files changed, 0 insertions, 516 deletions
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/2.6.patch b/packages/ixp4xx/ixp-osal-2.1.1/2.6.patch
deleted file mode 100644
index 9725b447c8..0000000000
--- a/packages/ixp4xx/ixp-osal-2.1.1/2.6.patch
+++ /dev/null
@@ -1,143 +0,0 @@
- os/linux/src/core/IxOsalOsMsgQ.c | 2 +-
- os/linux/src/core/IxOsalOsSemaphore.c | 6 +++---
- os/linux/src/core/IxOsalOsServices.c | 20 ++++++++++++++++----
- os/linux/src/core/IxOsalOsThread.c | 7 +------
- 4 files changed, 21 insertions(+), 14 deletions(-)
-
---- ixp_osal/os/linux/src/core/IxOsalOsMsgQ.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/core/IxOsalOsMsgQ.c 1970-01-01 00:00:00.000000000 +0000
-@@ -45,9 +45,9 @@
- * -- End Intel Copyright Notice --
- */
- #include <linux/linkage.h>
-+#include <linux/spinlock.h>
- #include <linux/ipc.h>
- #include <linux/msg.h>
--#include <linux/spinlock.h>
- #include <linux/interrupt.h>
-
- #include "IxOsal.h"
---- ixp_osal/os/linux/src/core/IxOsalOsSemaphore.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/core/IxOsalOsSemaphore.c 1970-01-01 00:00:00.000000000 +0000
-@@ -46,7 +46,7 @@
- */
-
- #include <linux/slab.h>
--#include <asm-arm/hardirq.h>
-+#include <linux/hardirq.h>
- #include "IxOsal.h"
-
- /* Define a large number */
-@@ -93,7 +93,7 @@ ixOsalSemaphoreWait (IxOsalOsSemaphore *
- {
-
- IX_STATUS ixStatus = IX_SUCCESS;
-- UINT32 timeoutTime;
-+ unsigned long timeoutTime;
-
- if (sid == NULL)
- {
-@@ -261,7 +261,7 @@ ixOsalMutexInit (IxOsalMutex * mutex)
- PUBLIC IX_STATUS
- ixOsalMutexLock (IxOsalMutex * mutex, INT32 timeout)
- {
-- UINT32 timeoutTime;
-+ unsigned long timeoutTime;
-
- if (in_irq ())
- {
---- ixp_osal/os/linux/src/core/IxOsalOsServices.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/core/IxOsalOsServices.c 1970-01-01 00:00:00.000000000 +0000
-@@ -54,6 +54,7 @@
- #include <linux/time.h>
- #include <linux/sched.h>
- #include <linux/slab.h>
-+#include <linux/interrupt.h>
-
- #include "IxOsal.h"
-
-@@ -89,7 +90,7 @@ static IxOsalInfoType IxOsalInfo[NR_IRQS
- /*
- * General interrupt handler
- */
--static void
-+static irqreturn_t
- ixOsalOsIsrProxy (int irq, void *dev_id, struct pt_regs *regs)
- {
- IxOsalInfoType *isr_proxy_info = (IxOsalInfoType *) dev_id;
-@@ -98,6 +99,7 @@ ixOsalOsIsrProxy (int irq, void *dev_id,
- "ixOsalOsIsrProxy: Interrupt used before ixOsalIrqBind was invoked");
-
- isr_proxy_info->routine (isr_proxy_info->parameter);
-+ return IRQ_HANDLED;
- }
-
- /*
-@@ -105,11 +107,12 @@ ixOsalOsIsrProxy (int irq, void *dev_id,
- * This handler saves the interrupted Program Counter (PC)
- * into a global variable
- */
--static void
-+static irqreturn_t
- ixOsalOsIsrProxyWithPC (int irq, void *dev_id, struct pt_regs *regs)
- {
- ixOsalLinuxInterruptedPc = regs->ARM_pc;
- ixOsalOsIsrProxy(irq, dev_id, regs);
-+ return IRQ_HANDLED;
- }
-
- /**************************************
-@@ -191,10 +194,15 @@ ixOsalIrqUnbind (UINT32 vector)
- PUBLIC UINT32
- ixOsalIrqLock ()
- {
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0))
-+ unsigned long flags;
-+ local_irq_save(flags);
-+#else
- UINT32 flags;
- save_flags (flags);
- cli ();
-- return flags;
-+#endif
-+ return (UINT32)flags;
- }
-
- /* Enable interrupts and task scheduling,
-@@ -204,7 +212,11 @@ ixOsalIrqLock ()
- PUBLIC void
- ixOsalIrqUnlock (UINT32 lockKey)
- {
-+# if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0))
-+ local_irq_restore((unsigned long)lockKey);
-+# else
- restore_flags (lockKey);
-+# endif
- }
-
- PUBLIC UINT32
-@@ -329,7 +341,7 @@ ixOsalBusySleep (UINT32 microseconds)
- PUBLIC void
- ixOsalSleep (UINT32 milliseconds)
- {
-- if (milliseconds != 0)
-+ if (milliseconds*HZ >= 1000)
- {
- set_current_state(TASK_INTERRUPTIBLE);
- schedule_timeout ((milliseconds * HZ) / 1000);
---- ixp_osal/os/linux/src/core/IxOsalOsThread.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/core/IxOsalOsThread.c 1970-01-01 00:00:00.000000000 +0000
-@@ -65,12 +65,7 @@ thread_internal (void *unused)
- void *arg = IxOsalOsThreadData.arg;
- static int seq = 0;
-
-- daemonize ();
-- reparent_to_init ();
--
-- exit_files (current);
--
-- snprintf(current->comm, sizeof(current->comm), "IxOsal %d", ++seq);
-+ daemonize ("IxOsal %d", ++seq);
-
- up (&IxOsalThreadMutex);
-
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch b/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch
deleted file mode 100644
index 1558e9cdb3..0000000000
--- a/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
- Makefile | 2 +-
- os/linux/make/macros.mk | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
---- ixp_osal/Makefile 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/Makefile 1970-01-01 00:00:00.000000000 +0000
-@@ -185,7 +185,7 @@ endif
- INCLUDE_DIRS = include $(OSAL_DIRS:%=$(MAIN_INC_PREFIX)/%) $(OSAL_DIRS:%=$(OS_INC_PREFIX)/%)
-
- ifeq ($(IX_OSAL_MK_HOST_OS), linux)
--INCLUDE_DIRS += $(LINUX_SRC)/include/asm-arm/arch-ixp425/
-+INCLUDE_DIRS += $(LINUX_SRC)/include/asm-arm/arch-ixp4xx/
- endif
-
- CFLAGS += $(INCLUDE_DIRS:%=-I%)
---- ixp_osal/os/linux/make/macros.mk 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/make/macros.mk 1970-01-01 00:00:00.000000000 +0000
-@@ -88,10 +88,10 @@ AR := $(LINUX_CROSS_COMPILE)ar
- # Compiler & linker options
-
- # Compiler flags
--LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mcpu=xscale -mtune=xscale
-+LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mtune=xscale
-
- CFLAGS := -D__KERNEL__ -I$(LINUX_SRC)/include -Wall -Wno-trigraphs -fno-common \
-- -pipe -mapcs-32 -mshort-load-bytes -msoft-float -DMODULE \
-+ -pipe -msoft-float -DMODULE \
- -D__linux -DCPU=33 -DXSCALE=33 $(LINUX_MACH_CFLAGS) -DEXPORT_SYMTAB
-
- # Linux linker flags
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/assert.patch b/packages/ixp4xx/ixp-osal-2.1.1/assert.patch
deleted file mode 100644
index a03113dcc2..0000000000
--- a/packages/ixp4xx/ixp-osal-2.1.1/assert.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-# Unnecessary patch - reduces the code size slightly, gives clearer
-# messages if IX_OSAL_ENSURE_ON is set
-# include/IxOsalAssert.h | 4 ++--
-# os/linux/include/core/IxOsalOsAssert.h | 9 ++++++++-
-# 2 files changed, 10 insertions(+), 3 deletions(-)
-#
---- ixp_osal/include/IxOsalAssert.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/include/IxOsalAssert.h 1970-01-01 00:00:00.000000000 +0000
-@@ -72,8 +72,8 @@
- */
- #ifdef IX_OSAL_ENSURE_ON
- #define IX_OSAL_ENSURE(c, str) do { \
--if (!(c)) ixOsalLog (IX_OSAL_LOG_LVL_MESSAGE, IX_OSAL_LOG_DEV_STDOUT, str, \
--0, 0, 0, 0, 0, 0); } while (0)
-+if (!(c)) ixOsalLog (IX_OSAL_LOG_LVL_MESSAGE, IX_OSAL_LOG_DEV_STDOUT, __FILE__ ": line %d: " str, \
-+__LINE__, 0, 0, 0, 0, 0); } while (0)
-
- #else
- #define IX_OSAL_ENSURE(c, str)
---- ixp_osal/os/linux/include/core/IxOsalOsAssert.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/include/core/IxOsalOsAssert.h 1970-01-01 00:00:00.000000000 +0000
-@@ -47,11 +47,18 @@
-
- #ifndef IxOsalOsAssert_H
- #define IxOsalOsAssert_H
-+#ifdef IX_OSAL_ENSURE_ON
- #define IX_OSAL_OS_ASSERT(c) if(!(c)) \
- { \
-- ixOsalLog (IX_OSAL_LOG_LVL_ERROR, IX_OSAL_LOG_DEV_STDOUT, "Assertion failure \n", 0, 0, 0, 0, 0, 0);\
-+ ixOsalLog (IX_OSAL_LOG_LVL_ERROR, IX_OSAL_LOG_DEV_STDOUT, "%s line %d: Assertion failure: %s\n", (int)__FILE__, __LINE__, (int)#c, 0, 0, 0);\
- BUG(); \
- }
-+#else
-+#define IX_OSAL_OS_ASSERT(c) if(!(c)) \
-+ { \
-+ BUG(); \
-+ }
-+#endif
-
- /*
- * Place holder.
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/invalidate-cache.patch b/packages/ixp4xx/ixp-osal-2.1.1/invalidate-cache.patch
deleted file mode 100644
index 33c1d132db..0000000000
--- a/packages/ixp4xx/ixp-osal-2.1.1/invalidate-cache.patch
+++ /dev/null
@@ -1,115 +0,0 @@
- os/linux/include/core/IxOsalOs.h | 17 ++++++++++
- os/linux/src/core/IxOsalOsCacheMMU.c | 56 +++++++++++++++++++++++++++++++++++
- os/linux/src/core/IxOsalOsSymbols.c | 4 ++
- 3 files changed, 76 insertions(+), 1 deletion(-)
-
---- ixp_osal/os/linux/include/core/IxOsalOs.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/include/core/IxOsalOs.h 1970-01-01 00:00:00.000000000 +0000
-@@ -56,6 +56,7 @@
- #include <linux/cache.h>
- #include <linux/mm.h>
- #include <linux/config.h>
-+#include <linux/version.h>
- #include <asm/pgalloc.h>
-
- /**
-@@ -66,9 +67,23 @@
-
- #define IX_OSAL_OS_MMU_PHYS_TO_VIRT(addr) ((addr) ? phys_to_virt((unsigned int)(addr)) : 0)
-
--#define IX_OSAL_OS_CACHE_INVALIDATE(addr, size) ( invalidate_dcache_range((__u32)addr, (__u32)addr + size ))
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0))
-+/*
-+ * 2.6 kernels do not export the required cache functions.
-+ */
-+extern void ixOsalCacheInvalidateRange(unsigned long start, unsigned long size);
-+extern void ixOsalCacheFlushRange(unsigned long start, unsigned long size);
-+
-+#define IX_OSAL_OS_CACHE_INVALIDATE(addr, size) \
-+ixOsalCacheInvalidateRange((unsigned long)addr, (unsigned long)addr + size)
-+#define IX_OSAL_OS_CACHE_FLUSH(addr, size) \
-+ixOsalCacheFlushRange((unsigned long)addr, (unsigned long)addr + size )
-
-+#else
-+
-+#define IX_OSAL_OS_CACHE_INVALIDATE(addr, size) ( invalidate_dcache_range((__u32)addr, (__u32)addr + size ))
- #define IX_OSAL_OS_CACHE_FLUSH(addr, size) ( clean_dcache_range((__u32)addr, (__u32)addr + size ))
-+#endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)) */
-
- /* Cache preload not available*/
- #define IX_OSAL_OS_CACHE_PRELOAD(addr,size) {}
---- ixp_osal/os/linux/src/core/IxOsalOsCacheMMU.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/core/IxOsalOsCacheMMU.c 1970-01-01 00:00:00.000000000 +0000
-@@ -210,3 +210,59 @@ ixOsalCacheDmaFree (void *ptr)
- free_pages ((unsigned int) memptr, order);
- }
- }
-+
-+
-+/*
-+ * 2.6 kernels do not export the required cache functions.
-+ */
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0))
-+
-+#define _IX_STR(x) #x
-+#define IX_STR(x) _IX_STR(x)
-+#define IX_CLM IX_STR(IX_OSAL_CACHE_LINE_SIZE-1)
-+
-+/*
-+ * reimplementation of kernel's invalidate_dcache_range()
-+ */
-+void
-+ixOsalCacheInvalidateRange(unsigned long start, unsigned long size)
-+{
-+ __asm__
-+ (" tst %0, #" IX_CLM "\n"
-+ " mcrne p15, 0, %0, c7, c10, 1 @ clean D cache line\n"
-+ " bic %0, %0, #" IX_CLM "\n"
-+ " tst %1, #" IX_CLM "\n"
-+ " mcrne p15, 0, %1, c7, c10, 1 @ clean D cache line\n"
-+ "1: mcr p15, 0, %0, c7, c6, 1 @ invalidate D cache line\n"
-+ " add %0, %0, #" IX_STR(IX_OSAL_CACHE_LINE_SIZE) "\n"
-+ " cmp %0, %1\n"
-+ " blo 1b\n"
-+ " mcr p15, 0, %0, c7, c10, 4 @ drain write & fill buffer\n"
-+ : /* no output */
-+ : "r"(start), "r"(size)
-+ : "cc");
-+}
-+
-+/*
-+ * reimplementation of kernel's invalidate_dcache_range()
-+ */
-+void
-+ixOsalCacheFlushRange(unsigned long start, unsigned long size)
-+{
-+ __asm__
-+ (" bic %0, %0, #" IX_CLM "\n"
-+ "1: mcr p15, 0, %0, c7, c10, 1 @ clean D cache line\n"
-+ " add %0, %0, #" IX_STR(IX_OSAL_CACHE_LINE_SIZE) "\n"
-+ " cmp %0, %1\n"
-+ " blo 1b\n"
-+ " mcr p15, 0, %0, c7, c10, 4 @ drain write & fill buffer\n"
-+ : /* no output */
-+ : "r"(start), "r"(size)
-+ : "cc");
-+}
-+
-+#undef _IX_STR
-+#undef IX_STR
-+#undef IX_CLM
-+
-+#endif /* (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)) */
---- ixp_osal/os/linux/src/core/IxOsalOsSymbols.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/core/IxOsalOsSymbols.c 1970-01-01 00:00:00.000000000 +0000
-@@ -64,6 +64,10 @@ EXPORT_SYMBOL (ixOsalMemSet);
-
- EXPORT_SYMBOL (ixOsalCacheDmaMalloc);
- EXPORT_SYMBOL (ixOsalCacheDmaFree);
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0))
-+EXPORT_SYMBOL (ixOsalCacheInvalidateRange);
-+EXPORT_SYMBOL (ixOsalCacheFlushRange);
-+#endif
-
- EXPORT_SYMBOL (ixOsalThreadCreate);
- EXPORT_SYMBOL (ixOsalThreadStart);
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/ixp4xx-header.patch b/packages/ixp4xx/ixp-osal-2.1.1/ixp4xx-header.patch
deleted file mode 100644
index a9d87d4b56..0000000000
--- a/packages/ixp4xx/ixp-osal-2.1.1/ixp4xx-header.patch
+++ /dev/null
@@ -1,115 +0,0 @@
- os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h | 72 ++++++++++
- os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Sys.h | 10 -
- 2 files changed, 78 insertions(+), 4 deletions(-)
-
---- ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Sys.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Sys.h 1970-01-01 00:00:00.000000000 +0000
-@@ -53,6 +53,8 @@
- #error "Error: IxOsalOsIxp425Sys.h cannot be included directly before IxOsalOsIxp400.h"
- #endif
-
-+#include "IxOsalOsIxp425Base.h"
-+
- /* Memory Base Address */
- #define IX_OSAL_IXP400_EXP_BUS_PHYS_BASE IXP425_EXP_BUS_BASE2_PHYS
- #define IX_OSAL_IXP400_EXP_BUS_BOOT_PHYS_BASE IXP425_EXP_BUS_BASE1_PHYS
-@@ -98,12 +100,12 @@ IxOsalMemoryMap ixOsalGlobalMemoryMap[]
- * Queue Manager
- */
- {
-- IX_OSAL_STATIC_MAP, /* type */
-+ IX_OSAL_DYNAMIC_MAP, /* type */
- IX_OSAL_IXP400_QMGR_PHYS_BASE, /* physicalAddress */
- IX_OSAL_IXP400_QMGR_MAP_SIZE, /* size */
-- IX_OSAL_IXP400_QMGR_VIRT_BASE, /* virtualAddress */
-- NULL, /* mapFunction */
-- NULL, /* unmapFunction */
-+ 0, /* virtualAddress */
-+ ixOsalLinuxMemMap, /* mapFunction */
-+ ixOsalLinuxMemUnmap, /* unmapFunction */
- 0, /* refCount */
- IX_OSAL_BE | IX_OSAL_LE_DC, /* endianType */
- "qMgr" /* name */
---- ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h 1970-01-01 00:00:00.000000000 +0000
-@@ -0,0 +1,80 @@
-+/*
-+ * Glue for the current linux definitons of this stuff.
-+ */
-+#ifndef IxOsalOsIxp425Base_H
-+#define IxOsalOsIxp425Base_H 1
-+#include <asm-arm/arch-ixp4xx/ixp4xx-regs.h>
-+#include <linux/version.h>
-+
-+/* Force Address Coherent (the default) mapping on LE - Linux 2.6
-+ * does not have a way of changing it.
-+ */
-+#if defined IX_OSAL_LINUX_LE
-+# if !defined IX_OSAL_ENFORCED_LE_AC_MAPPING
-+# define IX_OSAL_ENFORCED_LE_AC_MAPPING
-+# endif
-+# if defined IX_OSAL_LE_DC_MAPPING
-+# error Little Endian Data Coherent mapping not supported on this platform
-+# endif
-+
-+/* This doesn't matter on a BE build because it will never be used,
-+ * however it will be selected and will fail on an LE build.
-+ */
-+# undef IX_OSAL_LE_DC
-+# define IX_OSAL_LE_DC IX_OSAL_LE_DC_IS_INVALID_ON_THIS_PLATFORM
-+#endif
-+
-+/* Physical addresses. */
-+#define IXP425_PERIPHERAL_BASE_PHYS IXP4XX_PERIPHERAL_BASE_PHYS
-+#define IXP425_EXP_CFG_BASE_PHYS IXP4XX_EXP_CFG_BASE_PHYS
-+#define IXP425_PCI_CFG_BASE_PHYS IXP4XX_PCI_CFG_BASE_PHYS
-+
-+//#define IXP425_EXP_BUS_BASE1_PHYS
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,16)
-+#define IXP425_EXP_BUS_BASE2_PHYS IXP4XX_EXP_BUS_CS2_BASE_PHYS
-+#else
-+/* The following definition should be IXP4XX_EXP_BUS_BASE(2), but that is not
-+ static and causes compilation problems later. So we need to hard-code it.
-+ Note that this hard-coded value is only correct for IXP42X. */
-+#define IXP425_EXP_BUS_BASE2_PHYS (IXP4XX_EXP_BUS_BASE_PHYS + (2 * SZ_16M))
-+#endif
-+//#define IXP425_EXP_BUS_CS0_BASE_PHYS
-+//#define IXP425_EXP_BUS_CS1_BASE_PHYS
-+//#define IXP425_EXP_BUS_CS4_BASE_PHYS
-+#define IXP425_EthA_BASE_PHYS (IXP4XX_PERIPHERAL_BASE_PHYS + 0x9000)
-+#define IXP425_EthB_BASE_PHYS (IXP4XX_PERIPHERAL_BASE_PHYS + 0xA000)
-+//#define IXP425_GPIO_BASE_PHYS
-+#define IXP425_INTC_BASE_PHYS IXP4XX_INTC_BASE_PHYS
-+//#define IXP425_NPEA_BASE_PHYS
-+//#define IXP425_NPEB_BASE_PHYS
-+//#define IXP425_NPEC_BASE_PHYS
-+//#define IXP425_PMU_BASE_PHYS
-+#define IXP425_QMGR_BASE_PHYS IXP4XX_QMGR_BASE_PHYS
-+#define IXP425_TIMER_BASE_PHYS IXP4XX_TIMER_BASE_PHYS
-+//#define IXP425_UART1_BASE_PHYS
-+//#define IXP425_UART2_BASE_PHYS
-+#define IXP425_USB_BASE_PHYS IXP4XX_USB_BASE_PHYS
-+
-+/* Virtual addresses. */
-+#define IXP425_PERIPHERAL_BASE_VIRT IXP4XX_PERIPHERAL_BASE_VIRT
-+#define IXP425_PERIPHERAL_REGION_SIZE IXP4XX_PERIPHERAL_REGION_SIZE
-+#define IXP425_EXP_CFG_BASE_VIRT IXP4XX_EXP_CFG_BASE_VIRT
-+#define IXP425_PCI_CFG_BASE_VIRT IXP4XX_PCI_CFG_BASE_VIRT
-+
-+//#define IXP425_EthA_BASE_VIRT
-+//#define IXP425_EthB_BASE_VIRT
-+//#define IXP425_GPIO_BASE_VIRT
-+//#define IXP425_NPEA_BASE_VIRT
-+//#define IXP425_NPEB_BASE_VIRT
-+//#define IXP425_NPEC_BASE_VIRT
-+//#define IXP425_QMGR_BASE_VIRT /* must be ioremapped on Linux 2.6 */
-+//#define IXP425_TIMER_BASE_VIRT
-+//#define IXP425_UART1_BASE_VIRT
-+//#define IXP425_UART2_BASE_VIRT
-+//#define IXP425_USB_BASE_VIRT
-+
-+/* Miscellaneous stuff. */
-+#define IRQ_IXP425_XSCALE_PMU IRQ_IXP4XX_XSCALE_PMU
-+#define IXP425_ICMR IXP4XX_ICMR
-+#define IRQ_IXP425_USB IRQ_IXP4XX_USB
-+#endif
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/le.patch b/packages/ixp4xx/ixp-osal-2.1.1/le.patch
deleted file mode 100644
index a6936ea33b..0000000000
--- a/packages/ixp4xx/ixp-osal-2.1.1/le.patch
+++ /dev/null
@@ -1,72 +0,0 @@
- include/modules/ioMem/IxOsalIoMem.h | 4 ++--
- include/modules/ioMem/IxOsalMemAccess.h | 2 +-
- os/linux/include/platforms/ixp400/IxOsalOsIxp400CustomizedMapping.h | 2 +-
- os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Sys.h | 2 +-
- os/linux/src/modules/ioMem/IxOsalOsIoMem.c | 3 +++
- 5 files changed, 8 insertions(+), 5 deletions(-)
-
---- ixp_osal/include/modules/ioMem/IxOsalIoMem.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/include/modules/ioMem/IxOsalIoMem.h 1970-01-01 00:00:00.000000000 +0000
-@@ -117,8 +117,8 @@ ixOsalCoreWordSwap (UINT32 wordIn)
- #endif /* ndef __wince */
-
- #define IX_OSAL_SWAP_SHORT(sData) ((sData >> 8) | ((sData & 0xFF) << 8))
--#define IX_OSAL_SWAP_SHORT_ADDRESS(sAddr) ((sAddr) ^ 0x2)
--#define IX_OSAL_SWAP_BYTE_ADDRESS(bAddr) ((bAddr) ^ 0x3)
-+#define IX_OSAL_SWAP_SHORT_ADDRESS(sAddr) ((UINT16*)((UINT32)(sAddr) ^ 0x2))
-+#define IX_OSAL_SWAP_BYTE_ADDRESS(bAddr) ((UINT8*)((UINT32)(bAddr) ^ 0x3))
-
- #define IX_OSAL_BE_XSTOBUSL(wData) (wData)
- #define IX_OSAL_BE_XSTOBUSS(sData) (sData)
---- ixp_osal/include/modules/ioMem/IxOsalMemAccess.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/include/modules/ioMem/IxOsalMemAccess.h 1970-01-01 00:00:00.000000000 +0000
-@@ -84,7 +84,7 @@
-
- #elif defined (IX_OSAL_LINUX_LE)
-
--#define IX_SDRAM_LE_DATA_COHERENT
-+#define IX_SDRAM_LE_ADDRESS_COHERENT
-
- #elif defined (IX_OSAL_WINCE_LE)
-
---- ixp_osal/os/linux/include/platforms/ixp400/IxOsalOsIxp400CustomizedMapping.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/include/platforms/ixp400/IxOsalOsIxp400CustomizedMapping.h 1970-01-01 00:00:00.000000000 +0000
-@@ -171,7 +171,7 @@
- ***************************/
- #if (IX_COMPONENT_NAME == ix_qmgr)
-
--#define IX_OSAL_LE_DC_MAPPING
-+#define IX_OSAL_LE_AC_MAPPING
-
- #endif /* qmgr */
-
---- ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Sys.h 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Sys.h 1970-01-01 00:00:00.000000000 +0000
-@@ -107,7 +107,7 @@ IxOsalMemoryMap ixOsalGlobalMemoryMap[]
- ixOsalLinuxMemMap, /* mapFunction */
- ixOsalLinuxMemUnmap, /* unmapFunction */
- 0, /* refCount */
-- IX_OSAL_BE | IX_OSAL_LE_DC, /* endianType */
-+ IX_OSAL_BE | IX_OSAL_LE_AC, /* endianType */
- "qMgr" /* name */
- },
-
---- ixp_osal/os/linux/src/modules/ioMem/IxOsalOsIoMem.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp_osal/os/linux/src/modules/ioMem/IxOsalOsIoMem.c 1970-01-01 00:00:00.000000000 +0000
-@@ -45,6 +45,7 @@
- * -- End Intel Copyright Notice --
- */
-
-+#include <asm/page.h>
- #include <asm/io.h>
- #include <linux/ioport.h>
-
-@@ -54,6 +55,8 @@
- PUBLIC void
- ixOsalLinuxMemMap (IxOsalMemoryMap * map)
- {
-+ /* Linux requires LE mappings to use address coherency */
-+ IX_OSAL_ENSURE((map->mapEndianType & IX_OSAL_LE_DC) == 0, "LE Data Coherency not supported");
- map->virtualAddress = (UINT32) ioremap (map->physicalAddress, map->size);
- }
-