summaryrefslogtreecommitdiff
path: root/packages/ixp425-eth/ixp425-eth_1.2.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-11 07:09:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-11 07:09:54 +0000
commit3333852bd0bc5b926374b919a6fd2794fbadffd6 (patch)
treefab3192bc108ec0bdaa76b0ddf1bd8ddfdb03caa /packages/ixp425-eth/ixp425-eth_1.2.bb
parentc103910fd158f991efa64e1aefd0b267552b6767 (diff)
slugos-image: remove spurious DEPENDS in conf
- this upgrades slugos-image to the new RDEPENDS only world, some missing (R)dependencies are corrected slugos-init: remove virtual/ixp-eth in 0.10 - this stuff is no longer necessary and the modprobe.conf has been moved to the ixp-eth module rather than having it incorrectly introduced in a non-dependent module.
Diffstat (limited to 'packages/ixp425-eth/ixp425-eth_1.2.bb')
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/ixp425-eth/ixp425-eth_1.2.bb b/packages/ixp425-eth/ixp425-eth_1.2.bb
index 9336e1fe6d..3cc9a6c70a 100644
--- a/packages/ixp425-eth/ixp425-eth_1.2.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.2.bb
@@ -8,7 +8,8 @@ SRC_URI += "file://ixp400linuxethernetdriver-1_2-kernel26_hr_20050929.patch;patc
SRC_URI += "file://makefile.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r2"
+SRC_URI += "file://modprobe.conf"
+PR = "r4"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"
@@ -18,6 +19,7 @@ S = "${WORKDIR}"
COMPATIBLE_HOST = "^armeb-linux.*"
PROVIDES = "virtual/ixp-eth"
+RPROVIDES = "ixp-eth"
inherit module
@@ -46,4 +48,6 @@ do_compile () {
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 modprobe.conf ${D}${sysconfdir}/modprobe.d/eth0
}