summaryrefslogtreecommitdiff
path: root/packages/ivman
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/ivman
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/ivman')
-rw-r--r--packages/ivman/files/ivman-0.6-hotpluggable.patch40
-rw-r--r--packages/ivman/files/ivman-launch.patch15
-rw-r--r--packages/ivman/ivman_0.6.14.bb31
3 files changed, 0 insertions, 86 deletions
diff --git a/packages/ivman/files/ivman-0.6-hotpluggable.patch b/packages/ivman/files/ivman-0.6-hotpluggable.patch
deleted file mode 100644
index 8f734bd0d2..0000000000
--- a/packages/ivman/files/ivman-0.6-hotpluggable.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=169593
- iulica@box.co.uk
-This patch tests also for a storage if it is hotpluggable and mounts it
-automatically. A reason of creating the patch can be found here:
-http://lists.freedesktop.org/archives/hal/2005-October/003441.html
-
---- a/src/IvmConfig/IvmConfigCommon.c.old 2007-03-05 15:28:49.000000000 +0100
-+++ b/src/IvmConfig/IvmConfigCommon.c 2007-03-05 15:34:36.000000000 +0100
-@@ -146,7 +146,9 @@
- volume.policy.should_mount does not exist
- AND { storage.policy.should_mount == TRUE on block.storage_device
- OR { storage.policy.should_mount does not exist on
-- block.storage_device AND storage.removable == TRUE on
-+ block.storage_device AND { storage.removable == TRUE
-+ OR storage.hotpluggable == TRUE
-+ } on
- block.storage_device
- }
- }
-@@ -216,14 +218,16 @@
- {
- ivm_check_dbus_error(&dbus_error);
- // OK, so no storage policy was specified anywhere. Now we'll mount
-- // if parent device is removable.
-+ // if parent device is removable or hotpluggable.
- if (
-- !libhal_device_property_exists( hal_ctx, new_udi, "storage.removable", NULL ) ||
-- !libhal_device_get_property_bool( hal_ctx, new_udi, "storage.removable", NULL )
-+ (!libhal_device_property_exists( hal_ctx, new_udi, "storage.removable", NULL ) ||
-+ !libhal_device_get_property_bool( hal_ctx, new_udi, "storage.removable", NULL )) &&
-+ (!libhal_device_property_exists( hal_ctx, new_udi, "storage.hotpluggable", NULL ) ||
-+ !libhal_device_get_property_bool( hal_ctx, new_udi, "storage.hotpluggable", NULL ))
- ) {
- DEBUG(_("\
- Device %s won't be mounted because no mount policy was specified on \
--volume or storage device and storage device does not appear to be removable"), device
-+volume or storage device and storage device does not appear to be removable or hotpluggable"), device
- );
- libhal_free_string( device );
- libhal_free_string( new_udi );
diff --git a/packages/ivman/files/ivman-launch.patch b/packages/ivman/files/ivman-launch.patch
deleted file mode 100644
index 8595a4d806..0000000000
--- a/packages/ivman/files/ivman-launch.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- ivman-0.6.14/ivman-launch.orig 2008-09-29 11:58:49.000000000 +0300
-+++ ivman-0.6.14/ivman-launch 2008-09-29 12:02:17.000000000 +0300
-@@ -1,11 +1,10 @@
--#!/bin/bash
-+#!/bin/sh
- # This script was written by Daniele Favara <danjele@gmail.com>
- #
- CMD=ivman
- CONFDIR= # the config dir | null
- EXITWITH=
- SESSION=
--set -x
- while [ ! -z "$1" ];do
- case "$1" in
- --help|-h)
diff --git a/packages/ivman/ivman_0.6.14.bb b/packages/ivman/ivman_0.6.14.bb
deleted file mode 100644
index ecc4665b9b..0000000000
--- a/packages/ivman/ivman_0.6.14.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-DESCRIPTION = "Daemon to mount/unmount devices, based on info from HAL"
-HOMEPAGE = "http://ivman.sf.net"
-LICENSE = "GPLv2"
-PR = "r1"
-
-DEPENDS = "hal libxml2"
-RDEPENDS = "hal pmount-hal"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/ivman/${P}.tar.bz2 \
- file://ivman-0.6-hotpluggable.patch;patch=1 \
- file://ivman-launch.patch;patch=1 "
-
-inherit autotools
-
-# Add user ivman into group plugdev
-pkg_postinst_${PN} () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep "^ivman:" /etc/passwd > /dev/null || \
- adduser --disabled-password --system --home /dev/null \
- --no-create-home --ingroup plugdev -s /bin/false \
- -g "IVMAN" ivman
- /etc/init.d/populate-volatile.sh update
-}
-
-pkg_postrm_${PN} () {
- deluser ivman || true
-}