summaryrefslogtreecommitdiff
path: root/packages/ipsec-tools/files
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-06 02:34:04 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-06 02:34:04 +0000
commit1bb7ebd1b55f7dc62391068527c5d77a50cb6493 (patch)
treea356411d6fa6e8eaa2e06c2bd1a4b331520d7584 /packages/ipsec-tools/files
parentdc3575429a49219f6e94b5e2f304b1181576bf10 (diff)
ipsec-tools: Add 0.6.7, removed all 0.4 versions and fixed for
building with gcc 4.2.
Diffstat (limited to 'packages/ipsec-tools/files')
-rw-r--r--packages/ipsec-tools/files/cross.patch75
-rw-r--r--packages/ipsec-tools/files/gcc-4.2.patch47
-rw-r--r--packages/ipsec-tools/files/racoon-search-missing.patch17
3 files changed, 64 insertions, 75 deletions
diff --git a/packages/ipsec-tools/files/cross.patch b/packages/ipsec-tools/files/cross.patch
deleted file mode 100644
index a0e7b1da27..0000000000
--- a/packages/ipsec-tools/files/cross.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Index: ipsec-tools-0.5-rc1/acracoon.m4
-===================================================================
---- ipsec-tools-0.5-rc1.orig/acracoon.m4 2004-09-21 10:35:23.000000000 -0400
-+++ ipsec-tools-0.5-rc1/acracoon.m4 2005-02-03 13:56:02.144689256 -0500
-@@ -92,6 +92,8 @@
-
- AC_DEFUN([RACOON_CHECK_BUGGY_GETADDRINFO], [
- AC_MSG_CHECKING(getaddrinfo bug)
-+ AC_CACHE_CHECK([for a buggy getaddrinfo],
-+ racoon_cv_bug_getaddrinfo,[
- saved_CFLAGS=$CFLAGS
- CFLAGS="-Wall -O2"
- AC_TRY_RUN([
-@@ -182,12 +184,10 @@
- exit(1);
- }
- ],
-- AC_MSG_RESULT(good)
-- buggygetaddrinfo=no,
-- AC_MSG_RESULT(buggy)
-- buggygetaddrinfo=yes,
-- AC_MSG_RESULT(buggy)
-- buggygetaddrinfo=yes)
-+ racoon_cv_bug_getaddrinfo=no,
-+ racoon_cv_bug_getaddrinfo=yes,
-+ racoon_cv_bug_getaddrinfo=yes)
- CFLAGS=$saved_CFLAGS
- unset saved_CFLAGS
-+ ])
- ])
-Index: ipsec-tools-0.5-rc1/configure.ac
-===================================================================
---- ipsec-tools-0.5-rc1.orig/configure.ac 2005-01-04 09:20:57.000000000 -0500
-+++ ipsec-tools-0.5-rc1/configure.ac 2005-02-03 14:02:34.935975904 -0500
-@@ -16,6 +16,9 @@
- AC_PROG_LIBTOOL
- AC_PROG_YACC
- AM_PROG_LEX
-+ac_save_LIBS="$LIBS"
-+AC_CHECK_LIB(fl, yywrap, LEXLIB="-lfl")
-+LIBS="$ac_save_LIBS"
- AC_SUBST(LEXLIB)
- AC_PROG_EGREP
-
-@@ -57,10 +60,12 @@
- AC_SUBST(CONFIGURE_AMFLAGS) ],
- [ KERNEL_INCLUDE="/lib/modules/`uname -r`/build/include" ])
-
-+ if test "$cross_compiling" = no; then
- AC_CHECK_FILE($KERNEL_INCLUDE/linux/pfkeyv2.h, ,
- [ AC_CHECK_FILE(/usr/src/linux/include/linux/pfkeyv2.h,
- KERNEL_INCLUDE=/usr/src/linux/include ,
- [ AC_MSG_ERROR([Unable to find linux-2.6 kernel headers. Aborting.]) ] ) ] )
-+ fi
- AC_SUBST(KERNEL_INCLUDE)
- # We need the configure script to run with correct kernel headers.
- # However we don't want to point to kernel source tree in compile time,
-@@ -176,7 +181,7 @@
- AC_MSG_CHECKING(sha2 support)
- AC_DEFINE([WITH_SHA2], [], [SHA2 support])
- AC_CHECK_HEADER(openssl/sha2.h, [], [
-- CPPFLAGS_ADD="$CPPFLAGS_ADD -I./\${top_srcdir}/src/racoon/missing"
-+ CPPFLAGS_ADD="$CPPFLAGS_ADD -I\${top_srcdir}/src/racoon/missing"
- AC_LIBOBJ([sha2])
- CRYPTOBJS="$CRYPTOBJS sha2.o"])
- AC_SUBST(CRYPTOBJS)
-@@ -339,7 +344,7 @@
- fi
-
- RACOON_CHECK_BUGGY_GETADDRINFO
--if test "$buggygetaddrinfo" = "yes"; then
-+if test "$racoon_cv_bug_getaddrinfo" = "yes"; then
- AC_MSG_ERROR([Broken getaddrinfo() is no longer supported. Aborting.])
- fi
-
diff --git a/packages/ipsec-tools/files/gcc-4.2.patch b/packages/ipsec-tools/files/gcc-4.2.patch
new file mode 100644
index 0000000000..573f242e65
--- /dev/null
+++ b/packages/ipsec-tools/files/gcc-4.2.patch
@@ -0,0 +1,47 @@
+Index: ipsec-tools-0.6.7/src/racoon/var.h
+===================================================================
+--- ipsec-tools-0.6.7.orig/src/racoon/var.h 2004-11-21 03:16:59.000000000 +1100
++++ ipsec-tools-0.6.7/src/racoon/var.h 2007-06-06 12:21:41.000000000 +1000
+@@ -76,9 +76,9 @@
+ do { \
+ if (getnameinfo((x), sysdep_sa_len(x), (y), sizeof(y), (z), sizeof(z), \
+ NIFLAGS) != 0) { \
+- if (y) \
++ if (y != NULL) \
+ strncpy((y), "(invalid)", sizeof(y)); \
+- if (z) \
++ if (z != NULL) \
+ strncpy((z), "(invalid)", sizeof(z)); \
+ } \
+ } while (0);
+@@ -87,7 +87,7 @@
+ do { \
+ if (getnameinfo((x), sysdep_sa_len(x), (y), sizeof(y), NULL, 0, \
+ NIFLAGS) != 0) { \
+- if (y) \
++ if (y != NULL) \
+ strncpy((y), "(invalid)", sizeof(y)); \
+ } \
+ } while (0);
+Index: ipsec-tools-0.6.7/src/racoon/eaytest.c
+===================================================================
+--- ipsec-tools-0.6.7.orig/src/racoon/eaytest.c 2005-06-29 08:38:02.000000000 +1000
++++ ipsec-tools-0.6.7/src/racoon/eaytest.c 2007-06-06 12:22:59.000000000 +1000
+@@ -311,7 +311,7 @@
+
+ printf("exact match: succeed.\n");
+
+- if (dnstr_w1) {
++ if (dnstr_w1 != NULL) {
+ asn1dn = eay_str2asn1dn(dnstr_w1, strlen(dnstr_w1));
+ if (asn1dn == NULL || asn1dn->l == asn1dn0.l)
+ errx(1, "asn1dn length wrong for wildcard 1\n");
+@@ -321,7 +321,7 @@
+ printf("wildcard 1 match: succeed.\n");
+ }
+
+- if (dnstr_w1) {
++ if (dnstr_w1 != NULL) {
+ asn1dn = eay_str2asn1dn(dnstr_w2, strlen(dnstr_w2));
+ if (asn1dn == NULL || asn1dn->l == asn1dn0.l)
+ errx(1, "asn1dn length wrong for wildcard 2\n");
diff --git a/packages/ipsec-tools/files/racoon-search-missing.patch b/packages/ipsec-tools/files/racoon-search-missing.patch
new file mode 100644
index 0000000000..eebcb87017
--- /dev/null
+++ b/packages/ipsec-tools/files/racoon-search-missing.patch
@@ -0,0 +1,17 @@
+Older versions of openssl don't provide all the required crypto code.
+To handle this case ipsec-tools includes it's own version of the
+required crypto code but it fails to add it the search path so
+compilation fails. Fix it here since OE currently have an older
+version of openssl.
+
+--- ipsec-tools-0.6.6/src/racoon/Makefile.am 2006/08/17 05:10:57 1.1
++++ ipsec-tools-0.6.6/src/racoon/Makefile.am 2006/08/17 05:12:08
+@@ -9,7 +9,7 @@
+
+ adminsockdir=${localstatedir}/racoon
+
+-INCLUDES = -I${srcdir}/../libipsec
++INCLUDES = -I${srcdir}/../libipsec -I${srcdir}/missing
+ AM_CFLAGS = -D_GNU_SOURCE @GLIBC_BUGS@ -DSYSCONFDIR=\"${sysconfdir}\" \
+ -DADMINPORTDIR=\"${adminsockdir}\"
+ AM_LDFLAGS = @EXTRA_CRYPTO@ -lcrypto