summaryrefslogtreecommitdiff
path: root/packages/ipkg/ipkg_0.99.129.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
commit1bb521fd96e47c6437bda16cf922d897a171fc14 (patch)
tree6579b2df48f9bf5f48192b377dd81d1a41c9f85b /packages/ipkg/ipkg_0.99.129.bb
parent52da54beb1ebd89a0fcfdfea8247b357128e8e97 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 04:02:25-05:00 handhelds.org!kergoth automake 1.9.x build fixes: ice, libsm, libxcursor, libxfixes, libxft, libxss, xcomposite, xdamage, xpm, xt, xtst. 2005/01/20 04:00:34-05:00 handhelds.org!kergoth Disable PARALLEL_MAKE in opie-tinykate. 2005/01/20 03:58:05-05:00 handhelds.org!kergoth rosetta: inherit gettext and depend on virtual/libintl. 2005/01/20 03:57:40-05:00 handhelds.org!kergoth A few STAGING_KERNEL_DIR and PACKAGE_ARCH fixes for multimachine builds. 2005/01/20 03:53:46-05:00 handhelds.org!kergoth tosa.conf: don't bother installing the real modutils.. the busybox modutils is fine. 2005/01/20 03:52:08-05:00 handhelds.org!kergoth wireless-tools: Apply patch to stop poking into the kernel headers where it shouldnt be, clean things up, use the local wireless.h instead of the kernel's, and split out into more granular ipks. 2005/01/20 03:49:43-05:00 handhelds.org!kergoth Patch ipkg to fix a bug when built for relatively recent uclibc. BKrev: 41ef8a88apPGTS6jqkoO28j6FLNtjg
Diffstat (limited to 'packages/ipkg/ipkg_0.99.129.bb')
-rw-r--r--packages/ipkg/ipkg_0.99.129.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/packages/ipkg/ipkg_0.99.129.bb b/packages/ipkg/ipkg_0.99.129.bb
index e69de29bb2..4bb025c487 100644
--- a/packages/ipkg/ipkg_0.99.129.bb
+++ b/packages/ipkg/ipkg_0.99.129.bb
@@ -0,0 +1,53 @@
+SECTION = "base"
+DESCRIPTION = "Itsy Package Manager"
+DESCRIPTION_libipkg = "Itsy Package Manager Library"
+LICENSE = "GPL"
+PROVIDES = "virtual/ipkg libipkg"
+PR = "r5"
+
+PACKAGES =+ "libipkg-dev libipkg"
+FILES_libipkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
+FILES_libipkg = "${libdir}"
+AUTO_LIBNAME_PKGS = "libipkg"
+
+SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://buffer-overflow.patch;patch=1 \
+ file://uninclude-replace.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+S = "${WORKDIR}/ipkg/C"
+
+inherit autotools pkgconfig
+
+pkg_postinst_ipkg () {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
+ # this happens at S98 where our good 'ole packages script used to run
+ echo -e "#!/bin/sh
+ipkg-cl configure
+" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S98configure
+ chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S98configure
+fi
+
+update-alternatives --install /usr/bin/ipkg ipkg /usr/bin/ipkg-cl 100
+}
+
+pkg_postrm_ipkg () {
+#!/bin/sh
+update-alternatives --remove ipkg /usr/bin/ipkg-cl
+}
+
+do_stage() {
+ oe_libinstall -so libipkg ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/replace/
+ install -m 0644 replace/replace.h ${STAGING_INCDIR}/replace/
+ install -d ${STAGING_INCDIR}/libipkg/
+ for f in *.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/libipkg/
+ done
+}
+
+#
+# FIXME: Install /etc/ipkg.conf and /etc/ipkg/arch.conf
+#