summaryrefslogtreecommitdiff
path: root/packages/ion/ion3/luaconfig.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/ion/ion3/luaconfig.patch
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/ion/ion3/luaconfig.patch')
-rw-r--r--packages/ion/ion3/luaconfig.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/ion/ion3/luaconfig.patch b/packages/ion/ion3/luaconfig.patch
index e69de29bb2..9018f6aaee 100644
--- a/packages/ion/ion3/luaconfig.patch
+++ b/packages/ion/ion3/luaconfig.patch
@@ -0,0 +1,27 @@
+--- tmp/work/arm-linux/ion3-0.0+ds20041104-r0/ion-3ds-20041104/configure.ac 2004-11-04 08:55:55.000000000 -0600
++++ ion-3ds-20041104/configure.ac 2004-12-28 13:47:05.000000000 -0600
+@@ -204,11 +185,15 @@
+ fi
+ dnl }}}
+
++AC_PATH_PROG([LUACONFIG], [lua$with_lua_suffix-config], [], [$lua_search_path])
++
+ dnl LUA_INCLUDES {{{
+ if test "x$with_lua_includes" != x; then
+ LUA_INCLUDES="-I$with_lua_includes"
+ elif test "x$with_lua_prefix" != x; then
+ LUA_INCLUDES="-I$with_lua_prefix/include"
++elif test "x$LUACONFIG" != x; then
++ LUA_INCLUDES="`lua-config --includes`"
+ fi
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $LUA_INCLUDES"
+@@ -221,6 +206,8 @@
+ LUA_LIBS="-L$with_lua_libraries"
+ elif test "x$with_lua" != x; then
+ LUA_LIBS="-L$with_lua_prefix/lib"
++elif test "x$LUACONFIG" != x; then
++ LUA_LIBS="`lua-config --libs`"
+ fi
+ AC_CHECK_LIB([lua$with_lua_suffix],
+ [lua_open],