summaryrefslogtreecommitdiff
path: root/packages/initscripts
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-05-27 05:12:07 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-05-27 05:12:07 +0000
commitb8d24abf2d7472c7947cbd77c3ad6dd0b8b366e0 (patch)
tree7be859e40ce71a930ff5cfc2ebf3f33e818e9683 /packages/initscripts
parent33402435e9b05ece25b1e22d6efef0c3cf34be96 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into marsco.kalmiopsis:/home/nslu2/openembedded 2005/05/26 23:01:36+02:00 handhelds.org!CoreDump Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into handhelds.org:/home/mhentges/OpenEmbedded/bitbake/openembedded 2005/05/26 23:00:54+02:00 handhelds.org!CoreDump busybox: Undo previous cset, problem was caused by a too old bitbake version 2005/05/26 22:49:18+02:00 void!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into dominion.dominion.void:/data/build/oe/openembedded 2005/05/26 22:44:03+02:00 handhelds.org!CoreDump busybox: bump PR 2005/05/26 22:40:23+02:00 handhelds.org!CoreDump Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into handhelds.org:/home/mhentges/OpenEmbedded/bitbake/openembedded 2005/05/26 22:39:32+02:00 handhelds.org!CoreDump Unb0rk busybox .bb 2005/05/26 22:39:31+02:00 void!koen hildon-lgpl_0.9.14-2.bb: fix install and stage 2005/05/26 21:32:08+02:00 void!koen hildon-lgpl_0.9.14-2.bb: stage some libs too 2005/05/26 21:13:24+02:00 void!koen osso-thumbnail_0.3.1-1.bb, osso-gwobex_0.26.1.bb, hildon-lgpl_0.9.14-2.bb: DEPENDS: gtk+ -> gtk+-2.6.4-1.osso7 2005/05/26 20:46:28+02:00 void!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into dominion.dominion.void:/data/build/oe/openembedded 2005/05/26 20:45:22+02:00 void!koen gtk+_2.6.4-1.osso7.bb: fix MAINTAINER 2005/05/26 20:36:02+02:00 dyndns.org!reenoo Merge oe-devel@oe-devel.bkbits.net:openembedded into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2005/05/26 20:35:34+02:00 dyndns.org!reenoo handhelds-sa_2.4.19-rmk6-pxa1-hh39: DEFAULT_PREFERENCE = "-1" for now 2005/05/26 20:29:30+02:00 void!koen Add gtk+-2.6.4-1.osso7 + one hundred and four (104) patches, part of the maemo.org suite. (I believe this sets a record, try and beat that, RP ;)) 2005/05/26 20:03:43+02:00 handhelds.org!CoreDump .del-opie-image-ext2loop.bb~1275262c1f290f89: Delete: packages/meta/opie-image-ext2loop.bb 2005/05/26 19:44:44+02:00 handhelds.org!CoreDump Added opie-image-ext2loop.bb: Identical to opie-image but creates an ext2 image file to be used w/ altboot or similar scripts 2005/05/26 19:29:15+02:00 handhelds.org!CoreDump initscripts_1.0.bb: initscripts: Bump PR sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.bb: sharp-sd: Bump PR portmap_5-9.bb: portmap: Bump PR portmap: Remove initscript from runlevels 2 to 5 as it is already beeing launched in rcS.d ramdisk: Remove error message about missing /etc/ramdisk.conf sd: /etc/init.d/sd: Hide insmod messages BKrev: 4296ac27fFigmI4JpIL7z1pPTRIUHg
Diffstat (limited to 'packages/initscripts')
-rw-r--r--packages/initscripts/initscripts-1.0/ramdisk46
-rw-r--r--packages/initscripts/initscripts_1.0.bb2
2 files changed, 47 insertions, 1 deletions
diff --git a/packages/initscripts/initscripts-1.0/ramdisk b/packages/initscripts/initscripts-1.0/ramdisk
index e69de29bb2..03ac9bd05b 100644
--- a/packages/initscripts/initscripts-1.0/ramdisk
+++ b/packages/initscripts/initscripts-1.0/ramdisk
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+. /etc/default/rcS
+
+FSTYPE=ext2
+
+if test ! -e /proc/mtd
+then
+ test "$VERBOSE" != "no" && echo >&2 "/proc not mounted, or mtd support not enabled in kernel."
+ exit
+fi
+
+RAM_MTD_NO=`cat /proc/mtd | grep mtdram | tail -n 1 | cut -d: -f1 | cut -dd -f2`
+if test -z "$RAM_MTD_NO"; then exit 0; fi
+
+if test -e /dev/mtdblock/0
+then
+ RAM_MTD=/dev/mtd/$RAM_MTD_NO
+ RAM_MTDBLK=/dev/mtdblock/$RAM_MTD_NO
+else
+ RAM_MTD=/dev/mtd$RAM_MTD_NO
+ RAM_MTDBLK=/dev/mtdblock$RAM_MTD_NO
+fi
+
+RAM_MNTPT=/mnt/ram
+RAM_MTD_SIZE_HEX=`cat /proc/mtd | grep mtdram | tail -n 1 | cut -d" " -f 2`
+RAM_MTD_SIZE=`dc 0x$RAM_MTD_SIZE_HEX 1024 / p`
+test -e /etc/ramdisk.conf && OLD_MTD_SIZE=`cat /etc/ramdisk.conf`
+echo $RAM_MTD_SIZE > /etc/ramdisk.conf
+
+if test ! -d "$RAM_MNTPT"; then echo >&2 "Mountpoint $RAM_MNTPT does not exist!"; exit 0; fi
+
+if (test ! -e /etc/.configured) || test "$OLD_MTD_SIZE" != "$RAM_MTD_SIZE"; then
+ test "$VERBOSE" != "no" && echo -n "Wiping ramdisk: "
+ dd if=/dev/zero bs=1024 count=$RAM_MTD_SIZE of=$RAM_MTD 2>/dev/null >&2 || exit 1
+ test "$VERBOSE" != "no" && echo "$RAM_MTD";
+ test "$VERBOSE" != "no" && echo -n "Creating filesystem on ramdisk: "
+ mkfs.$FSTYPE $RAM_MTDBLK 2>/dev/null >&2 || exit 1
+ test "$VERBOSE" != "no" && echo "$RAM_MTDBLK";
+fi
+
+test "$VERBOSE" != "no" && echo -n "Mounting ramdisk: "
+mount -t $FSTYPE $RAM_MTDBLK $RAM_MNTPT 2>/dev/null >&2 || exit 1
+test "$VERBOSE" != "no" && echo "$RAM_MTDBLK";
+
+exit 0
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index 89d83cfbb5..a42948ef02 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "makedevs"
DEPENDS_openzaurus = "makedevs virtual/kernel"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r42"
+PR = "r43"
SRC_URI = "file://halt \
file://ramdisk \