summaryrefslogtreecommitdiff
path: root/packages/initscripts
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-31 09:41:38 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-31 09:41:38 +0000
commitad50b0674f6db015354de3eb26f406678c25b8a4 (patch)
tree88f9c63d4e147e2988e38e928a46ef923a4f9183 /packages/initscripts
parent4667dbc67ed4b86044bfbca044596c025ef5d4c6 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/03/31 11:28:44+02:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/03/31 01:34:08+02:00 uni-frankfurt.de!mickeyl apply the fix-nomax patch for Opie's libqpe from 1.2.0. It will land upstream, so it's not necessary to apply it on the cvs version 2005/03/31 01:32:37+02:00 uni-frankfurt.de!mickeyl put an end to the datetime problem on handhelds. if /etc/timestamp exists, it will be used to regenerate the time at bootup (see /etc/init.d/bootmisc.sh) and it will be freshened at halt (see /etc/init.d/halt) as well as on reboot (see /etc/init.d/reboot). Since we are still testing this, for now only in opie-image and for openzaurus distros. If that works out well, we should use it everywhere 2005/03/30 23:49:33+02:00 uni-frankfurt.de!mickeyl set Opie OTabWidget TabStyle to using text labels on hires displays - until we have hires tab icons and a sane tab height BKrev: 424bc5d2IBEsVN01WaE-JgWrsqwt2Q
Diffstat (limited to 'packages/initscripts')
-rw-r--r--packages/initscripts/initscripts-1.0/bootmisc.sh57
-rw-r--r--packages/initscripts/initscripts-1.0/halt31
-rw-r--r--packages/initscripts/initscripts-1.0/reboot17
-rw-r--r--packages/initscripts/initscripts_1.0.bb2
4 files changed, 106 insertions, 1 deletions
diff --git a/packages/initscripts/initscripts-1.0/bootmisc.sh b/packages/initscripts/initscripts-1.0/bootmisc.sh
index e69de29bb2..bd8a0721f1 100644
--- a/packages/initscripts/initscripts-1.0/bootmisc.sh
+++ b/packages/initscripts/initscripts-1.0/bootmisc.sh
@@ -0,0 +1,57 @@
+#
+# bootmisc.sh Miscellaneous things to be done during bootup.
+#
+
+. /etc/default/rcS
+#
+# Put a nologin file in /etc to prevent people from logging in before
+# system startup is complete.
+#
+if test "$DELAYLOGIN" = yes
+then
+ echo "System bootup in progress - please wait" > /etc/nologin
+ cp /etc/nologin /etc/nologin.boot
+fi
+
+#
+# Set pseudo-terminal access permissions.
+#
+if ( ! grep -q devfs /proc/mounts ) && test -c /dev/ttyp0
+then
+ chmod 666 /dev/tty[p-za-e][0-9a-f]
+ chown root:tty /dev/tty[p-za-e][0-9a-f]
+fi
+
+#
+# Update /etc/motd.
+#
+if test "$EDITMOTD" != no
+then
+ uname -a > /etc/motd.tmp
+ sed 1d /etc/motd >> /etc/motd.tmp
+ mv /etc/motd.tmp /etc/motd
+fi
+
+#
+# This is as good a place as any for a sanity check
+# /tmp should be a symlink to /var/tmp to cut down on the number
+# of mounted ramdisks.
+if test ! -L /tmp && test -d /var/tmp
+then
+ rm -rf /tmp
+ ln -sf /var/tmp tmp
+fi
+
+#
+# Update dynamic library cache
+#
+/sbin/ldconfig
+
+#
+# Recover the time, if there is a time file
+#
+if test -e /etc/timestamp
+then
+ date -s `cat /etc/timestamp`
+fi
+: exit 0
diff --git a/packages/initscripts/initscripts-1.0/halt b/packages/initscripts/initscripts-1.0/halt
index e69de29bb2..aa1769606a 100644
--- a/packages/initscripts/initscripts-1.0/halt
+++ b/packages/initscripts/initscripts-1.0/halt
@@ -0,0 +1,31 @@
+#! /bin/sh
+#
+# halt Execute the halt command.
+#
+# Version: @(#)halt 2.84-2 07-Jan-2002 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# Update the timestamp, if there is already one
+if test -e /etc/timestamp
+then
+ date +%2m%2d%2H%2M%Y > /etc/timestamp
+fi
+
+# See if we need to cut the power.
+if test -x /etc/init.d/ups-monitor
+then
+ /etc/init.d/ups-monitor poweroff
+fi
+
+# Don't shut down drives if we're using RAID.
+hddown="-h"
+if grep -qs '^md.*active' /proc/mdstat
+then
+ hddown=""
+fi
+
+halt -d -f -i -p $hddown
+
+: exit 0
diff --git a/packages/initscripts/initscripts-1.0/reboot b/packages/initscripts/initscripts-1.0/reboot
index e69de29bb2..7f95255bd9 100644
--- a/packages/initscripts/initscripts-1.0/reboot
+++ b/packages/initscripts/initscripts-1.0/reboot
@@ -0,0 +1,17 @@
+#! /bin/sh
+#
+# reboot Execute the reboot command.
+#
+# Version: @(#)reboot 2.75 22-Jun-1998 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# Update the timestamp, if there is one
+if test -e /etc/timestamp
+then
+ date +%2m%2d%2H%2M%Y > /etc/timestamp
+fi
+
+echo -n "Rebooting... "
+reboot -d -f -i
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index d5e9b5ee30..4d10dcf399 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "makedevs"
DEPENDS_openzaurus = "makedevs virtual/kernel"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r37"
+PR = "r38"
SRC_URI = "file://halt \
file://ramdisk \