summaryrefslogtreecommitdiff
path: root/packages/initscripts/initscripts_1.0.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/initscripts/initscripts_1.0.bb
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/initscripts/initscripts_1.0.bb')
-rw-r--r--packages/initscripts/initscripts_1.0.bb112
1 files changed, 56 insertions, 56 deletions
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index 2003c63094..076a69576c 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -63,80 +63,80 @@ do_install () {
${D}/${sysconfdir}/rc6.d \
${D}/${sysconfdir}/default
- install -m 0755 ${WORKDIR}/bootmisc.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/checkroot.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/finish ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/halt ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/hostname.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/mountall.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/mountnfs.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/ramdisk ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/reboot ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/rmnologin ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/sendsigs ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/single ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/umountnfs.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/urandom ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/devpts.sh ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/devpts ${D}/etc/default
- install -m 0755 ${WORKDIR}/sysfs.sh ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/bootmisc.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/checkroot.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/finish ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/halt ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/hostname.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/mountall.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/mountnfs.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/ramdisk ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/reboot ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/rmnologin ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/sendsigs ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/single ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/umountnfs.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/urandom ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/devpts.sh ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/devpts ${D}/${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/sysfs.sh ${D}/${sysconfdir}/init.d
if [ "${TARGET_ARCH}" = "arm" ]; then
- install -m 0755 ${WORKDIR}/alignment.sh ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/alignment.sh ${D}/${sysconfdir}/init.d
fi
#
# Install device dependent scripts
#
if [ "${DISTRO}" == "openzaurus" ]; then
- cat ${WORKDIR}/checkversion | sed -e "s,VERSION,${KERNEL_VERSION}-${DISTRO_VERSION}," > ${D}/etc/init.d/checkversion
- chmod 0755 ${D}/etc/init.d/checkversion
- ln -sf ../init.d/checkversion ${D}/etc/rcS.d/S00version
+ cat ${WORKDIR}/checkversion | sed -e "s,VERSION,${KERNEL_VERSION}-${DISTRO_VERSION}," > ${D}/${sysconfdir}/init.d/checkversion
+ chmod 0755 ${D}/${sysconfdir}/init.d/checkversion
+ ln -sf ../init.d/checkversion ${D}/${sysconfdir}/rcS.d/S00version
fi
if [ "${MACHINE}" == "c7x0" ]; then
- install -m 0755 ${WORKDIR}/corgikeymap-2.6.map ${D}/etc
- install -m 0755 ${WORKDIR}/keymap ${D}/etc/init.d
- ln -sf ../init.d/keymap ${D}/etc/rcS.d/S04keymap
+ install -m 0755 ${WORKDIR}/corgikeymap-2.6.map ${D}/${sysconfdir}
+ install -m 0755 ${WORKDIR}/keymap ${D}/${sysconfdir}/init.d
+ ln -sf ../init.d/keymap ${D}/${sysconfdir}/rcS.d/S04keymap
fi
- install -m 0755 ${WORKDIR}/banner ${D}/etc/init.d/banner
- install -m 0755 ${WORKDIR}/devices ${D}/etc/init.d/devices
- install -m 0755 ${WORKDIR}/umountfs ${D}/etc/init.d/umountfs
+ install -m 0755 ${WORKDIR}/banner ${D}/${sysconfdir}/init.d/banner
+ install -m 0755 ${WORKDIR}/devices ${D}/${sysconfdir}/init.d/devices
+ install -m 0755 ${WORKDIR}/umountfs ${D}/${sysconfdir}/init.d/umountfs
#
# Create runlevel links
#
- ln -sf ../init.d/rmnologin ${D}/etc/rc2.d/S99rmnologin
- ln -sf ../init.d/rmnologin ${D}/etc/rc3.d/S99rmnologin
- ln -sf ../init.d/rmnologin ${D}/etc/rc4.d/S99rmnologin
- ln -sf ../init.d/rmnologin ${D}/etc/rc5.d/S99rmnologin
- ln -sf ../init.d/sendsigs ${D}/etc/rc6.d/S20sendsigs
-# ln -sf ../init.d/urandom ${D}/etc/rc6.d/S30urandom
- ln -sf ../init.d/umountnfs.sh ${D}/etc/rc6.d/S31umountnfs.sh
-# ln -sf ../init.d/umountfs ${D}/etc/rc6.d/S40umountfs
- ln -sf ../init.d/ramdisk ${D}/etc/rcS.d/S30ramdisk
- ln -sf ../init.d/reboot ${D}/etc/rc6.d/S90reboot
- ln -sf ../init.d/sendsigs ${D}/etc/rc0.d/S20sendsigs
-# ln -sf ../init.d/urandom ${D}/etc/rc0.d/S30urandom
- ln -sf ../init.d/umountnfs.sh ${D}/etc/rc0.d/S31umountnfs.sh
-# ln -sf ../init.d/umountfs ${D}/etc/rc0.d/S40umountfs
- ln -sf ../init.d/halt ${D}/etc/rc0.d/S90halt
- ln -sf ../init.d/banner ${D}/etc/rcS.d/S01banner
- ln -sf ../init.d/checkroot.sh ${D}/etc/rcS.d/S10checkroot.sh
-# ln -sf ../init.d/checkfs.sh ${D}/etc/rcS.d/S30checkfs.sh
- ln -sf ../init.d/mountall.sh ${D}/etc/rcS.d/S35mountall.sh
- ln -sf ../init.d/hostname.sh ${D}/etc/rcS.d/S40hostname.sh
- ln -sf ../init.d/mountnfs.sh ${D}/etc/rcS.d/S45mountnfs.sh
- ln -sf ../init.d/bootmisc.sh ${D}/etc/rcS.d/S55bootmisc.sh
-# ln -sf ../init.d/urandom ${D}/etc/rcS.d/S55urandom
- ln -sf ../init.d/finish ${D}/etc/rcS.d/S99finish
- ln -sf ../init.d/devices ${D}/etc/rcS.d/S04devices
+ ln -sf ../init.d/rmnologin ${D}/${sysconfdir}/rc2.d/S99rmnologin
+ ln -sf ../init.d/rmnologin ${D}/${sysconfdir}/rc3.d/S99rmnologin
+ ln -sf ../init.d/rmnologin ${D}/${sysconfdir}/rc4.d/S99rmnologin
+ ln -sf ../init.d/rmnologin ${D}/${sysconfdir}/rc5.d/S99rmnologin
+ ln -sf ../init.d/sendsigs ${D}/${sysconfdir}/rc6.d/S20sendsigs
+# ln -sf ../init.d/urandom ${D}/${sysconfdir}/rc6.d/S30urandom
+ ln -sf ../init.d/umountnfs.sh ${D}/${sysconfdir}/rc6.d/S31umountnfs.sh
+# ln -sf ../init.d/umountfs ${D}/${sysconfdir}/rc6.d/S40umountfs
+ ln -sf ../init.d/ramdisk ${D}/${sysconfdir}/rcS.d/S30ramdisk
+ ln -sf ../init.d/reboot ${D}/${sysconfdir}/rc6.d/S90reboot
+ ln -sf ../init.d/sendsigs ${D}/${sysconfdir}/rc0.d/S20sendsigs
+# ln -sf ../init.d/urandom ${D}/${sysconfdir}/rc0.d/S30urandom
+ ln -sf ../init.d/umountnfs.sh ${D}/${sysconfdir}/rc0.d/S31umountnfs.sh
+# ln -sf ../init.d/umountfs ${D}/${sysconfdir}/rc0.d/S40umountfs
+ ln -sf ../init.d/halt ${D}/${sysconfdir}/rc0.d/S90halt
+ ln -sf ../init.d/banner ${D}/${sysconfdir}/rcS.d/S01banner
+ ln -sf ../init.d/checkroot.sh ${D}/${sysconfdir}/rcS.d/S10checkroot.sh
+# ln -sf ../init.d/checkfs.sh ${D}/${sysconfdir}/rcS.d/S30checkfs.sh
+ ln -sf ../init.d/mountall.sh ${D}/${sysconfdir}/rcS.d/S35mountall.sh
+ ln -sf ../init.d/hostname.sh ${D}/${sysconfdir}/rcS.d/S40hostname.sh
+ ln -sf ../init.d/mountnfs.sh ${D}/${sysconfdir}/rcS.d/S45mountnfs.sh
+ ln -sf ../init.d/bootmisc.sh ${D}/${sysconfdir}/rcS.d/S55bootmisc.sh
+# ln -sf ../init.d/urandom ${D}/${sysconfdir}/rcS.d/S55urandom
+ ln -sf ../init.d/finish ${D}/${sysconfdir}/rcS.d/S99finish
+ ln -sf ../init.d/devices ${D}/${sysconfdir}/rcS.d/S04devices
# udev will run at S03 if installed
- ln -sf ../init.d/sysfs.sh ${D}/etc/rcS.d/S02sysfs
- ln -sf ../init.d/devpts.sh ${D}/etc/rcS.d/S38devpts.sh
+ ln -sf ../init.d/sysfs.sh ${D}/${sysconfdir}/rcS.d/S02sysfs
+ ln -sf ../init.d/devpts.sh ${D}/${sysconfdir}/rcS.d/S38devpts.sh
if [ "${TARGET_ARCH}" = "arm" ]; then
- ln -sf ../init.d/alignment.sh ${D}/etc/rcS.d/S05alignment
+ ln -sf ../init.d/alignment.sh ${D}/${sysconfdir}/rcS.d/S05alignment
fi
- install -m 0755 ${WORKDIR}/device_table.txt ${D}/etc/device_table
+ install -m 0755 ${WORKDIR}/device_table.txt ${D}/${sysconfdir}/device_table
}