summaryrefslogtreecommitdiff
path: root/packages/initscripts/initscripts_1.0.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-15 01:42:06 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-15 01:42:06 +0000
commit82d760995f1a72fff24cfbc4f544878a14a2312d (patch)
tree5324ac0a1840ed5f7047b204084ca61bac29031f /packages/initscripts/initscripts_1.0.bb
parenteb58ba04e02ae24fe01debb64c1edd6e96d12810 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/15 02:42:05+01:00 vanille.de!mickeyl initscript: remove bogus and do it properly 2005/01/15 02:29:55+01:00 vanille.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into allanon.vanille.de:/local/pkg/oe/packages 2005/01/15 02:29:35+01:00 vanille.de!mickeyl fix dependency error in initscripts 2005/01/15 00:32:06+00:00 nexus.co.uk!pb remove error-dialog patch from gtk+ 2.4.13 as well 2005/01/15 00:31:01+00:00 nexus.co.uk!pb remove accidentally-included patch for gtk+ error box title 2005/01/15 00:28:40+00:00 nexus.co.uk!pb add workaround for gtk+ RTL bug #164125 2005/01/14 23:39:54+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2005/01/14 23:36:46+00:00 nexus.co.uk!pb banish bootlogd to eponymous package BKrev: 41e874ee05NaESBQ2krTEcTxw7Cvvw
Diffstat (limited to 'packages/initscripts/initscripts_1.0.bb')
-rw-r--r--packages/initscripts/initscripts_1.0.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index af2ae26822..06aa140a5e 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "makedevs"
DEPENDS_openzaurus = "virtual/kernel"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r27"
+PR = "r28"
SRC_URI = "file://halt \
file://ramdisk \
@@ -34,7 +34,15 @@ SRC_URI = "file://halt \
SRC_URI_append_arm = " file://alignment.sh"
SRC_URI_append_openzaurus = " file://checkversion"
-KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
+def read_kernel_version(d):
+ import bb
+ distro = bb.data.getVar('DISTRO', d, 1)
+ filename = bb.data.getVar('STAGING_KERNEL_DIR', d, 1)
+ if distro == "openzaurus":
+ return file( filename + "/kernel-abiversion", "r" ).read().strip()
+ else:
+ return "not important"
+KERNEL_VERSION = "${@read_kernel_version(d)}"
do_install () {
#