summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-11-15 18:23:17 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-15 18:23:17 +0100
commita25da5c491ac2a3820be7aaa7fa507fe7ca8b354 (patch)
treed8162d4d8d6aaf5f129e203b6bc9d3ccead522f7 /packages/images
parent9e167064390ce3bff7425be5c002ed3f1e7eb1d1 (diff)
parent828ced10e6eaf2048a8fd7ee7263807fab9d784d (diff)
Merge commit 'origin/org.openembedded.dev' into holger/openmoko-merges
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/beagleboard-demo-image.bb2
-rw-r--r--packages/images/fso-console-image.bb11
-rw-r--r--packages/images/fso-illume-image.bb82
-rw-r--r--packages/images/fso-image-nox.bb113
-rw-r--r--packages/images/fso-image.bb81
-rw-r--r--packages/images/x11-sato-image.bb4
6 files changed, 227 insertions, 66 deletions
diff --git a/packages/images/beagleboard-demo-image.bb b/packages/images/beagleboard-demo-image.bb
index d746f0d9d0..4a4b33f4d0 100644
--- a/packages/images/beagleboard-demo-image.bb
+++ b/packages/images/beagleboard-demo-image.bb
@@ -39,6 +39,8 @@ IMAGE_INSTALL = "\
gnome-games \
rt73-firmware zd1211-firmware \
stalonetray \
+ synergy \
+ x11vnc \
"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/packages/images/fso-console-image.bb b/packages/images/fso-console-image.bb
index 2c168b7e19..04d9d23afc 100644
--- a/packages/images/fso-console-image.bb
+++ b/packages/images/fso-console-image.bb
@@ -1,13 +1,12 @@
#------------------------------------------------------
-# freesmartphone.org Console Image Recipe
+# FSO compliant Console Image Recipe
#------------------------------------------------------
require fso-image.bb
IMAGE_INSTALL = "\
- ${BASE_INSTALL} \
- ${AUDIO_INSTALL} \
- ${TOOLS_INSTALL} \
- ${PYTHON_INSTALL} \
- frameworkd \
+ task-base \
+ task-fso-compliance \
+ task-cli-tools \
+ task-cli-tools-python \
"
diff --git a/packages/images/fso-illume-image.bb b/packages/images/fso-illume-image.bb
new file mode 100644
index 0000000000..a2bdda5e47
--- /dev/null
+++ b/packages/images/fso-illume-image.bb
@@ -0,0 +1,82 @@
+#------------------------------------------------------
+# FSO compliant Illume Image Recipe
+#------------------------------------------------------
+
+require fso-image.bb
+
+PV = "1.0"
+PR = "r1"
+
+# no languages for now
+IMAGE_LINGUAS = ""
+
+BASE_INSTALL = "\
+ task-base \
+"
+
+ILLUME_THEME = "illume-theme-fso"
+
+X_INSTALL = "\
+ task-x11-illume \
+ task-fonts-truetype-core \
+"
+
+X_INSTALL_append_om-gta02 = "\
+ task-fonts-truetype-chinese \
+ task-fonts-truetype-japanese \
+"
+
+# tools
+TOOLS_INSTALL = "\
+ task-cli-tools \
+ task-cli-tools-python \
+"
+
+# audio
+AUDIO_INSTALL = "\
+ alsa-oss \
+ alsa-state \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ gst-meta-audio \
+ gst-plugin-modplug \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-sid', d)} \
+ fso-sounds \
+"
+
+GTK_INSTALL = "\
+ xterm \
+ gpe-scap \
+"
+
+# FIXME these should rather be part of alsa-state,
+# once Om stabilizes them...
+AUDIO_INSTALL_append_om-gta01 = "\
+ openmoko-alsa-scenarios \
+"
+AUDIO_INSTALL_append_om-gta02 = "\
+ openmoko-alsa-scenarios \
+"
+
+# python
+PYTHON_INSTALL = "\
+ task-python-efl \
+ python-codecs \
+ python-gst \
+"
+
+# fso
+FSO_INSTALL = "\
+ task-fso-compliance \
+"
+
+IMAGE_INSTALL = "\
+ ${BASE_INSTALL} \
+ ${X_INSTALL} \
+ ${GTK_INSTALL} \
+ ${GAMES_INSTALL} \
+ ${AUDIO_INSTALL} \
+ ${TOOLS_INSTALL} \
+ ${PYTHON_INSTALL} \
+ ${FSO_INSTALL} \
+"
diff --git a/packages/images/fso-image-nox.bb b/packages/images/fso-image-nox.bb
new file mode 100644
index 0000000000..056982e1b0
--- /dev/null
+++ b/packages/images/fso-image-nox.bb
@@ -0,0 +1,113 @@
+#------------------------------------------------------
+# freesmartphone.org Image Recipe, No-x11 Edition
+#------------------------------------------------------
+
+PR = "r1.0"
+
+require fso-image.bb
+
+export IMAGE_BASENAME = "fso-image-nox"
+
+# The packages below should ideally be a subset of the
+# full fso-image. But unfortunately, the granularity
+# and some of the assumptions of the fso image do not
+# yet permit that. The gating factor is that this
+# particular image needs to include the necessary stuff
+# so that Qt Extended can run, but not so much that
+# it can no longer fit in the small flash available on
+# the GTA01. So, in practice this means that we will
+# need some X libs (for dbus at a minimum), but we need
+# to ensure that we limit that as much as possible.
+#
+# (There is little doubt that as the software stacks
+# mature, the GTA01 will need to become SD-card based.
+# Never-the-less, it is desirable to keep this as small
+# as possible for as long as possible.)
+#
+# Note: if packages are _added_ to this image, it is
+# important to also add the -dev versions of that
+# package to the toolchain, if applicable. In general,
+# _adding_ packages to this file is a bad idea; this
+# image should be a proper subset of the full fso image.
+#
+
+AUDIO_NOX_INSTALL = "\
+ alsa-oss \
+ alsa-state \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ openmoko-alsa-scenarios \
+"
+
+# python - just pull in some basics for now. Ideally we would like
+# to be able to run parts of the framework, but that's a future, and
+# would almost certainly require an SD card on the GTA01. So just
+# add the basics so that we at least have a scripting language.
+##
+# (I'm really of two minds on this; removing python is a big
+# win in terms of flash space, and I'm not sure how useful this
+# small set is. Need comments from others. --- MJW)
+
+PYTHON_NOX_INSTALL = "\
+ python-dbus \
+ python-pygobject \
+"
+
+# Tools - carefully picked so that we don't pull in too much.
+# This list should be edited -- in particular, s3c24xx-gpio is large
+# and statically linked. If not needed, we can save some flash on the
+# GTA01 by getting rid of it in the base image. Other candidates
+# might include nano, mickeydbus, powertop, sysstat, and tcpdump.
+
+TOOLS_NOX_INSTALL = "\
+ dosfstools \
+ htop \
+ iptables \
+ lsof \
+ mickeydbus \
+ mtd-utils \
+ nano \
+ powertop \
+ s3c24xx-gpio \
+ sysstat \
+ tcpdump \
+"
+
+# This block is intended to pull in stuff that is normally pulled
+# in as dependencies in the full fso image. At this moment,
+# libpng12 is an exception - it slipped into the toolchain, hence
+# it needs to be here as well. It should be added to the full
+# fso image at some point.
+
+EXTRA_NOX_INSTALL = "\
+ libstdc++ \
+ tslib \
+ pointercal \
+ tzdata \
+ libpng12 \
+"
+
+IMAGE_INSTALL = "\
+ ${BASE_INSTALL} \
+ ${EXTRA_NOX_INSTALL} \
+ ${AUDIO_NOX_INSTALL} \
+ ${PYTHON_NOX_INSTALL} \
+ ${TOOLS_NOX_INSTALL} \
+"
+
+# The post-processing step for this image is where we can do some
+# cleanup to get some space back if necessary, or do other touch-up
+# work specific to this image. It is currently empty, and should
+# continue to be empty -- but it appears here because that's probably
+# unrealistic, so we might as put the placeholder here right now.
+
+fso_nox_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+ # Execute commands to tweak the rootfs here
+
+ # End commands
+ cd ${curdir}
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "fso_nox_rootfs_postprocess"
diff --git a/packages/images/fso-image.bb b/packages/images/fso-image.bb
index d0ae4039d3..b97eb5c89b 100644
--- a/packages/images/fso-image.bb
+++ b/packages/images/fso-image.bb
@@ -2,70 +2,32 @@
# freesmartphone.org Image Recipe
#------------------------------------------------------
+PV = "1.0"
+PR = "r2"
+
+# no languages for now
IMAGE_LINGUAS = ""
-# getting the base system up
BASE_INSTALL = "\
- ${MACHINE_TASK_PROVIDER} \
- netbase \
- sysfsutils \
- module-init-tools-depmod \
- rsync \
- screen \
- fbset \
- fbset-modes \
+ task-base \
"
-# Some machines don't set a *runtime* provider for X, so default to Xfbdev here
-# virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
-XSERVER ?= "xserver-kdrive-fbdev"
+ILLUME_THEME = "illume-theme-freesmartphone"
-# getting an X window system up
X_INSTALL = "\
- e-wm \
- illume \
- illume-config-illume \
- illume-dicts-english-us \
- illume-keyboards-default \
- illume-keyboards-numbers \
- illume-keyboards-terminal \
- illume-theme-freesmartphone \
- ${XSERVER} \
- xserver-kdrive-common \
- xserver-nodm-init \
- xauth \
- xhost \
- xset \
- xrandr \
- \
- fontconfig-utils \
- \
- ttf-dejavu-common \
- ttf-dejavu-sans \
- ttf-dejavu-serif \
- \
+ task-x11-illume \
+ task-fonts-truetype-core \
"
X_INSTALL_append_om-gta02 = "\
- ttf-arphic-uming \
- \
+ task-fonts-truetype-chinese \
+ task-fonts-truetype-japanese \
"
-# useful command line tools
+# tools
TOOLS_INSTALL = "\
-# bash \
- dosfstools \
- htop \
- iptables \
- lsof \
- mickeydbus \
- mickeyterm \
- mtd-utils \
- nano \
- powertop \
- s3c24xx-gpio \
- sysstat \
- tcpdump \
+ task-cli-tools \
+ task-cli-tools-python \
"
# audio
@@ -75,15 +37,14 @@ AUDIO_INSTALL = "\
alsa-utils-aplay \
alsa-utils-amixer \
gst-meta-audio \
- gst-plugin-mad \
gst-plugin-modplug \
- gst-plugin-sid \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad gst-plugin-sid', d)} \
fso-sounds \
"
GTK_INSTALL = "\
openmoko-calculator2 \
- openmoko-terminal2 \
+ vala-terminal \
gpe-scap \
tangogps \
"
@@ -108,11 +69,9 @@ PYTHON_INSTALL = "\
python-gst \
"
-# zhone
+# fso+zhone
ZHONE_INSTALL = "\
- gsm0710muxd \
- frameworkd \
- fso-gpsd \
+ task-fso-compliance \
zhone \
"
@@ -140,7 +99,7 @@ IMAGE_INSTALL = "\
inherit image
-# perform some convenience tweaks to the rootfs
+# perform some convenience tweaks to the rootfs to improve the out-of-the-box experience :M:
fso_rootfs_postprocess() {
curdir=$PWD
cd ${IMAGE_ROOTFS}
@@ -165,6 +124,10 @@ fso_rootfs_postprocess() {
echo 'gtk-font-name = "Sans 5"' >> ./etc/gtk-2.0/gtkrc
# fix strange iconv/gconf bug
ln -s libc.so.6 ./lib/libc.so
+ # set sensible DNS entries
+ echo "nameserver 208.67.222.222" > ./etc/resolv.conf
+ echo "nameserver 208.67.220.220" >> ./etc/resolv.conf
+ # back on track
cd $curdir
}
diff --git a/packages/images/x11-sato-image.bb b/packages/images/x11-sato-image.bb
index 35163953dc..0a127f85cf 100644
--- a/packages/images/x11-sato-image.bb
+++ b/packages/images/x11-sato-image.bb
@@ -1,6 +1,8 @@
DISTRO_SSH_DAEMON ?= "dropbear"
DISTRO_PACKAGE_MANAGER ?= "opkg-nogpg opkg-collateral"
+XSERVER ?= "xserver-kdrive-fbdev"
+
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
IMAGE_INSTALL = "\
@@ -13,7 +15,7 @@ IMAGE_INSTALL = "\
matchbox-desktop \
${XSERVER} \
xserver-kdrive-common xserver-nodm-init \
- ttf-liberation \
+ ttf-liberation-sans ttf-liberation-serif ttf-liberation-mono \
xauth xhost xset xrandr \
matchbox-sato \
matchbox-config-gtk \