summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-17 19:24:23 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-17 19:24:23 +0000
commitdd8734fb36d95b8faca5db0a9967f7828fc75433 (patch)
tree326a78a014ab11806f5e2b0060706e755412c1b6 /packages/images
parent3ded06f5504f9a7b60b67aa9e280c3d3da2366f8 (diff)
parent09d0c6da109b9c875800dd46ff7d848c153322f4 (diff)
merge of '093b89e2fccb4864b6f56bcb61c6455a90dc384e'
and 'a87cb9fd512dbac5e9ea1f2571e2c946278a28ad'
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/angstrom-minimal-image.bb18
-rw-r--r--packages/images/helloworld-image.bb14
2 files changed, 15 insertions, 17 deletions
diff --git a/packages/images/angstrom-minimal-image.bb b/packages/images/angstrom-minimal-image.bb
index 54f7ff2c89..90f46a1e01 100644
--- a/packages/images/angstrom-minimal-image.bb
+++ b/packages/images/angstrom-minimal-image.bb
@@ -1,10 +1,22 @@
-# Hello world image
-# gives you a small image with a statically linked
+#Angstrom minimalist image
+#gives you a small images with ssh access
LICENSE = "MIT"
PR = "r0"
-export IMAGE_BASENAME = "helloworld-image"
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+DEPENDS = "task-base \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+RDEPENDS = "task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+export IMAGE_BASENAME = "minimalist-image"
export IMAGE_LINGUAS = ""
+export PACKAGE_INSTALL = "${RDEPENDS}"
inherit image
diff --git a/packages/images/helloworld-image.bb b/packages/images/helloworld-image.bb
deleted file mode 100644
index 5154752f75..0000000000
--- a/packages/images/helloworld-image.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-# Hello world image
-# Contains *only* a statically linked hello world init program
-LICENSE = "MIT"
-PR = "r0"
-
-RDEPENDS = "helloworld"
-
-export IMAGE_BASENAME = "helloworld-image"
-export IMAGE_LINGUAS = ""
-
-PACKAGE_INSTALL = ${RDEPENDS}
-
-inherit image
-