summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-01-31 21:24:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-01-31 21:24:36 +0000
commitb20edcd38445574cbdd667d5e82fb59572e4cab2 (patch)
tree5a52d1265144694e035f2087d0495c83b69f5c9a /packages/images
parent64529f883fb70f97a28cb8fe082fb7b357d509d9 (diff)
parentd8918d114e1286ff97435a543b65d270e79a0f92 (diff)
merge of '4ea5971c2dd26e9c357b906128f0e339d80e3d50'
and 'e651c4fa9a5d1fc6120cc2309e9cba1388cecc52'
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/base-image.bb84
-rw-r--r--packages/images/initramfs-minimal-image.bb3
-rw-r--r--packages/images/minimal-gpe-image.bb25
-rw-r--r--packages/images/minimal-openmoko-image.bb21
-rw-r--r--packages/images/nas-server-image.bb53
-rw-r--r--packages/images/nslu2-base-image.bb (renamed from packages/images/nslu2-minimal-image.bb)6
-rw-r--r--packages/images/nylon-image-base.bb2
-rw-r--r--packages/images/openmoko-python-devel-image.bb6
-rw-r--r--packages/images/openprotium-image.bb134
-rw-r--r--packages/images/opie-image-16mb.bb45
-rw-r--r--packages/images/opie-image.bb47
-rw-r--r--packages/images/qtopia-core-console-image.bb19
-rw-r--r--packages/images/qtopia-core-gui-image.bb20
-rw-r--r--packages/images/unslung-image.bb14
-rw-r--r--packages/images/x11-sato-image.bb29
15 files changed, 296 insertions, 212 deletions
diff --git a/packages/images/base-image.bb b/packages/images/base-image.bb
new file mode 100644
index 0000000000..9afa682d2c
--- /dev/null
+++ b/packages/images/base-image.bb
@@ -0,0 +1,84 @@
+# This image is intended to provide a basic configuration that allows
+# you to access a newly flashed device over the network or via the
+# native console, and use ipkg to install (from feeds accessible via
+# the network) any further features you require into internal flash
+# memory or onto attached storage.
+
+# It should be as small as possible, while still achieving that goal.
+
+# The rationale for naming it 'base-image' is that this image is the
+# base upon which you can install any other functionality you desire.
+
+# See the end of this file for further rationale and policy regarding
+# the contents of this image, and the criteria which are used to make
+# decisions about adding and removing packages from this image.
+
+# Although it is only fully tested with the Angstrom distro, this
+# image is intended to be distro-agnostic.
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+# FIXME: We need a distro-indendent way of specifying feed configs.
+# Once the RFC for the DISTRO_FEED_CONFIGS variable name is approved,
+# we can remove this default definition and set it in the distro config.
+DISTRO_FEED_CONFIGS ?= "${ANGSTROM_FEED_CONFIGS}"
+
+DEPENDS = "\
+ task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ ${DISTRO_FEED_CONFIGS} \
+ ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
+ "
+
+IMAGE_INSTALL = "\
+ task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ ${DISTRO_FEED_CONFIGS} \
+ ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
+ "
+
+export IMAGE_BASENAME = "base-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+
+# Key features of this image are:
+
+# 1) Must be able to mount attached storage devices like SD cards, CF
+# cards, internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum. The rationale
+# for this is that you need storage to be able to install significant
+# new functionality.
+
+# 2) Must be able to boot from internal flash, or directly from a
+# filesystem stored on the attached storage. The rationale for this
+# is that you will want to boot from attached storage instead of
+# messing around with ipkg-link.
+
+# Rationale and policy:
+
+# 'base-image' is the smallest possible image which allows you to ssh
+# into a device via it's native network interface, and install
+# packages from feeds across the network into internal flash or onto
+# an attached storage device.
+
+# It is "larger" than minimal-image (which is strictly only that which
+# is required to boot and get ssh access to the device, and nothing
+# else), but is "smaller" than console-image (which has a whole lot of
+# stuff in it which could easily be ipkg installed after boot rather
+# than being in the initial rootfs).
+
+# It is required to always be small enough to fit in the internal
+# flash rootfs partition of an NSLU2 (as an example of the smaller end
+# of flash sizes that OE supports), and features will be removed from
+# the image to ensure that this is always the case. Any feature that
+# can be installed over the network using the package manager after
+# the first boot is always fair game for removal at any time, and
+# patches are welcome to make base-image as small as possible while
+# still retaining the ability to subsequently install that feature.
diff --git a/packages/images/initramfs-minimal-image.bb b/packages/images/initramfs-minimal-image.bb
index 1aa928b2a9..d696468913 100644
--- a/packages/images/initramfs-minimal-image.bb
+++ b/packages/images/initramfs-minimal-image.bb
@@ -1,7 +1,6 @@
# Sample initramfs image
-#IMAGE_INSTALL = "initramfs-boot busybox kernel-module-uinput uclibc libgcc1"
-IMAGE_INSTALL = "initramfs-nfsboot busybox-static kernel-module-uinput"
+IMAGE_INSTALL = "initramfs-module-nfs busybox-static"
export IMAGE_BASENAME = "initramfs-image"
IMAGE_LINGUAS = ""
diff --git a/packages/images/minimal-gpe-image.bb b/packages/images/minimal-gpe-image.bb
new file mode 100644
index 0000000000..64583741cd
--- /dev/null
+++ b/packages/images/minimal-gpe-image.bb
@@ -0,0 +1,25 @@
+#Angstrom minimal gpe image
+# This image provides a barebone dm and 'desktop'
+# Very angstrom and ipkg centric
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+export IMAGE_BASENAME = "minimalist-gpe-image"
+
+PR = "r2"
+
+DEPENDS = "task-boot"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ task-boot \
+ gpe-dm gpe-session-scripts gpe-login \
+ matchbox-wm \
+ gpe-terminal \
+ angstrom-feed-configs \
+ ipkg \
+ "
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image
diff --git a/packages/images/minimal-openmoko-image.bb b/packages/images/minimal-openmoko-image.bb
new file mode 100644
index 0000000000..6ab4935c24
--- /dev/null
+++ b/packages/images/minimal-openmoko-image.bb
@@ -0,0 +1,21 @@
+#------------------------------------------------------
+# Minimal OpenMoko Image Recipe
+# This should only have the base system + dialer
+# #------------------------------------------------------
+
+IMAGE_LINGUAS = ""
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = "\
+ task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ task-openmoko-linux \
+ task-openmoko-net \
+ task-openmoko-ui \
+ task-openmoko-base \
+ task-openmoko-phone \
+ "
+
+inherit image
+
+ROOTFS_POSTPROCESS_COMMAND += 'date "+%m%d%H%M%Y" >${IMAGE_ROOTFS}/etc/timestamp'
diff --git a/packages/images/nas-server-image.bb b/packages/images/nas-server-image.bb
new file mode 100644
index 0000000000..ca8f94e749
--- /dev/null
+++ b/packages/images/nas-server-image.bb
@@ -0,0 +1,53 @@
+# This image is intended to provide a configuration
+# for a network attached storage server device.
+
+# Key features are:
+#
+# 1) Must be able to mount attached storage devices like
+# internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum.
+#
+# 2) Must be able to boot from internal flash, or directly
+# from a filesystem stored on the attached storage.
+#
+# 3) Must be able to share that storage across the network
+# using various protocols like Samba, NFS, etc.
+#
+# 4) Bonus points for being able to support other central
+# network services like a central gateway machine might.
+
+# Although it is tested with the Angstrom distro, it is
+# intended to be distro-agnostic.
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+DEPENDS = "\
+ task-boot \
+ ${@base_contains('MACHINE_FEATURES', 'apex', 'task-base-apex', '', d)} \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
+ task-nas-server-everything \
+ "
+
+IMAGE_INSTALL_TASKS = "\
+ task-nas-server-everything \
+ "
+
+IMAGE_INSTALL = "\
+ task-boot \
+ ${@base_contains('MACHINE_FEATURES', 'apex', 'task-base-apex', '', d)} \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
+ ${IMAGE_INSTALL_TASKS} \
+ "
+
+export IMAGE_BASENAME = "nas-server-image"
+IMAGE_LINGUAS = ""
+
+inherit image
diff --git a/packages/images/nslu2-minimal-image.bb b/packages/images/nslu2-base-image.bb
index 5a601b2995..444e9f6a49 100644
--- a/packages/images/nslu2-minimal-image.bb
+++ b/packages/images/nslu2-base-image.bb
@@ -1,14 +1,14 @@
# Note that this package is intended to create an *identical*
-# kernel and rootfs as the normal minimal-image.bb
+# kernel and rootfs as the normal base-image.bb
# The only reason for the existence of this .bb file is to
# create the 8MB and 16MB flashable NSLU2 firmware images.
# Please do not add anything other than the following two
# lines to this file, and please do not do anything in
-# the nslu2-image.bb class which might affect the kernel
+# the nslu2-image class which might affect the kernel
# or rootfs.
-require minimal-image.bb
+require base-image.bb
inherit nslu2-image
diff --git a/packages/images/nylon-image-base.bb b/packages/images/nylon-image-base.bb
index b4913097be..27dc165800 100644
--- a/packages/images/nylon-image-base.bb
+++ b/packages/images/nylon-image-base.bb
@@ -8,7 +8,7 @@ NYLON_BASE = "base-files base-passwd bash busybox \
mtd-utils \
nano ncurses netbase \
openssh sysvinit \
- timezones tinylogin udev"
+ tzdata tinylogin udev"
DEPENDS += "virtual/kernel less nano"
IMAGE_INSTALL = "kernel less nano elvis-tiny \
diff --git a/packages/images/openmoko-python-devel-image.bb b/packages/images/openmoko-python-devel-image.bb
new file mode 100644
index 0000000000..9d2a8db2c6
--- /dev/null
+++ b/packages/images/openmoko-python-devel-image.bb
@@ -0,0 +1,6 @@
+require openmoko-image.bb
+
+IMAGE_INSTALL += "\
+ task-openmoko-python-devel \
+"
+
diff --git a/packages/images/openprotium-image.bb b/packages/images/openprotium-image.bb
index 818fd0b186..0f64ba2052 100644
--- a/packages/images/openprotium-image.bb
+++ b/packages/images/openprotium-image.bb
@@ -1,128 +1,28 @@
DESCRIPTION = "OpenProtium image"
HOMEPAGE = "http://www.openprotium.com"
-DEPENDS = "${MACHINE_TASK_PROVIDER}"
-EXTRA_IMAGECMD_jffs2 = "--pad --big-endian --eraseblock=0x10000 -D ${SLUGOS_DEVICE_TABLE}"
+DEPENDS = "task-openprotium"
+IMAGE_INSTALL = "task-openprotium"
IMAGE_LINGUAS = ""
-# Setting USE_DEVFS prevents *any* entries being created initially
-# in /dev
-USE_DEVFS = "1"
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}-${DISTRO_VERSION}"
+PACKAGE_REMOVE = "kernel-image-* task-openprotium"
-# This is passed to the image command to build the correct /dev
-# directory (because only the image program can make actual
-# dev entries!)
-SLUGOS_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-slugos.txt')}"
+USE_DEVFS = "1"
+OPENPROTIUM_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-minimal-add-md.txt')}"
+EXTRA_IMAGECMD_jffs2 += " -D ${OPENPROTIUM_DEVICE_TABLE}"
-# IMAGE_PREPROCESS_COMMAND is run before making the image.
-# We use this to do a few things:
-# . remove the uImage, which is in a separate part of the flash already.
-# . adjust the default run level (sysvinit is 5 by default, we like 3)
-# . set a default root password, which is no more secure than a blank one
-# (since it is documented, in case you were wondering)
-# . make the boot more verbose
-#
-IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/uImage-*;"
-IMAGE_PREPROCESS_COMMAND += "sed -i -es,^id:5:initdefault:,id:3:initdefault:, ${IMAGE_ROOTFS}/etc/inittab;"
+IMAGE_PREPROCESS_COMMAND += "install -c -m 644 ${OPENPROTIUM_DEVICE_TABLE} ${IMAGE_ROOTFS}/etc/device_table;"
+IMAGE_PREPROCESS_COMMAND += "sed -i -es,^id:5:initdefault:,id:3:initdefault:, ${IMAGE_ROOTFS}/etc/inittab;"
IMAGE_PREPROCESS_COMMAND += "sed -i -es,^root::0,root:BTMzOOAQfESg6:0, ${IMAGE_ROOTFS}/etc/passwd;"
IMAGE_PREPROCESS_COMMAND += "sed -i -es,^VERBOSE=no,VERBOSE=very, ${IMAGE_ROOTFS}/etc/default/rcS;"
+IMAGE_PREPROCESS_COMMAND += "sed -i -es,^VOLATILE_ENABLE_CACHE=yes,VOLATILE_ENABLE_CACHE=no, ${IMAGE_ROOTFS}/etc/default/rcS;"
+IMAGE_PREPROCESS_COMMAND += "sed -i -es,/dev/tty0,/dev/console, ${IMAGE_ROOTFS}/etc/init.d/populate-volatile.sh;"
+IMAGE_PREPROCESS_COMMAND += "echo /dev/md >> ${IMAGE_ROOTFS}/etc/udev/mount.blacklist;"
+IMAGE_PREPROCESS_COMMAND += "echo /dev/hd >> ${IMAGE_ROOTFS}/etc/udev/mount.blacklist;"
+IMAGE_PREPROCESS_COMMAND += "echo /dev/mtd3 0x30000 0x10000 0x10000 > ${IMAGE_ROOTFS}/etc/fw_env.config;"
-# Always just make a new flash image.
-PACK_IMAGE = 'storcenter_pack_image;'
-IMAGE_POSTPROCESS_COMMAND += "${PACK_IMAGE}"
-PACK_IMAGE_DEPENDS = ""
-#EXTRA_IMAGEDEPENDS += "${PACK_IMAGE_DEPENDS}"
-
-# This hack removes '${MACHINE}' from the end of the arch.conf for ipk,
-# preventing _mach.ipk (with no byte sex) taking precedence over everything
-# else.
-# but we want 'storcenter' in there so kernel modules work correctly.
-#
-#ROOTFS_POSTPROCESS_COMMAND += "sed -i '$d' '${IMAGE_ROOTFS}/etc/ipkg/arch.conf';"
-
-# These depends define native utilities - they do not get put in the flash and
-# are not required to build the image.
-IMAGE_TOOLS = ""
-#EXTRA_IMAGEDEPENDS += "${IMAGE_TOOLS}"
-
-# CONFIG:
-# SLUGOS_EXTRA_RDEPENDS: set in conf, things to add to the image
-# SLUGOS_SUPPORT: set to here, see below, added to the image.
-# SLUGOS_KERNEL: set here, kernel modules added to the image
-#
-# Do not override the last two unless you really know what you
-# are doing - there is more information below.
-
-# diff, cpio and find are required for reflash and turnup ram.
-# Removing these probably leaves the system bootable, but standard
-# openslug and ucslugc stuff won't work, so only take these out in
-# very non-standard turnkey slugos builds.
-#
-# udev is the default way of handling devices, there is no guarantee
-# that the static device table is completely correct (it is just
-# known to be sufficient for boot.)
-# we'ere still on 2.6.12 devfs....
-#OPENPROTIUM_SUPPORT ?= "diffutils cpio findutils udev"
-#
-OPENPROTIUM_SUPPORT ?= "diffutils cpio findutils uboot-utils"
-
-# kernel-module-af-packet must be in the image for DHCP to work
-# kernel-module-netconsole is here because it is small and is
-# highly useful on minimal systems (which really don't have anywhere
-# other than the network to output error messages!)
-SLUGOS_KERNEL ?= "kernel-module-af-packet kernel-module-netconsole \
- kernel-module-mii "
-
-# this gets /lib/modules made....
-OPENPROTIUM_KERNEL = "kernel-module-dummy \
- kernel-module-af-packet "
-
-IMAGE_INSTALL = " \
- kernel base-files base-passwd netbase \
- busybox initscripts-openprotium openprotium-init \
- update-modules sysvinit tinylogin \
- module-init-tools-depmod modutils-initscripts \
- ipkg-collateral ipkg ipkg-link \
- libgcc1 \
- portmap \
- dropbear \
- e2fsprogs-blkid \
- mdadm \
- hdparm \
- mtd-utils \
- ${OPENPROTIUM_SUPPORT} \
- ${OPENPROTIUM_KERNEL} "
-# ${SLUGOS_EXTRA_RDEPENDS}"
-
-inherit image
+ROOTFS_POSTPROCESS_COMMAND += "ipkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
-storcenter_pack_image() {
- # find latest kernel
- KERNEL=`ls -tr ${DEPLOY_DIR_IMAGE}/uImage* | tail -1`
- if [ -z "$KERNEL" ]; then
- oefatal "No kernel found in ${DEPLOY_DIR_IMAGE}. Bitbake linux-storcenter to create one."
- exit 1
- fi
- ROOTFS=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2
- OUTPUT=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.flash.img
- PADFILE=${DEPLOY_DIR_IMAGE}/padfile.zzz
- HEX_MAX_KERN_SIZE=170000
- DEC_MAX_KERN_SIZE=`echo "ibase=16; $HEX_MAX_KERN_SIZE" | bc `
- HEX_MAX_ROOT_SIZE=590000
- DEC_MAX_ROOT_SIZE=`echo "ibase=16; $HEX_MAX_ROOT_SIZE" | bc `
- KERNEL_SIZE=`ls -l $KERNEL | awk '{print $5}'`
- if [ $KERNEL_SIZE -gt $DEC_MAX_KERN_SIZE ]; then
- oefatal "Kernel too large at $KERNEL_SIZE bytes. Max is $DEC_MAX_KERN_SIZE."
- exit 1
- fi
- ROOT_SIZE=`ls -l $ROOTFS | awk '{print $5}'`
- if [ $ROOT_SIZE -gt $DEC_MAX_ROOT_SIZE ]; then
- oefatal "Rootfs is too large at $ROOT_SIZE bytes. Max is $DEC_MAX_ROOT_SIZE."
- exit 1
- fi
- PAD_SIZE=`echo "$DEC_MAX_KERN_SIZE - $KERNEL_SIZE" | bc `
- dd if=/dev/zero of=$PADFILE bs=$PAD_SIZE count=1 2>>/dev/null
- cat $KERNEL $PADFILE $ROOTFS > $OUTPUT
- rm -f $PADFILE
- ls -l $OUTPUT
-}
+inherit image concatenated-image
diff --git a/packages/images/opie-image-16mb.bb b/packages/images/opie-image-16mb.bb
index 06bcdad7e8..42bf611880 100644
--- a/packages/images/opie-image-16mb.bb
+++ b/packages/images/opie-image-16mb.bb
@@ -13,50 +13,7 @@ IMAGE_INSTALL = "task-boot \
task-opie-16mb-pim \
task-opie-irda"
-# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
-merge_feeds() {
-
- if ! test -z "${FEED_URIS}"
- then
- # Die gracefully if ipkg-collateral failed
- if ! test -e "${IMAGE_ROOTFS}/etc/ipkg.conf"
- then
- echo "[${IMAGE_ROOTFS}/etc/ipkg.conf] is missing!"
- exit 1
- fi
-
- # comment out existing feed-sources inserted by ipkg-collateral
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf | sed "s/^src\ /#src\ /" > ${IMAGE_ROOTFS}/etc/ipkg.conf_
- rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
-
- # extract, then delete destinations
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep -v "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf_
- rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
-
-
- for line in ${FEED_URIS}
- do
- # strip leading and trailing spaces/tabs, then split into name and uri
- line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
- feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
- feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"
-
- # insert new feed-sources
- echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
- done
-
- # remove temporary files and rebuild ipkg.conf
- echo "" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf.dest >> ${IMAGE_ROOTFS}/etc/ipkg.conf
- rm ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
-
- # remove -feed.conf files which are no longer needed
- cd ${IMAGE_ROOTFS}/etc/ipkg/ && rm -- *-feed.conf
- fi
-}
-
-# merge feed-sources into ipkg.conf and create /etc/timestamp from build date
+# create /etc/timestamp from build date
IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
inherit image
diff --git a/packages/images/opie-image.bb b/packages/images/opie-image.bb
index 1f1130204a..04c1f260e8 100644
--- a/packages/images/opie-image.bb
+++ b/packages/images/opie-image.bb
@@ -9,50 +9,7 @@ IMAGE_INSTALL = "${MACHINE_TASK_PROVIDER} task-opie-base task-opie-base-applets
task-opie-extra-settings \
task-opie-bluetooth task-opie-irda "
-# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
-merge_feeds() {
-
- if ! test -z "${FEED_URIS}"
- then
- # Die gracefully if ipkg-collateral failed
- if ! test -e "${IMAGE_ROOTFS}/etc/ipkg.conf"
- then
- echo "[${IMAGE_ROOTFS}/etc/ipkg.conf] is missing!"
- exit 1
- fi
-
- # comment out existing feed-sources inserted by ipkg-collateral
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf | sed "s/^src\ /#src\ /" > ${IMAGE_ROOTFS}/etc/ipkg.conf_
- rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
-
- # extract, then delete destinations
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep -v "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf_
- rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
-
-
- for line in ${FEED_URIS}
- do
- # strip leading and trailing spaces/tabs, then split into name and uri
- line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
- feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
- feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"
-
- # insert new feed-sources
- echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
- done
-
- # remove temporary files and rebuild ipkg.conf
- echo "" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
- cat ${IMAGE_ROOTFS}/etc/ipkg.conf.dest >> ${IMAGE_ROOTFS}/etc/ipkg.conf
- rm ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
-
- # remove -feed.conf files which are no longer needed
- cd ${IMAGE_ROOTFS}/etc/ipkg/ && rm -- *-feed.conf
- fi
-}
-
-# merge feed-sources into ipkg.conf and create /etc/timestamp from build date
-IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
+# create /etc/timestamp from build date
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
inherit image
diff --git a/packages/images/qtopia-core-console-image.bb b/packages/images/qtopia-core-console-image.bb
new file mode 100644
index 0000000000..62382cd11f
--- /dev/null
+++ b/packages/images/qtopia-core-console-image.bb
@@ -0,0 +1,19 @@
+#QtopiaCore 'console' image
+#gives you a small images with ssh access
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+DEPENDS = "task-boot"
+
+IMAGE_INSTALL = "task-boot \
+ util-linux-mount util-linux-umount \
+ ${DISTRO_SSH_DAEMON} \
+ angstrom-version \
+ task-qtopia-core-console \
+ "
+
+export IMAGE_BASENAME = "trolltech-qtopia-core-console-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+
diff --git a/packages/images/qtopia-core-gui-image.bb b/packages/images/qtopia-core-gui-image.bb
new file mode 100644
index 0000000000..6f3e594e62
--- /dev/null
+++ b/packages/images/qtopia-core-gui-image.bb
@@ -0,0 +1,20 @@
+#QtopiaCore 'console' image
+#gives you a small images with ssh access
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+DEPENDS = "task-boot task-qtopia-core-gui task-qtopia-core-gui"
+
+IMAGE_INSTALL = "task-boot \
+ util-linux-mount util-linux-umount \
+ ${DISTRO_SSH_DAEMON} \
+ angstrom-version \
+ task-qtopia-core-console \
+ task-qtopia-core-gui \
+ "
+
+export IMAGE_BASENAME = "trolltech-qtopia-core-gui-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index c6d4e73718..c258f4250a 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -87,3 +87,17 @@ unslung_clean_image () {
# #### End of Hack!
}
+
+
+# Override this function for unslung, since we don't need Apex.
+
+nslu2_pack_image () {
+ slugimage -p \
+ -b ${STAGING_LIBDIR}/nslu2-binaries/RedBoot \
+ -s ${STAGING_LIBDIR}/nslu2-binaries/SysConf \
+ -k ${DEPLOY_DIR_IMAGE}/zImage-${MACHINE}.bin \
+ -r Ramdisk:1,Flashdisk:${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
+ -m ${STAGING_FIRMWARE_DIR}/NPE-B \
+ -t ${STAGING_LIBDIR}/nslu2-binaries/Trailer \
+ -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}-nslu2.bin
+}
diff --git a/packages/images/x11-sato-image.bb b/packages/images/x11-sato-image.bb
new file mode 100644
index 0000000000..1204f22496
--- /dev/null
+++ b/packages/images/x11-sato-image.bb
@@ -0,0 +1,29 @@
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+IMAGE_INSTALL = "\
+ task-base-extended \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ pointercal \
+ matchbox-wm \
+ matchbox-keyboard matchbox-keyboard-applet matchbox-keyboard-im \
+ matchbox-desktop \
+ ${XSERVER} \
+ xserver-kdrive-common xserver-nodm-init \
+ ttf-liberation \
+ xauth xhost xset xrandr \
+ matchbox-sato \
+ matchbox-config-gtk \
+ matchbox-themes-gtk \
+ matchbox-applet-startup-monitor \
+ xcursor-transparent-theme \
+ sato-icon-theme \
+ settings-daemon \
+"
+
+export IMAGE_BASENAME = "${PN}"
+IMAGE_LINGUAS = ""
+
+inherit image
+