summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-12-19 10:02:27 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-12-19 10:02:27 +0000
commitc7e33ecf737e93f9ecec2cc609064bfd593f2b61 (patch)
treea657ac69b5e38e1887286933e9ae748e2267b27b /packages/images
parentef93660d2fbd162ca59457c96d7e1cea9cd8b907 (diff)
parentf871fead79da276cf252c7a9ab1b33e33119b009 (diff)
merge of '074f227db84b62ec3c531c61efcd62fc6b429dc3'
and '5af64e0f29377b9ebbc655af469dd70d6a2f6dfb'
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/base-image.bb76
-rw-r--r--packages/images/minimal-gpe-image.bb4
-rw-r--r--packages/images/minimal-openmoko-image.bb21
-rw-r--r--packages/images/nslu2-base-image.bb (renamed from packages/images/nslu2-minimal-image.bb)6
-rw-r--r--packages/images/poky-base-image.bb29
5 files changed, 132 insertions, 4 deletions
diff --git a/packages/images/base-image.bb b/packages/images/base-image.bb
new file mode 100644
index 0000000000..20a5fd9445
--- /dev/null
+++ b/packages/images/base-image.bb
@@ -0,0 +1,76 @@
+# This image is intended to provide a basic configuration that allows
+# you to access a newly flashed device over the network or via the
+# native console, and use ipkg to install (from feeds accessible via
+# the network) any further features you require into internal flash
+# memory or onto attached storage.
+
+# It should be as small as possible, while still achieving that goal.
+
+# The rationale for naming it 'base-image' is that this image is the
+# base upon which you can install any other functionality you desire.
+
+# See the end of this file for further rationale and policy regarding
+# the contents of this image, and the criteria which are used to make
+# decisions about adding and removing packages from this image.
+
+# Although it is only fully tested with the Angstrom distro, this
+# image is intended to be distro-agnostic.
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+DEPENDS = "\
+ task-boot \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ task-base-usbhost task-base-ext2 \
+ "
+
+IMAGE_INSTALL = "\
+ task-boot \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ task-base-usbhost task-base-ext2 \
+ "
+
+export IMAGE_BASENAME = "base-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+
+# Key features of this image are:
+
+# 1) Must be able to mount attached storage devices like SD cards, CF
+# cards, internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum. The rationale
+# for this is that you need storage to be able to install significant
+# new functionality.
+
+# 2) Must be able to boot from internal flash, or directly from a
+# filesystem stored on the attached storage. The rationale for this
+# is that you will want to boot from attached storage instead of
+# messing around with ipkg-link.
+
+# Rationale and policy:
+
+# 'base-image' is the smallest possible image which allows you to ssh
+# into a device via it's native network interface, and install
+# packages from feeds across the network into internal flash or onto
+# an attached storage device.
+
+# It is "larger" than minimal-image (which is strictly only that which
+# is required to boot and get ssh access to the device, and nothing
+# else), but is "smaller" than console-image (which has a whole lot of
+# stuff in it which could easily be ipkg installed after boot rather
+# than being in the initial rootfs).
+
+# It is required to always be small enough to fit in the internal
+# flash rootfs partition of an NSLU2 (as an example of the smaller end
+# of flash sizes that OE supports), and features will be removed from
+# the image to ensure that this is always the case. Any feature that
+# can be installed over the network using the package manager after
+# the first boot is always fair game for removal at any time, and
+# patches are welcome to make base-image as small as possible while
+# still retaining the ability to subsequently install that feature.
diff --git a/packages/images/minimal-gpe-image.bb b/packages/images/minimal-gpe-image.bb
index 356070f5f8..3f475567d2 100644
--- a/packages/images/minimal-gpe-image.bb
+++ b/packages/images/minimal-gpe-image.bb
@@ -6,11 +6,13 @@ XSERVER ?= "xserver-kdrive-fbdev"
export IMAGE_BASENAME = "minimalist-gpe-image"
+PR = "r1"
+
DEPENDS = "task-boot"
IMAGE_INSTALL = "\
${XSERVER} \
task-boot \
- gpe-session-scripts gpe-login \
+ gpe-dm gpe-session-scripts gpe-login \
matchbox-wm \
angstrom-feed-configs \
ipkg \
diff --git a/packages/images/minimal-openmoko-image.bb b/packages/images/minimal-openmoko-image.bb
new file mode 100644
index 0000000000..6ab4935c24
--- /dev/null
+++ b/packages/images/minimal-openmoko-image.bb
@@ -0,0 +1,21 @@
+#------------------------------------------------------
+# Minimal OpenMoko Image Recipe
+# This should only have the base system + dialer
+# #------------------------------------------------------
+
+IMAGE_LINGUAS = ""
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = "\
+ task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ task-openmoko-linux \
+ task-openmoko-net \
+ task-openmoko-ui \
+ task-openmoko-base \
+ task-openmoko-phone \
+ "
+
+inherit image
+
+ROOTFS_POSTPROCESS_COMMAND += 'date "+%m%d%H%M%Y" >${IMAGE_ROOTFS}/etc/timestamp'
diff --git a/packages/images/nslu2-minimal-image.bb b/packages/images/nslu2-base-image.bb
index 5a601b2995..444e9f6a49 100644
--- a/packages/images/nslu2-minimal-image.bb
+++ b/packages/images/nslu2-base-image.bb
@@ -1,14 +1,14 @@
# Note that this package is intended to create an *identical*
-# kernel and rootfs as the normal minimal-image.bb
+# kernel and rootfs as the normal base-image.bb
# The only reason for the existence of this .bb file is to
# create the 8MB and 16MB flashable NSLU2 firmware images.
# Please do not add anything other than the following two
# lines to this file, and please do not do anything in
-# the nslu2-image.bb class which might affect the kernel
+# the nslu2-image class which might affect the kernel
# or rootfs.
-require minimal-image.bb
+require base-image.bb
inherit nslu2-image
diff --git a/packages/images/poky-base-image.bb b/packages/images/poky-base-image.bb
new file mode 100644
index 0000000000..0980fc46bf
--- /dev/null
+++ b/packages/images/poky-base-image.bb
@@ -0,0 +1,29 @@
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+IMAGE_INSTALL = "\
+ task-base-extended \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ pointercal \
+ matchbox-wm \
+ matchbox-keyboard matchbox-keyboard-applet matchbox-keyboard-im \
+ matchbox-desktop \
+ ${XSERVER} \
+ xserver-kdrive-common xserver-nodm-init \
+ ttf-liberation \
+ xauth xhost xset xrandr \
+ matchbox-sato \
+ matchbox-config-gtk \
+ matchbox-themes-gtk \
+ matchbox-applet-startup-monitor \
+ xcursor-transparent-theme \
+ sato-icon-theme \
+ settings-daemon \
+"
+
+export IMAGE_BASENAME = "poky-base-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+