summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 16:31:13 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 16:31:13 +0000
commit435dc70aa0e43b448804045a9aa358856bc67bb8 (patch)
treeda9e14804b9b0a0b0bc0989906fb00525e7dc1bb /packages/images
parentdcd01b049d371444c3ca32639c08db28df8fe400 (diff)
helloworld: package plus image for truly minimal user space, a statically linked hello world executable.
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/angstrom-minimal-image.bb18
-rw-r--r--packages/images/helloworld-image.bb14
2 files changed, 17 insertions, 15 deletions
diff --git a/packages/images/angstrom-minimal-image.bb b/packages/images/angstrom-minimal-image.bb
index 90f46a1e01..54f7ff2c89 100644
--- a/packages/images/angstrom-minimal-image.bb
+++ b/packages/images/angstrom-minimal-image.bb
@@ -1,22 +1,10 @@
-#Angstrom minimalist image
-#gives you a small images with ssh access
+# Hello world image
+# gives you a small image with a statically linked
LICENSE = "MIT"
PR = "r0"
-ANGSTROM_EXTRA_INSTALL ?= ""
-DISTRO_SSH_DAEMON ?= "dropbear"
-
-DEPENDS = "task-base \
- ${DISTRO_SSH_DAEMON} \
- "
-
-RDEPENDS = "task-boot \
- ${DISTRO_SSH_DAEMON} \
- "
-
-export IMAGE_BASENAME = "minimalist-image"
+export IMAGE_BASENAME = "helloworld-image"
export IMAGE_LINGUAS = ""
-export PACKAGE_INSTALL = "${RDEPENDS}"
inherit image
diff --git a/packages/images/helloworld-image.bb b/packages/images/helloworld-image.bb
new file mode 100644
index 0000000000..5154752f75
--- /dev/null
+++ b/packages/images/helloworld-image.bb
@@ -0,0 +1,14 @@
+# Hello world image
+# Contains *only* a statically linked hello world init program
+LICENSE = "MIT"
+PR = "r0"
+
+RDEPENDS = "helloworld"
+
+export IMAGE_BASENAME = "helloworld-image"
+export IMAGE_LINGUAS = ""
+
+PACKAGE_INSTALL = ${RDEPENDS}
+
+inherit image
+