summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-09 21:38:01 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-09 21:38:01 +0000
commitb6ae1290d940b748aea399d57506e7cb853980a2 (patch)
treec797a785064711006c7717a9217df9d9e7755341 /packages/images
parenta85f58a9138734421bcf7f15a05aaa8e937bcdda (diff)
remove openturbostation distro, add foonas
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/foonas-image.bb (renamed from packages/images/openturbostation-image.bb)56
-rw-r--r--packages/images/openprotium-image.bb7
2 files changed, 12 insertions, 51 deletions
diff --git a/packages/images/openturbostation-image.bb b/packages/images/foonas-image.bb
index 512a15441a..f5a258b3d9 100644
--- a/packages/images/openturbostation-image.bb
+++ b/packages/images/foonas-image.bb
@@ -1,16 +1,11 @@
-DESCRIPTION = "Turbostation image"
-HOMEPAGE = "http://www.kynisk.com/opents"
-LICENSE = "MIT"
+DESCRIPTION = "Foonas image"
+LICENSE = "GPL"
PR = "r0"
DEPENDS = "${MACHINE_TASK_PROVIDER}"
EXTRA_IMAGECMD_jffs2 = "--big-endian --eraseblock=${ERASEBLOCK_SIZE} -D ${SLUGOS_DEVICE_TABLE}"
IMAGE_LINGUAS = ""
-# Setting USE_DEVFS prevents *any* entries being created initially
-# in /dev
-#USE_DEVFS = "1"
-
# This is passed to the image command to build the correct /dev
# directory (because only the image program can make actual
# dev entries!)
@@ -29,55 +24,25 @@ IMAGE_PREPROCESS_COMMAND += "sed -i -es,^root::0,root:BTMzOOAQfESg6:0, ${IMAGE_R
IMAGE_PREPROCESS_COMMAND += "sed -i -es,^VERBOSE=no,VERBOSE=very, ${IMAGE_ROOTFS}/etc/default/rcS;"
# Always just make a new flash image.
-PACK_IMAGE = 'turbostation_pack_image;'
+PACK_IMAGE = '${MACHINE}_pack_image;'
IMAGE_POSTPROCESS_COMMAND += "${PACK_IMAGE}"
PACK_IMAGE_DEPENDS = ""
#EXTRA_IMAGEDEPENDS += "${PACK_IMAGE_DEPENDS}"
-# This hack removes '${MACHINE}' from the end of the arch.conf for ipk,
-# preventing _mach.ipk (with no byte sex) taking precedence over everything
-# else.
-# but we want 'storcenter' in there so kernel modules work correctly.
-#
-#ROOTFS_POSTPROCESS_COMMAND += "sed -i '$d' '${IMAGE_ROOTFS}/etc/ipkg/arch.conf';"
-
# These depends define native utilities - they do not get put in the flash and
# are not required to build the image.
IMAGE_TOOLS = ""
#EXTRA_IMAGEDEPENDS += "${IMAGE_TOOLS}"
-OPENTURBOSTATION_KERNEL = ""
-# CONFIG:
-# SLUGOS_EXTRA_RDEPENDS: set in conf, things to add to the image
-# SLUGOS_SUPPORT: set to here, see below, added to the image.
-# SLUGOS_KERNEL: set here, kernel modules added to the image
-#
-# Do not override the last two unless you really know what you
-# are doing - there is more information below.
-
-# diff, cpio and find are required for reflash and turnup ram.
-# Removing these probably leaves the system bootable, but standard
-# openslug and ucslugc stuff won't work, so only take these out in
-# very non-standard turnkey slugos builds.
-#
-# udev is the default way of handling devices, there is no guarantee
-# that the static device table is completely correct (it is just
-# known to be sufficient for boot.)
-# we'ere still on 2.6.12 devfs....
-#OPENPROTIUM_SUPPORT ?= "diffutils cpio findutils udev"
-#
-OPENTURBOSTATION_SUPPORT ?= "diffutils cpio findutils uboot-utils udev"
-
-# kernel-module-af-packet must be in the image for DHCP to work
-# kernel-module-netconsole is here because it is small and is
-# highly useful on minimal systems (which really don't have anywhere
-# other than the network to output error messages!)
+FOONAS_SUPPORT += "diffutils cpio findutils uboot-utils udev"
# this gets /lib/modules made....
+FOONAS_KERNEL = "kernel-module-ext3 kernel-module-minix \
+ kernel-module-usb-storage"
RDEPENDS = " \
base-files base-passwd netbase \
- busybox initscripts-openturbostation openturbostation-init \
+ busybox initscripts foonas-init \
update-modules sysvinit tinylogin \
module-init-tools-depmod modutils-initscripts \
ipkg-collateral ipkg ipkg-link \
@@ -88,15 +53,16 @@ RDEPENDS = " \
mdadm \
hdparm \
mtd-utils \
- xfsprogs \
udev \
- ${OPENTURBOSTATION_SUPPORT} \
- ${OPENTURBOSTATION_KERNEL} "
+ ${FOONAS_SUPPORT} \
+ ${FOONAS_KERNEL} "
PACKAGE_INSTALL = "${RDEPENDS}"
inherit image
+# At this point you have to make a ${MACHINE}_pack_image for your machine.
+
turbostation_pack_image() {
# find latest kernel
KERNEL=`ls -tr ${DEPLOY_DIR_IMAGE}/uImage* | tail -1`
diff --git a/packages/images/openprotium-image.bb b/packages/images/openprotium-image.bb
index 472000f4f0..25d38cf1c3 100644
--- a/packages/images/openprotium-image.bb
+++ b/packages/images/openprotium-image.bb
@@ -83,7 +83,7 @@ RDEPENDS = " \
kernel base-files base-passwd netbase \
busybox initscripts-openprotium openprotium-init \
update-modules sysvinit tinylogin \
- module-init-tools modutils-initscripts \
+ module-init-tools-depmod modutils-initscripts \
ipkg-collateral ipkg ipkg-link \
libgcc1 \
portmap \
@@ -92,11 +92,6 @@ RDEPENDS = " \
mdadm \
hdparm \
mtd-utils \
- sccd \
- util-linux-mount \
- util-linux-umount \
- util-linux-swaponoff \
- util-linux-losetup \
${OPENPROTIUM_SUPPORT} \
${OPENPROTIUM_KERNEL} "
# ${SLUGOS_EXTRA_RDEPENDS}"