summaryrefslogtreecommitdiff
path: root/packages/images
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-08-01 19:54:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-08-01 19:54:29 +0000
commitbc5e0f85b578dfcf823c614f50df2d47a1bfade7 (patch)
treeffc6e480e5b5ef0b4211c85ac3e89344c65db203 /packages/images
parent05322108768afa2e5a439f99bfd6f6431141e0f8 (diff)
parent394fadfbbe27b53e829489d8e5d462df904e6bd8 (diff)
merge of '0f116f3500c10a0c6df76297f3ab887bebb2d8ad'
and 'dce598404f82b5e5bef1adc1cc1d91fbfc2aecc2'
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/e-image.bb23
-rw-r--r--packages/images/gpe-image.bb18
2 files changed, 18 insertions, 23 deletions
diff --git a/packages/images/e-image.bb b/packages/images/e-image.bb
index 2f0bef98ef..acd45cd5ae 100644
--- a/packages/images/e-image.bb
+++ b/packages/images/e-image.bb
@@ -1,15 +1,15 @@
require e-image-core.bb
DESCRIPTION = "An X11-based distribution with the Enlightenment Window Manager and Tools"
-PR = "r5"
+PR = "r6"
export IMAGE_BASENAME = "e-image"
export PACKAGE_INSTALL += "task-e-x11-core \
- gpe-task-pim \
- gpe-task-settings \
- gpe-task-apps \
- gpe-task-connectivity \
- gpe-task-games \
- gpe-task-apps-extra \
+ ask-gpe-pim \
+ task-gpe-settings \
+ task-gpe-apps \
+ task-gpe-connectivity \
+ task-gpe-games \
+ task-apps-extra \
figment \
xhost \
gpe-soundserver \
@@ -23,13 +23,8 @@ export PACKAGE_INSTALL += "task-e-x11-core \
gdk-pixbuf-loader-pnm \
gdk-pixbuf-loader-xbm \
gdk-pixbuf-loader-xpm"
-# gdk-pixbuf-loader-pcx \
-# gdk-pixbuf-loader-ico \
-# gdk-pixbuf-loader-ani \
-# gdk-pixbuf-loader-ras \
-# gdk-pixbuf-loader-tga \
-# gdk-pixbuf-loader-wbmp \
-DEPENDS += "task-e-x11-core task-gpe figment xhost gpe-soundserver gpe-confd xauth"
+DEPENDS += "task-e-x11-core task-gpe-base task-gpe-pim task-gpe-settings task-gpe-apps task-gpe-connectivity task-gpe-games \
+ figment xhost gpe-soundserver gpe-confd xauth"
RDEPENDS = "${PACKAGE_INSTALL}"
diff --git a/packages/images/gpe-image.bb b/packages/images/gpe-image.bb
index 552384c9e6..5a0632ff37 100644
--- a/packages/images/gpe-image.bb
+++ b/packages/images/gpe-image.bb
@@ -1,20 +1,20 @@
-PR = "r20"
+PR = "r21"
export IMAGE_BASENAME = "gpe-image"
GPE_EXTRA_THEMES = "gpe-theme-industrial"
GPE_EXTRA_INSTALL_none = ""
-GPE_EXTRA_INSTALL_bigscreen = "gpe-task-games ${GPE_EXTRA_THEMES}"
-GPE_EXTRA_INSTALL_smallscreen = "gpe-task-games ${GPE_EXTRA_THEMES}"
+GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
+GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
GUI_MACHINE_CLASS ?= "none"
GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
#ship more stuff with devices with >16MB of flash
GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
- gpe-task-connectivity \
+ task-gpe-connectivity \
gpe-theme-clearlooks \
figment \
",d)}'
@@ -23,15 +23,15 @@ GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
XSERVER ?= "xserver-kdrive-fbdev"
-DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpe"
+DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpe-base task-gpe-apps task-gpe-pim task-gpe-settings task-gpe-games"
RDEPENDS = "${PACKAGE_INSTALL}"
export PACKAGE_INSTALL = "\
${MACHINE_TASK_PROVIDER} \
- gpe-task-base \
- gpe-task-pim \
- gpe-task-settings \
- gpe-task-apps \
+ task-gpe-base \
+ task-gpe-pim \
+ task-gpe-settings \
+ task-gpe-apps \
${XSERVER} \
${GPE_EXTRA_INSTALL}"