summaryrefslogtreecommitdiff
path: root/packages/i2c-tools/picodlp-control_0.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-10 22:20:34 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-10 22:20:34 +0100
commit3a6e211cc0f0c55573b2e760f6cb3944b0e5939a (patch)
tree2176676a08898a7cd014f79f5d02e24157abdcff /packages/i2c-tools/picodlp-control_0.1.bb
parent9917f3a8406a139bc2afd12965fc8911f812b8d6 (diff)
pico-dlpcontrol: use a modified version of the gumstix 'i2c' program and wrap it with a script
* 'picodlp-control hflip 1' will turn on horizontil flipping
Diffstat (limited to 'packages/i2c-tools/picodlp-control_0.1.bb')
-rw-r--r--packages/i2c-tools/picodlp-control_0.1.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/packages/i2c-tools/picodlp-control_0.1.bb b/packages/i2c-tools/picodlp-control_0.1.bb
index 94b2b50c02..79a896b35e 100644
--- a/packages/i2c-tools/picodlp-control_0.1.bb
+++ b/packages/i2c-tools/picodlp-control_0.1.bb
@@ -1,19 +1,20 @@
DESCRIPTION = "Small application to control the pico DLP over I2C"
LICENSE = "GPLv3"
-PR = "r1"
+PR = "r2"
-SRC_URI = "file://${PN}.c file://i2c-dev.h"
+SRC_URI = "file://*.c file://*.h file://${PN}"
do_configure() {
- cp ${WORKDIR}/*.[ch] ${S}
+ cp ${WORKDIR}/*.[ch] ${WORKDIR}/${PN} ${S}
}
do_compile() {
- ${CC} -o ${PN} ${PN}.c ${CFGLAGS} ${LDFLAGS}
+ ${CC} -o bus3-i2c *.c ${CFLAGS} ${LDFLAGS}
}
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/${PN} ${D}/${bindir}
+ install -m 0755 ${S}/bus3-i2c ${D}/${bindir}
}