summaryrefslogtreecommitdiff
path: root/packages/hotplug
diff options
context:
space:
mode:
authorBruno Randolf <br1@subnet.at>2004-12-20 14:19:45 +0000
committerBruno Randolf <br1@subnet.at>2004-12-20 14:19:45 +0000
commit0158ae8f0ff7abe3a436dcd63f7af8618bbd0533 (patch)
tree53db0f8d37907ec3ffb094fcc0c036f3c3468a21 /packages/hotplug
parentdc6b5a4fa396c3fc79c30300cc95b924c584ae31 (diff)
fixed hotplug:
ispnp.rc exit, not return. added pciutils pcimodules patch. added hotplug script for usb-storage to load sd_mod. BKrev: 41c6df81gZaR8uZVtby7Kxah22qr4A
Diffstat (limited to 'packages/hotplug')
-rw-r--r--packages/hotplug/hotplug-20040920/isapnp-exit.diff0
-rw-r--r--packages/hotplug/hotplug-20040920/usb-storage0
-rw-r--r--packages/hotplug/hotplug_20040920.bb63
3 files changed, 63 insertions, 0 deletions
diff --git a/packages/hotplug/hotplug-20040920/isapnp-exit.diff b/packages/hotplug/hotplug-20040920/isapnp-exit.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hotplug/hotplug-20040920/isapnp-exit.diff
diff --git a/packages/hotplug/hotplug-20040920/usb-storage b/packages/hotplug/hotplug-20040920/usb-storage
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hotplug/hotplug-20040920/usb-storage
diff --git a/packages/hotplug/hotplug_20040920.bb b/packages/hotplug/hotplug_20040920.bb
index e69de29bb2..6948125c65 100644
--- a/packages/hotplug/hotplug_20040920.bb
+++ b/packages/hotplug/hotplug_20040920.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "This package contains the scripts necessary \
+for hotplug Linux support, and lets you plug in new devices \
+and use them immediately."
+HOMEPAGE = "http://linux-hotplug.sourceforge.net/"
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r5"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_09_20.tar.gz \
+ file://userspecified_hcd.patch;patch=1 \
+ file://fix-net.agent \
+ file://update-usb.usermap \
+ file://logcheck-ignore \
+ file://sleeve.agent \
+ file://sleeve.rc \
+ file://mmc.agent \
+ file://usbd.agent \
+ file://usbd \
+ file://sysconfig-hotplug \
+ file://sysconfig-usb \
+ file://isapnp-exit.diff;patch=1 \
+ file://usb-storage"
+
+S = "${WORKDIR}/hotplug-2004_09_20"
+
+INITSCRIPT_NAME = "hotplug"
+INITSCRIPT_PARAMS = "start 40 S . stop 89 0 6 ."
+
+inherit update-rc.d
+
+do_compile () {
+ :
+}
+
+oldmandir := "${mandir}"
+oldsbindir := "${sbindir}"
+prefix = ""
+exec_prefix = ""
+FILES_hotplug_append = " ${oldsbindir}"
+FILES_hotplug-doc_append = " ${oldmandir}"
+
+export DEBFIX = "sed -e 's:sysconfig/usb:default/hotplug.usb:'"
+do_install () {
+ install -d ${D}/${sysconfdir}/logcheck/ignore.d
+ install -d ${D}/${oldmandir}
+ install -d ${D}/${oldsbindir}
+ #install -d ${D}/${sysconfdir}/default
+ oe_runmake prefix=${D}${prefix} exec_prefix=${D}${exec_prefix} \
+ etcdir=${D}${sysconfdir} sbindir=${D}${sbindir} \
+ mandir=${D}${oldmandir} install
+ sh ${WORKDIR}/fix-net.agent ${D}
+ install -m 0755 ${WORKDIR}/update-usb.usermap ${D}/${oldsbindir}/
+ install -m 0644 ${WORKDIR}/logcheck-ignore ${D}/${sysconfdir}/logcheck/ignore.d/hotplug
+ install -m 0755 ${WORKDIR}/sleeve.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/sleeve.rc ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/mmc.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/usbd.agent ${D}${sysconfdir}/hotplug/
+ #install -m 0755 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
+ install -d ${D}${sysconfdir}/sysconfig
+ install -m 0644 ${WORKDIR}/sysconfig-hotplug ${D}${sysconfdir}/sysconfig/hotplug
+ install -m 0644 ${WORKDIR}/sysconfig-usb ${D}/${sysconfdir}/sysconfig/usb
+ install -m 0755 ${WORKDIR}/usb-storage ${D}${sysconfdir}/hotplug/usb
+}