summaryrefslogtreecommitdiff
path: root/packages/hostap/hostap-daemon_0.6.3.bb
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-03-31 14:41:29 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-03-31 14:41:29 +0000
commitf9302761ebe835b0059b73e104169837b31f5c14 (patch)
tree634f16e4af795919ce17e2c2b5c3c5ea30c299cb /packages/hostap/hostap-daemon_0.6.3.bb
parent80b1d5fe7b58c66f8a1b05edd2967cadfd9a1984 (diff)
hostap-daemon: replace version 0.6.0 by 0.6.3
Diffstat (limited to 'packages/hostap/hostap-daemon_0.6.3.bb')
-rw-r--r--packages/hostap/hostap-daemon_0.6.3.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/hostap/hostap-daemon_0.6.3.bb b/packages/hostap/hostap-daemon_0.6.3.bb
new file mode 100644
index 0000000000..37b710db19
--- /dev/null
+++ b/packages/hostap/hostap-daemon_0.6.3.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://makefile-cross.diff;patch=1 \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/hostapd-${PV}/hostapd"
+
+export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
+
+inherit update-rc.d
+INITSCRIPT_NAME=hostapd
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ if [ "x$HAS_PCI" == "x1" ] ; then
+ echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+ echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
+ fi
+}
+
+do_compile() {
+ CFLAGS='${CFLAGS}' CC='${CC}' make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ make TARGET_PREFIX=${D}${sbindir} install
+ install -m 0644 hostapd.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
+