summaryrefslogtreecommitdiff
path: root/packages/hostap/hostap-daemon_0.5.10.bb
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-04-28 15:39:55 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-04-28 15:39:55 +0000
commit50cfa4afecc878d1ddde60e4254c801e4b4ba6e0 (patch)
tree49a5a18fc3c5ead016d6ac65ced9c5b602e5dd64 /packages/hostap/hostap-daemon_0.5.10.bb
parent7be7517af3948a6a78b76805ff54958da3b92ac2 (diff)
hostap-daemon: use version 0.5.10 by default
Diffstat (limited to 'packages/hostap/hostap-daemon_0.5.10.bb')
-rw-r--r--packages/hostap/hostap-daemon_0.5.10.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/hostap/hostap-daemon_0.5.10.bb b/packages/hostap/hostap-daemon_0.5.10.bb
new file mode 100644
index 0000000000..f75efc4a34
--- /dev/null
+++ b/packages/hostap/hostap-daemon_0.5.10.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
+
+#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://makefile-cross.diff;patch=1 \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/hostapd-${PV}"
+
+export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
+
+inherit update-rc.d
+INITSCRIPT_NAME=hostapd
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ if [ "x$HAS_PCI" == "x1" ] ; then
+ echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+ echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
+ fi
+}
+
+do_compile() {
+ make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ make TARGET_PREFIX=${D}${sbindir} install
+ install -m 0644 hostapd.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
+