summaryrefslogtreecommitdiff
path: root/packages/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-06-09 14:55:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-09 14:55:07 +0000
commit640023036621fc74c4fb29818016596dcc753066 (patch)
treeeed057e6a1e8cb196a67872c5620f180cd009729 /packages/hostap/hostap-conf_1.0.bb
parent389a24af91dc21cdaaa14a100ad519e9731a069b (diff)
hostap-conf: ship module aliases for Prism2 cards supported by orinoco to get only hostap loaded
Diffstat (limited to 'packages/hostap/hostap-conf_1.0.bb')
-rw-r--r--packages/hostap/hostap-conf_1.0.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/packages/hostap/hostap-conf_1.0.bb b/packages/hostap/hostap-conf_1.0.bb
index 094722c845..e6d2e4454a 100644
--- a/packages/hostap/hostap-conf_1.0.bb
+++ b/packages/hostap/hostap-conf_1.0.bb
@@ -4,13 +4,32 @@ SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "GPL"
PACKAGE_ARCH = "all"
-PR = "r4"
+PR = "r5"
SRC_URI = "file://hostap_cs.conf \
+ file://hostap_cs.modalias \
file://hostap_cs.conf-upstream"
+do_compile() {
+}
+
do_install() {
install -d ${D}${sysconfdir}/pcmcia
+ install -d ${D}${sysconfdir}/modutils
+
install -m 0644 ${WORKDIR}/hostap_cs.conf-upstream ${D}${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
+
+ install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
}