summaryrefslogtreecommitdiff
path: root/packages/helloworld/helloworld_1.0.0.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 18:08:04 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 18:08:04 +0000
commitbe45ff7d2ecd063fb2d01e618aef73198f353f0d (patch)
tree19bc2959184c1c3a8567ddf989d6e1bf7b1c6249 /packages/helloworld/helloworld_1.0.0.bb
parent7605d989539a54cb2e6a00fba7cd3943bb9be7ec (diff)
helloworld: fix broken commit.
Diffstat (limited to 'packages/helloworld/helloworld_1.0.0.bb')
-rw-r--r--packages/helloworld/helloworld_1.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/helloworld/helloworld_1.0.0.bb b/packages/helloworld/helloworld_1.0.0.bb
index 9e68b0bd61..99ebc051fd 100644
--- a/packages/helloworld/helloworld_1.0.0.bb
+++ b/packages/helloworld/helloworld_1.0.0.bb
@@ -23,3 +23,28 @@ do_install () {
ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
}
+DESCRIPTION = "Minimal statically compiled Hello world!"
+LICENSE = "GPL"
+PR = "r0"
+
+S = "${WORKDIR}/${P}"
+
+do_fetch () {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ echo -e "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
+}
+
+do_compile () {
+ ${CC} -o helloworld helloworld.c -static
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}/
+ # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
+ # so if a sysvinit is installed, it will be used instead of helloworld
+ install -d ${D}${base_bindir}
+ ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
+}
+