summaryrefslogtreecommitdiff
path: root/packages/gutenprint/gutenprint_5.1.3.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-18 19:29:43 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-18 19:29:43 +0000
commit1010441880aee280580534f0fb0a68e4a98eb375 (patch)
tree58800c7dbb1b770ab67a02fa08d9767f6fc9471c /packages/gutenprint/gutenprint_5.1.3.bb
parent7bcfa6ab969ca61e3bcde9eee3240f32f578d1e5 (diff)
parentfdb7f09ca89562f586e1d9a6235e6a72da1ff77b (diff)
merge of '947287d07500dfb42d1f2f6b23d0bcd2ed00c920'
and 'da91d7ddb56154d2bd01a37943cd55b4ba49ac8a'
Diffstat (limited to 'packages/gutenprint/gutenprint_5.1.3.bb')
-rw-r--r--packages/gutenprint/gutenprint_5.1.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/packages/gutenprint/gutenprint_5.1.3.bb b/packages/gutenprint/gutenprint_5.1.3.bb
new file mode 100644
index 0000000000..8886323da5
--- /dev/null
+++ b/packages/gutenprint/gutenprint_5.1.3.bb
@@ -0,0 +1,48 @@
+require gutenprint.inc
+
+PR = "r1"
+
+DEPENDS = "glib-2.0 ijs ncurses cups tiff jpeg libpng gutenprint-native espgs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gimp-print/gutenprint-5.1.3.tar.bz2"
+S = "${WORKDIR}/gutenprint-${PV}"
+
+
+EXTRA_OECONF = "\
+ --disable-nls \
+ --disable-gtktest \
+# --enable-cups-ppds \
+# this option is disabled here, since the ppds are generated during native build
+ --disable-libgutenprintui \
+ --disable-libgutenprintui2 \
+ --disable-translated-cups-ppds \
+# --with-ghostscript \
+# i MAY have to disable this one as well, since these are probably built in native as well
+ --enable-cups-level3-ppds \
+ --disable-gimptest \
+ --enable-test \
+ --enable-epson \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+
+do_install_append() {
+ install -d ${D}${datadir}/cups/model/
+ install -m 644 ${STAGING_DIR}/${BUILD_SYS}/share/cups/model/* ${D}${datadir}/cups/model/
+ cp -pPr ${D}${STAGING_LIBDIR}/* ${D}${libdir}/
+ cp -pPr ${D}${STAGING_DATADIR}/* ${D}${datadir}/
+}
+
+
+FILES_${PN} += "${datadir}/cups/model ${libdir}/cups ${datadir}/cups/calibrate.ppm"
+FILES_${PN}-dbg += "${libdir}/cups/*/.debug"
+
+