summaryrefslogtreecommitdiff
path: root/packages/gutenprint/gutenprint-native_5.1.3.bb
diff options
context:
space:
mode:
authorPurdyd <purdyd_at_wisheights@yahoo.com>2007-10-13 14:50:23 +0000
committerKoen Kooi <koen@openembedded.org>2007-10-13 14:50:23 +0000
commit5c1480d31358e12f7ac7dd5327d332de5451a832 (patch)
tree6049fe1295b66bd4a313c71d3f754de4ce6bd2b7 /packages/gutenprint/gutenprint-native_5.1.3.bb
parent3345d9b2012877d3d554934efa15468eb0416048 (diff)
gutenprint: add gutenprint native (need cups-native and libijs-native on host)
Diffstat (limited to 'packages/gutenprint/gutenprint-native_5.1.3.bb')
-rw-r--r--packages/gutenprint/gutenprint-native_5.1.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/gutenprint/gutenprint-native_5.1.3.bb b/packages/gutenprint/gutenprint-native_5.1.3.bb
new file mode 100644
index 0000000000..4fe56d6c59
--- /dev/null
+++ b/packages/gutenprint/gutenprint-native_5.1.3.bb
@@ -0,0 +1,39 @@
+SECTION = "libs"
+require gutenprint_${PV}.bb
+DEPENDS = ""
+inherit native
+
+EXTRA_OECONF = "\
+ --disable-nls \
+ --disable-gtktest \
+ --enable-cups-ppds \
+ --disable-libgutenprintui \
+ --disable-libgutenprintui2 \
+ --disable-translated-cups-ppds \
+ --with-ghostscript \
+ --enable-cups-level3-ppds \
+ --disable-gimptest \
+ --enable-test \
+ --enable-epson \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+
+
+
+do_stage() {
+ autotools_stage_includes
+ install -m 0755 -d ${STAGING_DATADIR}/cups/model
+ install -m 0644 src/cups/ppd/C/*ppd* ${STAGING_DATADIR}/cups/model/
+# oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+