summaryrefslogtreecommitdiff
path: root/packages/guichan/guichan_0.7.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-09-24 14:36:25 +0000
committerKoen Kooi <koen@openembedded.org>2007-09-24 14:36:25 +0000
commit62b0c096d11002dfef70a76e4d90b1e3d8fb2f67 (patch)
tree822db1fcc55b475d9b2e23de48b9d388c3ab0ce9 /packages/guichan/guichan_0.7.1.bb
parentb2b667e89381c5bee23b9a6e96ccd7f04a15fd1b (diff)
parentcd3c4c17264f76f2a257e30d703984206e97febc (diff)
propagate from branch 'org.openembedded.dev' (head d4815037189353e6445b917ec6b4bd64777c3c0d)
to branch 'org.openembedded.dev.avr32' (head ba98da9ed913fe826c336573fe5912b1168f3e28)
Diffstat (limited to 'packages/guichan/guichan_0.7.1.bb')
-rw-r--r--packages/guichan/guichan_0.7.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/guichan/guichan_0.7.1.bb b/packages/guichan/guichan_0.7.1.bb
new file mode 100644
index 0000000000..28c5c8e948
--- /dev/null
+++ b/packages/guichan/guichan_0.7.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A portable C++ GUI library designed for games using Allegro, HGE, OpenGL, OpenLayer and/or SDL."
+HOMEPAGE = "http://guichan.sourceforge.net"
+DEPENDS = "virtual/libsdl libsdl-image"
+
+SRC_URI = "http://guichan.googlecode.com/files/guichan-0.7.1.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-opengl --disable-glut --disable-allegro \
+ --enable-sdlimage --enable-sdl"
+
+PACKAGES =+ "libguichan libguichan-sdl"
+
+FILES_libguichan = "${libdir}/libguichan.so.*"
+FILES_libguichan-sdl = "${libdir}/libguichan_sdl.so.*"
+
+do_stage () {
+ autotools_stage_all
+}
+