summaryrefslogtreecommitdiff
path: root/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2008-03-25 04:00:25 +0000
committerRod Whitby <rod@whitby.id.au>2008-03-25 04:00:25 +0000
commitbc02b41d392b6fce7a50e992de6b5b2234bab183 (patch)
tree8fcd23eb18fef2513ea6551f5c19b6a8d0083588 /packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
parent944b7d1e45e88431d81d9aede85d66b5d03dee39 (diff)
parent852b7bc38f9f7a4b5f4e896b04354835be1b2c68 (diff)
merge of '95ddd65a9c9a2104b071c450f7b75de0533a9a13'
and 'e827e49beb99d448d8fffea3f155c549865b2e84'
Diffstat (limited to 'packages/gtkhtml/gtkhtml-3.8_3.12.3.bb')
-rw-r--r--packages/gtkhtml/gtkhtml-3.8_3.12.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
new file mode 100644
index 0000000000..e8727bd0dc
--- /dev/null
+++ b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
+ file://60_glib-2.15-g-gnuc-function.patch;patch=1"
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+ find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+