summaryrefslogtreecommitdiff
path: root/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-03-25 07:34:23 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-03-25 07:34:23 +0000
commit80e765ba6f2c395006d82251bea0b3590b277dff (patch)
treea1af31784e3970f80650ca0af796ab7386362423 /packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
parent30670f2daf9a086b47cee18af56265bf8fedaf29 (diff)
parentbc02b41d392b6fce7a50e992de6b5b2234bab183 (diff)
merge of '55b6b2c132d8b0a81bcec0deed383a3da45e39e8'
and '67254ac9ecc3abdbf0b718b05d6eaa8d6b4b6e92'
Diffstat (limited to 'packages/gtkhtml/gtkhtml-3.8_3.12.3.bb')
-rw-r--r--packages/gtkhtml/gtkhtml-3.8_3.12.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
new file mode 100644
index 0000000000..e8727bd0dc
--- /dev/null
+++ b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
+ file://60_glib-2.15-g-gnuc-function.patch;patch=1"
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+ find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+