summaryrefslogtreecommitdiff
path: root/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-03-25 03:07:20 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-03-25 03:07:20 +0000
commit45d016c3f9258d087688d2888e15ae89bbced832 (patch)
treee2f5f8fe5b7fe0697357131baf3edecfa0978c89 /packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
parent5974b53400d03b7b7640172bead99aad3905ba37 (diff)
gtkhtml-3.8_3.12.3.bb : update gtkhtml with patch stolen from debian for
glib API changes
Diffstat (limited to 'packages/gtkhtml/gtkhtml-3.8_3.12.3.bb')
-rw-r--r--packages/gtkhtml/gtkhtml-3.8_3.12.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
new file mode 100644
index 0000000000..e8727bd0dc
--- /dev/null
+++ b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
+ file://60_glib-2.15-g-gnuc-function.patch;patch=1"
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+ find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+