summaryrefslogtreecommitdiff
path: root/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-07-28 09:53:19 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-28 09:53:19 +0000
commit2cbbcd4672da6b992f2ee51cf9e66692ed8d290d (patch)
treedcf1ed6d01ce556645cdb41ec132651a6e5aa6a0 /packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
parent00473bf1e8ad87f24780b5abf250d73bffae3d9c (diff)
parenta9ce299f26d511edac955fca9f55fd19a20ced4a (diff)
propagate from branch 'org.openembedded.koen' (head bb1a38be37cbbff81441ed44aa2837140560b742)
to branch 'org.openembedded.dev' (head 18c7455de8346644397b35e55e0862a9124bf444)
Diffstat (limited to 'packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb')
-rw-r--r--packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb b/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
new file mode 100644
index 0000000000..78700b91a2
--- /dev/null
+++ b/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+ file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+