summaryrefslogtreecommitdiff
path: root/packages/gtk+/gtk+-1.2_1.2.10.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/gtk+/gtk+-1.2_1.2.10.bb
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/gtk+/gtk+-1.2_1.2.10.bb')
-rw-r--r--packages/gtk+/gtk+-1.2_1.2.10.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/packages/gtk+/gtk+-1.2_1.2.10.bb b/packages/gtk+/gtk+-1.2_1.2.10.bb
index e69de29bb2..089f13e996 100644
--- a/packages/gtk+/gtk+-1.2_1.2.10.bb
+++ b/packages/gtk+/gtk+-1.2_1.2.10.bb
@@ -0,0 +1,57 @@
+LICENSE = LGPL
+DESCRIPTION = "GTK+1.2 is a deprecated library provided for running programs not yet converted to GTK+2.0"
+HOMEPAGE = "http://www.gtk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Rob Taylor <robtaylor@fastmail.fm>"
+DEPENDS = "glib-1.2 jpeg libpng xext"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-${PV}.tar.gz \
+ file://gtk+1.2-reconf-fix;patch=1 \
+ file://no-xwc;patch=1"
+S = "${WORKDIR}/gtk+-${PV}"
+
+inherit autotools pkgconfig flow-lossage
+
+do_configure_prepend() {
+ install -d m4
+ rm -f ltconfig libtool ltmain.sh aclocal.m4
+}
+
+FILES_${PN} += "${datadir}/themes"
+FILES_${PN}-dev += "${datadir}/gtk-1.2/include ${libdir}/gtk-1.2/include"
+
+
+EXTRA_OECONF = "--enable-debug=no --disable-glibtest --disable-xim"
+# --disable-cruft
+
+LIBV = "1.2.10"
+
+gtk_include = "fnmatch.h gtk.h gtkaccelgroup.h gtkaccellabel.h gtkadjustment.h gtkalignment.h gtkarg.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclist.h gtkcolorsel.h gtkcombo.h gtkcompat.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdata.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfeatures.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkimage.h gtkinputdialog.h gtkintl.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenufactory.h gtkmenuitem.h gtkmenushell.h gtkmisc.h gtknotebook.h gtkobject.h gtkoptionmenu.h gtkpacker.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtksignal.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtkthemes.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreeitem.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h makeenums.h stamp-gtkmarshal.h stamp-gtktypebuiltins.h"
+gdk_include = "MwmUtil.h gdk.h gdkcursors.h gdki18n.h gdkinput.h gdkinputcommon.h gdkinputgxi.h gdkinputnone.h gdkinputxfree.h gdkkeysyms.h gdkprivate.h gdkrgb.h gdktypes.h gdkx.h gxid_lib.h gxid_proto.h"
+
+do_stage () {
+ oe_libinstall -so -C gtk libgtk ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk libgdk ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gtk-1.2/gtk
+ for i in ${gtk_include}; do
+ install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-1.2/gtk/$i
+ done
+
+ mkdir -p ${STAGING_INCDIR}/gtk-1.2/gdk
+ for i in ${gdk_include}; do
+ install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-1.2/gdk/$i
+ done
+
+ mkdir -p ${STAGING_LIBDIR}/gtk-1.2/include
+
+ install -m 0644 gtk.m4 ${STAGING_DATADIR}/aclocal/
+ install -m 0755 gtk-config ${STAGING_BINDIR}
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/gtk-1.2
+}
+