summaryrefslogtreecommitdiff
path: root/packages/gtk+/composite-pixbuf_0.0.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-06-12 14:45:27 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-06-12 14:45:27 +0000
commitb1f4d34f8541f039d72d423223c91e32540a2fc5 (patch)
treec50f34a595a58cb31a25d96727c3e2c9c27c0a91 /packages/gtk+/composite-pixbuf_0.0.bb
parent10013e9ed4e79a2f6ca0ceb6451787aaa47c46e5 (diff)
parentb655c71aac44af6eab2a52774ea810a945592cee (diff)
merge of '30c320b2f51c86226580e5bbf68fa8b0896a0655'
and '8dfee9b2427785432e4161eb7cc749155230e08e'
Diffstat (limited to 'packages/gtk+/composite-pixbuf_0.0.bb')
-rw-r--r--packages/gtk+/composite-pixbuf_0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gtk+/composite-pixbuf_0.0.bb b/packages/gtk+/composite-pixbuf_0.0.bb
new file mode 100644
index 0000000000..729343fb44
--- /dev/null
+++ b/packages/gtk+/composite-pixbuf_0.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Pixbuf performance test"
+LICENSE = "Public domain"
+DEPENDS = "gtk+"
+
+SRC_URI = "http://amelang.net/composite_pixbuf.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} ${CFLAGS} composite_pixbuf.c -o composite_pixbuf \
+ `pkg-config --cflags gdk-2.0` `pkg-config --libs gdk-2.0` `pkg-config --libs x11` `pkg-config --libs pango` \
+ -lxcb -lXext -lXinerama -lXrandr -lXcursor -lXfixes -lpangoft2-1.0 -lz -lexpat -lxcb-xlib -lXau -lXdmcp
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 composite_pixbuf ${D}${bindir}
+}