summaryrefslogtreecommitdiff
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-11-15 18:23:17 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-15 18:23:17 +0100
commita25da5c491ac2a3820be7aaa7fa507fe7ca8b354 (patch)
treed8162d4d8d6aaf5f129e203b6bc9d3ccead522f7 /packages/gstreamer
parent9e167064390ce3bff7425be5c002ed3f1e7eb1d1 (diff)
parent828ced10e6eaf2048a8fd7ee7263807fab9d784d (diff)
Merge commit 'origin/org.openembedded.dev' into holger/openmoko-merges
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-meta-base_0.10.bb20
-rw-r--r--packages/gstreamer/gst-plugins-ugly_0.10.7.bb2
-rw-r--r--packages/gstreamer/gst-plugins.inc4
-rw-r--r--packages/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch39
-rw-r--r--packages/gstreamer/gstreamer_0.10.17.bb5
5 files changed, 50 insertions, 20 deletions
diff --git a/packages/gstreamer/gst-meta-base_0.10.bb b/packages/gstreamer/gst-meta-base_0.10.bb
index 06a4fba4cd..c54429aca8 100644
--- a/packages/gstreamer/gst-meta-base_0.10.bb
+++ b/packages/gstreamer/gst-meta-base_0.10.bb
@@ -1,8 +1,10 @@
# Based on its sibling on Poky which is copyright (C) 2006,2007 OpenedHand LTD
DESCRIPTION = "Gstreamer package groups"
-DEPENDS = "gstreamer gst-plugins-base gst-plugins-bad gst-plugins-good gst-plugins-ugly"
-PR = "r11"
+DEPENDS = "gstreamer gst-plugins-base gst-plugins-bad gst-plugins-good \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugins-ugly', d)}"
+
+PR = "r12"
PACKAGES = "${PN}-dbg \
gst-meta-base \
@@ -34,14 +36,7 @@ RDEPENDS_gst-meta-audio = "\
gst-meta-base \
gst-plugin-ivorbis \
gst-plugin-ogg \
- gst-plugin-mad \
- gst-plugin-id3demux \
- gst-plugin-wavparse"
-
-RDEPENDS_gst-meta-audio_openmoko = "\
- gst-meta-base \
- gst-plugin-ivorbis \
- gst-plugin-ogg \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad', d)} \
gst-plugin-id3demux \
gst-plugin-wavparse"
@@ -55,10 +50,7 @@ RDEPENDS_gst-meta-video = "\
gst-meta-base \
gst-plugin-avi \
gst-plugin-matroska \
- gst-plugin-mpegstream \
- gst-plugin-mpegaudioparse \
- gst-plugin-mpegvideoparse \
- gst-plugin-mpeg2dec"
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mpegstream gst-plugin-mpegaudioparse gst-plugin-mpegvideoparse gst-plugin-mpeg2dec', d)}"
RRECOMMENDS_gst-meta-video = "\
gst-meta-audio"
diff --git a/packages/gstreamer/gst-plugins-ugly_0.10.7.bb b/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
index d7ff21d4e9..fd008b065a 100644
--- a/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
@@ -1,8 +1,6 @@
require gst-plugins.inc
PR = "r0"
-EXTRA_OECONF_append_openmoko = "--disable-mad"
-
DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
SRC_URI += "\
diff --git a/packages/gstreamer/gst-plugins.inc b/packages/gstreamer/gst-plugins.inc
index f8447ee25d..68a0502182 100644
--- a/packages/gstreamer/gst-plugins.inc
+++ b/packages/gstreamer/gst-plugins.inc
@@ -1,7 +1,7 @@
require gst-common.inc
DESCRIPTION = "Plugins for GStreamer"
-DEPENDS = "gstreamer libmikmod liboil libogg tremor libvorbis libid3tag"
-DEPENDS += "${@base_conditional('DISTRO', 'openmoko', '', 'libmad', d)}"
+DEPENDS = "gstreamer libmikmod liboil libogg tremor libvorbis"
+DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
PACKAGES_DYNAMIC = "gst-plugin-*"
diff --git a/packages/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch b/packages/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch
new file mode 100644
index 0000000000..6733e6be06
--- /dev/null
+++ b/packages/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch
@@ -0,0 +1,39 @@
+Work around a glibc 2.6.1 bug with dlopen. We try to dlopen a .so file that
+only contains debug symbols (e.g. no architecture is set in the elf header)
+
+
+#0 0x4000a88c in _dl_relocate_object () from /lib/ld-linux.so.3
+(gdb) bt
+#0 0x4000a88c in _dl_relocate_object () from /lib/ld-linux.so.3
+#1 0x40011f68 in dl_open_worker () from /lib/ld-linux.so.3
+#2 0x4000d7e4 in _dl_catch_error () from /lib/ld-linux.so.3
+#3 0x400117d8 in _dl_open () from /lib/ld-linux.so.3
+#4 0x402fba84 in dlopen_doit () from /lib/libdl.so.2
+#5 0x4000d7e4 in _dl_catch_error () from /lib/ld-linux.so.3
+#6 0x402fbf50 in _dlerror_run () from /lib/libdl.so.2
+#7 0x402fb9bc in dlopen@@GLIBC_2.4 () from /lib/libdl.so.2
+#8 0x402f2790 in g_module_open () from /usr/lib/libgmodule-2.0.so.0
+#9 0x40078784 in gst_plugin_load_file (
+ filename=0x10a6c8 "/usr/lib/gstreamer-0.10/.debug/libgstcoreindexers.so",
+ error=0x0) at gstplugin.c:481
+#10 0x4007e3c4 in gst_registry_scan_path_level (registry=0x27828,
+ path=0x10a6a0 "/usr/lib/gstreamer-0.10/.debug", level=1) at gstregistry.c:891
+#11 0x4007df04 in gst_registry_scan_path_level (registry=0x27828,
+
+
+Index: gstreamer-0.10.17/gst/gstregistry.c
+===================================================================
+--- gstreamer-0.10.17.orig/gst/gstregistry.c 2008-11-14 23:30:48.000000000 +0100
++++ gstreamer-0.10.17/gst/gstregistry.c 2008-11-14 23:32:39.000000000 +0100
+@@ -813,7 +813,10 @@
+ GST_LOG_OBJECT (registry, "examining file: %s", filename);
+
+ if (g_file_test (filename, G_FILE_TEST_IS_DIR)) {
+- if (level > 0) {
++ if (g_str_has_suffix (filename, ".debug")) {
++ GST_LOG_OBJECT (registry,
++ "found directory, not descending into .debug directory");
++ } else if (level > 0) {
+ GST_LOG_OBJECT (registry, "found directory, recursing");
+ changed |= gst_registry_scan_path_level (registry, filename, level - 1);
+ } else {
diff --git a/packages/gstreamer/gstreamer_0.10.17.bb b/packages/gstreamer/gstreamer_0.10.17.bb
index 51a1426564..4087e8e1d0 100644
--- a/packages/gstreamer/gstreamer_0.10.17.bb
+++ b/packages/gstreamer/gstreamer_0.10.17.bb
@@ -1,6 +1,7 @@
require gstreamer.inc
-PR = "r3"
+PR = "r4"
-SRC_URI += "file://po-makefile-fix.patch;patch=1"
+SRC_URI += "file://po-makefile-fix.patch;patch=1 \
+ file://registry-do-not-look-into-debug-dirs.patch;patch=1 "