summaryrefslogtreecommitdiff
path: root/packages/gstreamer
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/gstreamer
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gstreamer_0.8.5.bb34
-rw-r--r--packages/gstreamer/gstreamer_0.8.7.bb33
2 files changed, 67 insertions, 0 deletions
diff --git a/packages/gstreamer/gstreamer_0.8.5.bb b/packages/gstreamer/gstreamer_0.8.5.bb
index e69de29bb2..2e5ef2a53a 100644
--- a/packages/gstreamer/gstreamer_0.8.5.bb
+++ b/packages/gstreamer/gstreamer_0.8.5.bb
@@ -0,0 +1,34 @@
+LICENSE = LGPL
+PR = "r0"
+
+DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
+It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
+DEPENDS = "glib-2.0 libxml2 popt"
+SECTION = "x11/network"
+PRIORITY = "optional"
+
+FILES_${PN} += " ${libdir}/gstreamer-0.8/*.so"
+FILES_${PN}-dev += " ${libdir}/gstreamer-0.8/*.la ${libdir}/gstreamer-0.8/*.a"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
+ file://gstreamer.xsession \
+ file://configure-largefile.patch;patch=1;pnum=0"
+
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking"
+
+inherit autotools pkgconfig gettext
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR}/share/man
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install ${WORKDIR}/gstreamer.xsession ${D}/${sysconfdir}/X11/Xsession.d/90gst-register
+}
+
diff --git a/packages/gstreamer/gstreamer_0.8.7.bb b/packages/gstreamer/gstreamer_0.8.7.bb
index e69de29bb2..3f0ce7c307 100644
--- a/packages/gstreamer/gstreamer_0.8.7.bb
+++ b/packages/gstreamer/gstreamer_0.8.7.bb
@@ -0,0 +1,33 @@
+LICENSE = LGPL
+PR = "r0"
+
+DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
+It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
+DEPENDS = "glib-2.0 gettext-native libxml2 popt"
+SECTION = "base"
+PRIORITY = "optional"
+
+FILES_${PN} += " ${libdir}/gstreamer-0.8/*.so"
+FILES_${PN}-dev += " ${libdir}/gstreamer-0.8/*.la ${libdir}/gstreamer-0.8/*.a"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
+ file://gstreamer.xsession"
+
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR}/share/man
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install ${WORKDIR}/gstreamer.xsession ${D}/${sysconfdir}/X11/Xsession.d/90gst-register
+}
+