summaryrefslogtreecommitdiff
path: root/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-18 00:46:34 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-18 00:47:11 +0100
commit18951738599540f7c53b7af8b3059f302bfc351d (patch)
tree292f559481a325731a588946eae83d365988ad66 /packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
parent41f080ef4f7f7e84feb199a01536bfa716377924 (diff)
gst-plugins-ugly: skip package for ENTERPRISE_DISTRO = 1
gst-plugins-ugly-sid: skip package for ENTERPRISE_DISTRO = 0
Diffstat (limited to 'packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb')
-rw-r--r--packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb b/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
index 950b7f56aa..573fbd61f3 100644
--- a/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
@@ -7,3 +7,11 @@ SRC_URI = "\
file://gstsid_autofoo_HACK.patch;patch=1 \
"
S = "${WORKDIR}/gst-plugins-ugly-${PV}"
+
+python() {
+ # Don't build, if we are building an ENTERPRISE distro
+ enterprise = bb.data.getVar("ENTERPRISE_DISTRO", d, 1)
+ if enterprise == "0":
+ raise bb.parse.SkipPackage("gst-plugins-ugly-sid will only build if ENTERPRISE_DISTRO != 0")
+}
+