summaryrefslogtreecommitdiff
path: root/packages/gsm
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-06-13 18:56:49 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-06-13 18:56:49 +0000
commit1d8b6398b57bf66611e92a0ee2c1689caf97daa7 (patch)
tree379ca07b441160c272a511f8ee44961d5a41a1bc /packages/gsm
parent49fc40335631daf60d2ead73ca6e346d52b0f305 (diff)
libgsmd: add two universal patches, bump PR
Diffstat (limited to 'packages/gsm')
-rw-r--r--packages/gsm/files/vendor-qc-v0.patch38
-rw-r--r--packages/gsm/libgsmd_svn.bb8
2 files changed, 43 insertions, 3 deletions
diff --git a/packages/gsm/files/vendor-qc-v0.patch b/packages/gsm/files/vendor-qc-v0.patch
new file mode 100644
index 0000000000..8306f8a66e
--- /dev/null
+++ b/packages/gsm/files/vendor-qc-v0.patch
@@ -0,0 +1,38 @@
+Index: gsm/src/gsmd/vendor_qc.c
+===================================================================
+--- gsm.orig/src/gsmd/vendor_qc.c 2007-06-13 20:13:47.000000000 +0200
++++ gsm/src/gsmd/vendor_qc.c 2007-06-13 20:45:19.000000000 +0200
+@@ -81,6 +88,9 @@
+ {
+ /* FIXME: do actual detection of vendor if we have multiple vendors */
+ /* open /proc/cpuinfo and check for HTC Universal? */
++
++ /* The Qualcomm chip starts in V0 mode */
++ g->flags |= GSMD_FLAG_V0;
+ return 1;
+ }
+
+Index: gsm/src/gsmd/gsmd.c
+===================================================================
+--- gsm.orig/src/gsmd/gsmd.c 2007-06-13 20:13:47.000000000 +0200
++++ gsm/src/gsmd/gsmd.c 2007-06-13 20:49:54.000000000 +0200
+@@ -62,7 +62,8 @@
+ {
+ struct gsmd_alive_priv *alp = ctx;
+
+- if (!strcmp(resp, "OK"))
++ if (!strcmp(resp, "OK") ||
++ ((alp->gsmd->flags & GSMD_FLAG_V0) && resp[0] == '0'))
+ alp->alive_responded = 1;
+ return 0;
+ }
+@@ -201,7 +202,8 @@
+ {
+ struct gsmd *gsmd = ctx;
+
+- if (strcmp(resp, "OK")) {
++ if (strcmp(resp, "OK") &&
++ (!(gsmd->flags & GSMD_FLAG_V0) || resp[0] != '0')) {
+ gsmd_log(GSMD_FATAL, "response '%s' to initial command invalid", resp);
+ exit(5);
+ }
diff --git a/packages/gsm/libgsmd_svn.bb b/packages/gsm/libgsmd_svn.bb
index 230d4d6fe5..7fc54a5afb 100644
--- a/packages/gsm/libgsmd_svn.bb
+++ b/packages/gsm/libgsmd_svn.bb
@@ -4,15 +4,17 @@ LICENSE = "GPL"
SECTION = "libs/gsm"
PROVIDES += "gsmd"
PV = "0.0+svn${SRCDATE}"
-PR = "r13"
+PR = "r14"
SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
file://gsmd \
file://default \
file://extreplychars.patch;patch=1 \
file://getopt-wait-interpreter-ready.patch;patch=1 \
- file://alive-start-if-interpreter-ready.patch;patch=1 \
- file://tihtc-csq-fix.patch;patch=1"
+ file://alive-start-if-interpreter-ready.patch;patch=1 \
+ file://tihtc-csq-fix.patch;patch=1 \
+ file://vendor-qc-v0.patch;patch=1 \
+ file://universal-wcdma.patch;patch=1"
S = "${WORKDIR}/gsm"