summaryrefslogtreecommitdiff
path: root/packages/gsm
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-03-31 00:34:23 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-03-31 00:34:23 +0000
commitc0dbcb125c5be97862e0977a7671fc699e0758aa (patch)
tree096a04b60b7df17d870e97ec65b36b5609472616 /packages/gsm
parentff824b1d9d5d2aa031188263d2098b2e35f86189 (diff)
parentd872ea5d2c9ed96e72f7cd833e80eaeb599a6cf6 (diff)
merge of '5b3c06549bda71c0b02a8f27fa8aa82c95abc4ad'
and '6396af305b4f951d7d88215419603669286e4715'
Diffstat (limited to 'packages/gsm')
-rw-r--r--packages/gsm/files/gsmd22
-rw-r--r--packages/gsm/files/magician/default4
-rw-r--r--packages/gsm/libgsmd_svn.bb2
3 files changed, 14 insertions, 14 deletions
diff --git a/packages/gsm/files/gsmd b/packages/gsm/files/gsmd
index 4b8db5d5a5..5c78e8178a 100644
--- a/packages/gsm/files/gsmd
+++ b/packages/gsm/files/gsmd
@@ -16,21 +16,21 @@ RETVAL=0
prog="gsmd"
start() {
- # FIXME add check whether GSM_POW is set at all, otherwise don't try to power on
- # Power on GSM device
-
# Hack for broken uboot and/or kernel on the neo1973
dmesg -n1
- if [ -e "${GSM_POW}" ]
+ if [ -n "${GSM_POW}" ]
then
- echo -n "Powering up GSM device..."
- echo "1" > ${GSM_POW}
- sleep 1
- echo "done"
- else
- echo "GSM device not found. Aborting startup"
- return false
+ if [ -e "${GSM_POW}" ]
+ then
+ echo -n "Powering up GSM device..."
+ echo "1" > ${GSM_POW}
+ sleep 1
+ echo "done"
+ else
+ echo "GSM device not found. Aborting startup"
+ return false
+ fi
fi
# Start daemons.
echo -n "Starting $prog: "
diff --git a/packages/gsm/files/magician/default b/packages/gsm/files/magician/default
index fb19d46fd5..a9c3b94b1d 100644
--- a/packages/gsm/files/magician/default
+++ b/packages/gsm/files/magician/default
@@ -1,7 +1,7 @@
# gsmd This shell script configures for the gsmd init script.
-# If you must specify special options, uncomment and modify the next line
-GSMD_OPTS="-s 115200 -F"
+# Set line Discipline 17 (N_TIHTC), needs ldisc.patch-ed gsmd
+GSMD_OPTS="-s 115200 -F -D 17"
# If your GSM device needs to be powered up, uncomment and modify the next line
#GSM_POW="/sys/bus/platform/devices/gta01-pm-gsm.0/power_on"
diff --git a/packages/gsm/libgsmd_svn.bb b/packages/gsm/libgsmd_svn.bb
index 910fa26d4d..0b3a29e931 100644
--- a/packages/gsm/libgsmd_svn.bb
+++ b/packages/gsm/libgsmd_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
SECTION = "libs/gsm"
PROVIDES += "gsmd"
PV = "0.0+svn${SRCDATE}"
-PR = "r7"
+PR = "r8"
SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
file://gsmd \