summaryrefslogtreecommitdiff
path: root/packages/gpsd
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/gpsd
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/gpsd')
-rw-r--r--packages/gpsd/gpsd_2.6.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/packages/gpsd/gpsd_2.6.bb b/packages/gpsd/gpsd_2.6.bb
index e89d775928..90f51c65d7 100644
--- a/packages/gpsd/gpsd_2.6.bb
+++ b/packages/gpsd/gpsd_2.6.bb
@@ -31,20 +31,20 @@ do_stage () {
do_install () {
install -d ${D}/${sbindir}
- install -d ${D}/${datadir}/man/man1
- install -d ${D}/${datadir}/man/man3
+ install -d ${D}/${mandir}/man1
+ install -d ${D}/${mandir}/man3
install -d ${D}/${incdir}
install -d ${D}/${libdir}
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${S}/.libs/gpsd ${D}${sbindir}
oe_libinstall -so -C ${S}/.libs libgps ${D}${libdir}
- install -m 755 gpsd.1 ${D}/usr/share/man/man1/gpsd.1
+ install -m 755 gpsd.1 ${D}${mandir}/man1/gpsd.1
install -m 0755 ${S}/libgps.la ${D}${libdir}libgps.la
install -m 0755 ${S}/gps.h ${S}/gpsd.h ${D}/${incdir}
- install -m 755 libgps.3 libgpsd.3 ${D}/${datadir}/man/man3/
+ install -m 755 libgps.3 libgpsd.3 ${D}/${mandir}/man3/
install -m 755 gpsd.init ${D}${sysconfdir}/init.d/gpsd
}
PACKAGES =+ "gpsd-devdoc "
-FILES_${PN}-devdoc = "${datadir}/man/man3 "
+FILES_${PN}-devdoc = "${mandir}/man3 "