summaryrefslogtreecommitdiff
path: root/packages/gpm
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-01-11 00:45:43 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-01-11 00:45:43 +0000
commitc238b57a1f2bec383c24cdf6b071b9e63d823e36 (patch)
tree8b0b0a1bd65a3e973d03862a0fd41f74dcdb163b /packages/gpm
parent11973b641c7679c198a03fa3aff75196c06cecc3 (diff)
parent42bc6671a743c737ce3e70c779170ec9614b81ee (diff)
merge of '31bb8b63bcf6d0058be6512a2ef765778179d5b7'
and 'a718cfa84598b79768ec169f5aa277b23b9c79cf'
Diffstat (limited to 'packages/gpm')
-rw-r--r--packages/gpm/gpm_1.20.1.bb31
1 files changed, 11 insertions, 20 deletions
diff --git a/packages/gpm/gpm_1.20.1.bb b/packages/gpm/gpm_1.20.1.bb
index 5623ebbf16..c017cafc9a 100644
--- a/packages/gpm/gpm_1.20.1.bb
+++ b/packages/gpm/gpm_1.20.1.bb
@@ -1,21 +1,25 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DEPENDS = "ncurses"
DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
for the console and xterm, with sample clients included \
(emacs, etc)."
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
-PR="r1"
-PARALLEL_MAKE=""
+PR = "r2"
+PARALLEL_MAKE = ""
SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
file://no-docs.patch;patch=1 \
file://init"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "gpm"
+INITSCRIPT_PARAMS = "defaults"
export LIBS = "-lm"
+
do_configure_prepend () {
cp aclocal.m4 acinclude.m4
}
@@ -29,18 +33,5 @@ do_install () {
oe_runmake 'ROOT=${D}' install
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
-}
-
-pkg_postinst () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm defaults
-}
-
-pkg_prerm () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm remove
+ cd ${D}${libdir} && ln -sf libgpm.so.1.19.0 libgpm.so.1
}