summaryrefslogtreecommitdiff
path: root/packages/gpm/gpm_1.20.1.bb
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-04-18 01:33:13 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-18 01:33:13 +0000
commitcbbcbb9eab5ba1f1caaf31f5a838b45c52b17685 (patch)
tree4e7fbe2b79180c049e47f095823fdde2c0c4449f /packages/gpm/gpm_1.20.1.bb
parent5d2e2203caf732811538b072b8d8bfd0f5ebf512 (diff)
gpm: Add gpm init script
Diffstat (limited to 'packages/gpm/gpm_1.20.1.bb')
-rw-r--r--packages/gpm/gpm_1.20.1.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/packages/gpm/gpm_1.20.1.bb b/packages/gpm/gpm_1.20.1.bb
index 2ceea6fccd..5623ebbf16 100644
--- a/packages/gpm/gpm_1.20.1.bb
+++ b/packages/gpm/gpm_1.20.1.bb
@@ -5,9 +5,13 @@ DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
for the console and xterm, with sample clients included \
(emacs, etc)."
+PR="r1"
+PARALLEL_MAKE=""
+
SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
- file://no-docs.patch;patch=1"
+ file://no-docs.patch;patch=1 \
+ file://init"
inherit autotools
@@ -23,4 +27,20 @@ do_stage () {
do_install () {
oe_runmake 'ROOT=${D}' install
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
+}
+
+pkg_postinst () {
+ if test -n "${D}"; then
+ D="-r $D"
+ fi
+ update-rc.d $D gpm defaults
+}
+
+pkg_prerm () {
+ if test -n "${D}"; then
+ D="-r $D"
+ fi
+ update-rc.d $D gpm remove
}