summaryrefslogtreecommitdiff
path: root/packages/gpm/gpm_1.20.1.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-01-11 05:01:57 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-01-11 05:01:57 +0000
commit63b28eccf03090e6ffbc22b43b7e2980bcaa6ac0 (patch)
tree9c782475d9fb0272145ff339f3d2e22a0a9a06f7 /packages/gpm/gpm_1.20.1.bb
parenta5bfba15d1d4bfb1f2691d1d8fa47a6511dcccf7 (diff)
parent3a5d5af1f6f0b43bc46535d82f5dcffc06ec19c6 (diff)
merge of '242e744e01fe3fbbbae94031b14a816bec5caeae'
and 'cec9dea27c828bc6ef75f6e0fe0254ada1f011cb'
Diffstat (limited to 'packages/gpm/gpm_1.20.1.bb')
-rw-r--r--packages/gpm/gpm_1.20.1.bb31
1 files changed, 11 insertions, 20 deletions
diff --git a/packages/gpm/gpm_1.20.1.bb b/packages/gpm/gpm_1.20.1.bb
index 5623ebbf16..c017cafc9a 100644
--- a/packages/gpm/gpm_1.20.1.bb
+++ b/packages/gpm/gpm_1.20.1.bb
@@ -1,21 +1,25 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DEPENDS = "ncurses"
DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
for the console and xterm, with sample clients included \
(emacs, etc)."
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
-PR="r1"
-PARALLEL_MAKE=""
+PR = "r2"
+PARALLEL_MAKE = ""
SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
file://no-docs.patch;patch=1 \
file://init"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "gpm"
+INITSCRIPT_PARAMS = "defaults"
export LIBS = "-lm"
+
do_configure_prepend () {
cp aclocal.m4 acinclude.m4
}
@@ -29,18 +33,5 @@ do_install () {
oe_runmake 'ROOT=${D}' install
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
-}
-
-pkg_postinst () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm defaults
-}
-
-pkg_prerm () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm remove
+ cd ${D}${libdir} && ln -sf libgpm.so.1.19.0 libgpm.so.1
}