summaryrefslogtreecommitdiff
path: root/packages/gpgme/gpgme_1.0.3.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-19 15:10:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-19 15:10:57 +0000
commit9de11cb504b6552a72c135a6d221fd24235884f4 (patch)
tree98ae0480b772ede5f633b686734a3a72c52e7461 /packages/gpgme/gpgme_1.0.3.bb
parent01c623131aff75c317c40d4c3aaabcfb1e264d99 (diff)
parentb992eedcc577867859d8ae2757a2a06f1b7b6460 (diff)
merge of 71af6d6609e0de2507d7cd21adfb7e2c18454ef4
and fd2bac75affd95bc23ea64c23ecb07ebd31313e8
Diffstat (limited to 'packages/gpgme/gpgme_1.0.3.bb')
-rw-r--r--packages/gpgme/gpgme_1.0.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gpgme/gpgme_1.0.3.bb b/packages/gpgme/gpgme_1.0.3.bb
new file mode 100644
index 0000000000..8292991a89
--- /dev/null
+++ b/packages/gpgme/gpgme_1.0.3.bb
@@ -0,0 +1,22 @@
+LICENSE = "GPL"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.gz"
+PR = "r1"
+
+DEPENDS = "libgpg-error pth libassuan"
+
+EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test --with-gpg=${bindir}/gpg --without-gpgsm"
+
+inherit autotools binconfig
+
+do_stage() {
+ autotools_stage_includes
+
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pth ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pthread ${STAGING_LIBDIR}
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
+}
+