summaryrefslogtreecommitdiff
path: root/packages/gpephone
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-09-14 16:13:59 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-09-14 16:13:59 +0000
commit299229062faeb88f10f2433fbb158b490d3203c1 (patch)
tree3c9448651120984b27959d35e956b754be66b557 /packages/gpephone
parenteb1c5ce759640e621bacfe6969743ca15dcd3aec (diff)
gpe-applauncher: add svn recipe, ship device specific softkey configuration.
Diffstat (limited to 'packages/gpephone')
-rw-r--r--packages/gpephone/gpe-applauncher/fic-gta01/.mtn2git_empty0
-rw-r--r--packages/gpephone/gpe-applauncher/fic-gta01/hotkeys.conf20
-rw-r--r--packages/gpephone/gpe-applauncher/fic-gta01/softkeys.conf25
-rw-r--r--packages/gpephone/gpe-applauncher/hotkeys.conf20
-rw-r--r--packages/gpephone/gpe-applauncher/softkeys.conf25
-rw-r--r--packages/gpephone/gpe-applauncher_0.11.bb8
-rw-r--r--packages/gpephone/gpe-applauncher_svn.bb35
7 files changed, 130 insertions, 3 deletions
diff --git a/packages/gpephone/gpe-applauncher/fic-gta01/.mtn2git_empty b/packages/gpephone/gpe-applauncher/fic-gta01/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpephone/gpe-applauncher/fic-gta01/.mtn2git_empty
diff --git a/packages/gpephone/gpe-applauncher/fic-gta01/hotkeys.conf b/packages/gpephone/gpe-applauncher/fic-gta01/hotkeys.conf
new file mode 100644
index 0000000000..34bd6a22b7
--- /dev/null
+++ b/packages/gpephone/gpe-applauncher/fic-gta01/hotkeys.conf
@@ -0,0 +1,20 @@
+# We have two types of sections in here:
+# 'System' defines the bindings for buit-in functions
+# Each 'Application' section defines a binding of an application (desktop file)
+# to a key.
+
+[System]
+homescreen_show=k
+homescreen_toggle=F5
+system_controls=Execute
+
+[Application0]
+key=F7
+application=abook
+hold=false
+
+[Application1]
+key=F8
+application=gpe-taskmanager
+hold=false
+
diff --git a/packages/gpephone/gpe-applauncher/fic-gta01/softkeys.conf b/packages/gpephone/gpe-applauncher/fic-gta01/softkeys.conf
new file mode 100644
index 0000000000..f9fde86d2d
--- /dev/null
+++ b/packages/gpephone/gpe-applauncher/fic-gta01/softkeys.conf
@@ -0,0 +1,25 @@
+# This an example configuration file for GPE Application launcher softkeys.
+# All sizes and positions have pixels as units.
+# The align setting is a positive value from 0 (left) to 10 (right).
+
+[Key 1]
+label = left
+width = 180
+height = 36
+xpos = 5
+ypos = 5
+xpos_menu = 5
+ypos_menu = 30
+align = 1
+key = F3
+
+[Key 2]
+label = right
+width = 180
+height = 36
+xpos = 295
+ypos = 5
+xpos_menu = 5
+ypos_menu = 30
+align = 9
+key = F4
diff --git a/packages/gpephone/gpe-applauncher/hotkeys.conf b/packages/gpephone/gpe-applauncher/hotkeys.conf
new file mode 100644
index 0000000000..f8007ddbb5
--- /dev/null
+++ b/packages/gpephone/gpe-applauncher/hotkeys.conf
@@ -0,0 +1,20 @@
+# We have two types of sections in here:
+# 'System' defines the bindings for buit-in functions
+# Each 'Application' section defines a binding of an application (desktop file)
+# to a key.
+
+[System]
+homescreen_show=k
+homescreen_toggle=F5
+system_controls=F6
+
+[Application0]
+key=F7
+application=abook
+hold=false
+
+[Application1]
+key=F8
+application=gpe-taskmanager
+hold=false
+
diff --git a/packages/gpephone/gpe-applauncher/softkeys.conf b/packages/gpephone/gpe-applauncher/softkeys.conf
new file mode 100644
index 0000000000..3e9a6c8882
--- /dev/null
+++ b/packages/gpephone/gpe-applauncher/softkeys.conf
@@ -0,0 +1,25 @@
+# This an example configuration file for GPE Application launcher softkeys.
+# All sizes and positions have pixels as units.
+# The align setting is a positive value from 0 (left) to 10 (right).
+
+[Key 1]
+label = left
+width = 100
+height = 22
+xpos = 0
+ypos = 1
+xpos_menu = 1
+ypos_menu = 1
+align = 1
+key = F3
+
+[Key 2]
+label = right
+width = 100
+height = 22
+xpos = 140
+ypos = 1
+xpos_menu = 1
+ypos_menu = 1
+align = 9
+key = F4
diff --git a/packages/gpephone/gpe-applauncher_0.11.bb b/packages/gpephone/gpe-applauncher_0.11.bb
index 396981659b..1efcd793e0 100644
--- a/packages/gpephone/gpe-applauncher_0.11.bb
+++ b/packages/gpephone/gpe-applauncher_0.11.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
DESCRIPTION = "A cellphone application launcher."
SECTION = "gpe"
PRIORITY = "optional"
-PR = "r0"
+PR = "r1"
SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
@@ -15,7 +15,8 @@ RDEPENDS_${PN} += "gpe-applauncher-config"
GPE_TARBALL_SUFFIX= "bz2"
inherit gpephone autotools
-SRC_URI += "file://hotkeys.conf"
+SRC_URI += "file://hotkeys.conf \
+ file://softkeys.conf"
EXTRA_OECONF = "--disable-gridlayout"
@@ -23,5 +24,6 @@ FILES_${PN} = '${datadir} ${bindir}'
FILES_gpe-applauncher-config = '${sysconfdir}/gpe/'
do_configure_append () {
- install ${WORKDIR}/hotkeys.conf ${S}
+ install ${WORKDIR}/hotkeys.conf ${S}
+ install ${WORKDIR}/softkeys.conf ${S}
}
diff --git a/packages/gpephone/gpe-applauncher_svn.bb b/packages/gpephone/gpe-applauncher_svn.bb
new file mode 100644
index 0000000000..4fe82877e3
--- /dev/null
+++ b/packages/gpephone/gpe-applauncher_svn.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cellphone application launcher."
+SECTION = "gpe"
+PRIORITY = "optional"
+PR = "r0"
+PV = "0.11+svn-${SRCREV}"
+
+SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
+DEFAULT_PREFERENCE = "-1"
+
+inherit gpephone autotools
+SRC_URI = "svn://projects.linuxtogo.org/svn/gpephone/trunk/source;module=${PN}"
+
+S = "${WORKDIR}/${PN}"
+
+
+PACKAGES += "gpe-applauncher-config"
+PACKAGE_ARCH_gpe-applauncher-config_fic-gta01 = "${MACHINE_ARCH}"
+
+DEPENDS = "gtk+ libgpewidget libgpephone libgpelaunch dbus-glib libsettings libxsettings-client"
+RDEPENDS_${PN} += "gpe-applauncher-config"
+
+
+SRC_URI += "file://hotkeys.conf \
+ file://softkeys.conf"
+
+EXTRA_OECONF = "--disable-gridlayout"
+
+FILES_${PN} = '${datadir} ${bindir}'
+FILES_gpe-applauncher-config = '${sysconfdir}/gpe/'
+
+do_configure_append () {
+ install ${WORKDIR}/hotkeys.conf ${S}
+ install ${WORKDIR}/softkeys.conf ${S}
+}