summaryrefslogtreecommitdiff
path: root/packages/gpe-gallery/files
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-26 09:07:19 +0000
committerKoen Kooi <koen@openembedded.org>2006-07-26 09:07:19 +0000
commitad6612ecfca7ded33e4c4bc8030eeb699629e73c (patch)
tree8213b55967d8dee1c1d81e83d900d7e5b8b545cc /packages/gpe-gallery/files
parent18d8807139c2c5de1c2364a7b20c22cd26d27cf9 (diff)
gpe-gallery: fix install badness and remove old versions
Diffstat (limited to 'packages/gpe-gallery/files')
-rw-r--r--packages/gpe-gallery/files/makefile-fix.patch11
-rw-r--r--packages/gpe-gallery/files/mcheck.patch24
2 files changed, 11 insertions, 24 deletions
diff --git a/packages/gpe-gallery/files/makefile-fix.patch b/packages/gpe-gallery/files/makefile-fix.patch
new file mode 100644
index 0000000000..ae4583573e
--- /dev/null
+++ b/packages/gpe-gallery/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile 2006-07-26 11:02:47.000000000 +0200
++++ gpe-gallery-0.97/Makefile 2006-07-26 11:05:07.584411000 +0200
+@@ -28,7 +28,7 @@
+ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all
+- install -Ds $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install -D -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -D -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ install -D -m 644 $(PACKAGE).applications $(DESTDIR)/$(PREFIX)/share/application-registry/$(PACKAGE).applications
+ mkdir -p $(DESTDIR)$(PREFIX)/share/applications
diff --git a/packages/gpe-gallery/files/mcheck.patch b/packages/gpe-gallery/files/mcheck.patch
deleted file mode 100644
index a2f2376eba..0000000000
--- a/packages/gpe-gallery/files/mcheck.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: gpe-gallery-0.95/main.c
-===================================================================
---- gpe-gallery-0.95.orig/main.c 2004-09-07 09:01:39.000000000 -0500
-+++ gpe-gallery-0.95/main.c 2004-11-18 15:55:18.856050416 -0600
-@@ -19,7 +19,9 @@
- #include <fcntl.h>
- #include <math.h>
- #include <time.h>
-+#ifdef USE_MCHECK
- #include <mcheck.h>
-+#endif
-
- #include <gtk/gtk.h>
- #include <gdk/gdk.h>
-@@ -1115,7 +1117,9 @@
- GdkBitmap *bmap;
- struct stat arg_stat;
-
-+#ifdef USE_MCHECK
- mtrace ();
-+#endif
-
- if (gpe_application_init (&argc, &argv) == FALSE)
- exit (1);