summaryrefslogtreecommitdiff
path: root/packages/gnutls/gnutls_1.4.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-05-23 16:31:13 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-23 16:31:13 +0000
commit665b18531d8ae69b3f1af008a3153c6298d3061a (patch)
tree10d2144e1ca11316252d8af46009c9d63af5fa3f /packages/gnutls/gnutls_1.4.0.bb
parentcb93e08f81bbce50ad035e4dc933ac84ef053c17 (diff)
gnutls: added 1.4.0 (current stable)
- we probably should drop 1.0.xx (old old stable) and 1.3.5 (development) versions
Diffstat (limited to 'packages/gnutls/gnutls_1.4.0.bb')
-rw-r--r--packages/gnutls/gnutls_1.4.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls_1.4.0.bb b/packages/gnutls/gnutls_1.4.0.bb
new file mode 100644
index 0000000000..3c48bc95ff
--- /dev/null
+++ b/packages/gnutls/gnutls_1.4.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt lzo"
+MAINTAINER = "Eric Shattow <lucent@gmail.com>"
+HOMEPAGE = "http://www.gnu.org/software/gnutls/"
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2 \
+ file://gnutls-openssl.patch;patch=1 \
+ file://gnutls-texinfo-euro.patch;patch=1"
+
+inherit autotools binconfig
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv \
+ ${bindir}/gnutls-cli \
+ ${bindir}/srptool \
+ ${bindir}/certtool \
+ ${bindir}/gnutls-srpcrypt \
+ ${bindir}/psktool"
+
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+