summaryrefslogtreecommitdiff
path: root/packages/gnutls/gnutls_1.3.4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-02 17:54:35 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-02 17:54:35 +0000
commit40ce95ca64d662c16cec3d1efabc966dda5a2610 (patch)
treec5687492fbbc7f7e46b8db8448b1da640fef9955 /packages/gnutls/gnutls_1.3.4.bb
parent858ca7bc53e7c03eac036217486e87e36eb1e3e6 (diff)
parent966f3a94af2c83ffd2c634171fbe04917731b6f9 (diff)
explicit_merge of '601faaded8a6427e29dc8dc43433fe9be662c96c'
and 'a67386ccbaf4538441ab5d8769e018207ab0c744' using ancestor '9c1b32d8825be71ddfdcbe3ddfa31b4cc8bb2aa0' to branch 'org.openembedded.dev'
Diffstat (limited to 'packages/gnutls/gnutls_1.3.4.bb')
-rw-r--r--packages/gnutls/gnutls_1.3.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls_1.3.4.bb b/packages/gnutls/gnutls_1.3.4.bb
new file mode 100644
index 0000000000..0c02f4bd0f
--- /dev/null
+++ b/packages/gnutls/gnutls_1.3.4.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt lzo"
+
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/devel/gnutls-${PV}.tar.bz2"
+
+inherit autotools
+inherit binconfig
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
+ ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+