summaryrefslogtreecommitdiff
path: root/packages/gnuradio/gnuradio_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-07-27 12:19:58 +0000
committerKoen Kooi <koen@openembedded.org>2007-07-27 12:19:58 +0000
commit40d3de312d7892436cb00b8bdb77eda0746564b1 (patch)
tree7e70fb76fb781b718754412cc16de94633f30121 /packages/gnuradio/gnuradio_svn.bb
parent12e9dd26696aaa5b1ffbc48b8d8eff9afc2c6102 (diff)
gnuradio: fixes
* update PV to 3.0.4 * patch out doc generation for gr-trellis subdir * packages all libs seperately * package python files as well
Diffstat (limited to 'packages/gnuradio/gnuradio_svn.bb')
-rw-r--r--packages/gnuradio/gnuradio_svn.bb20
1 files changed, 17 insertions, 3 deletions
diff --git a/packages/gnuradio/gnuradio_svn.bb b/packages/gnuradio/gnuradio_svn.bb
index f3d4873e5a..0eed243618 100644
--- a/packages/gnuradio/gnuradio_svn.bb
+++ b/packages/gnuradio/gnuradio_svn.bb
@@ -3,13 +3,16 @@ SECTION = "apps"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "fftwf python boost cppunit sdcc-native swig swig-native"
-RDEPENDS = "libfftwf python swig"
-PV = "0.0+svn${SRCDATE}"
+RDEPENDS_${PN} = "python-core swig"
+
+PV = "3.0.4+svn${SRCDATE}"
PR = "r0"
-SRC_URI = "svn://gnuradio.org/svn/gnuradio;module=trunk;proto=http"
+SRC_URI = "svn://gnuradio.org/svn/gnuradio;module=trunk;proto=http \
+ file://no-trellis-doc.patch;patch=1 \
+ "
inherit autotools pkgconfig
@@ -22,3 +25,14 @@ export HOST_SYS := "${HOST_SYS}"
EXTRA_OECONF = "--disable-gr-atsc --disable-gr-video-sdl"
+PACKAGES =+ "libgromnithread libgnuradio-core libgnuradio-core-qa"
+FILES_libgnuradio-core = "${libdir}/libgnuradio-core.so.*"
+FILES_libgnuradio-core-qa = "${libdir}/libgnuradio-core-qa.so.*"
+FILES_libgromnithread = "${libdir}/libgromnithread.so*"
+
+FILES_${PN} += "${libdir}/python*/site-packages/gnuradio/*"
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/gnuradio/.debug \
+ ${libdir}/python*/site-packages/gnuradio/*/.debug \
+ "
+
+