summaryrefslogtreecommitdiff
path: root/packages/gnuradio/gnuradio.inc
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2008-10-06 20:18:43 +0000
committerPhilip Balister <philip@balister.org>2008-10-06 20:18:43 +0000
commite707c438cc8e36bb255fc80fbe2ba811a35d02ff (patch)
tree6eadfee162474f29de73c40f1b1a6face04813cc /packages/gnuradio/gnuradio.inc
parent568af3b5b1ef8d5c3b0a140acc5730cfe785d34a (diff)
gnuradio_svn.bb : Commit basic support for GNU Radio trunk
* You will need to enable boost-1.36.0 * This does not build USRP code, yet.
Diffstat (limited to 'packages/gnuradio/gnuradio.inc')
-rw-r--r--packages/gnuradio/gnuradio.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/gnuradio/gnuradio.inc b/packages/gnuradio/gnuradio.inc
index 9cb936a105..a084b1cae0 100644
--- a/packages/gnuradio/gnuradio.inc
+++ b/packages/gnuradio/gnuradio.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "GNU Radio"
SECTION = "apps"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = " guile-native fftwf python libusb-compat virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native"
+DEPENDS = " guile-native fftwf python libusb virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native"
RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs python-lang python-textutils"
RDEPENDS_gnuradio-usrp = "python-core"
@@ -22,6 +22,7 @@ EXTRA_OECONF = " \
--enable-gr-audio-oss \
--enable-mblock \
--disable-html-docs \
+ PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/python2.5 \
"
do_configure_append() {
@@ -55,7 +56,7 @@ FILES_${PN}-dbg += "${libdir}/python*/site-packages/gnuradio/.debug \
"
FILES_gnuradio-usrp = "${libdir}/python*/site-packages/usrpm/* \
- ${datadir}/usrp"
+ ${datadir}/usrp/*/*"
FILES_gnuradio-usrp-dbg = "${libdir}/python*/site-packages/usrpm/.debug"